new package: fatsort

This commit is contained in:
Tee KOBAYASHI 2022-12-02 01:52:44 +09:00 committed by xtkoba
parent 92560a5530
commit 1ffd21e73b
2 changed files with 28 additions and 0 deletions

18
packages/fatsort/build.sh Normal file
View File

@ -0,0 +1,18 @@
TERMUX_PKG_HOMEPAGE=https://fatsort.sourceforge.io/
TERMUX_PKG_DESCRIPTION="A C utility that sorts FAT12, FAT16, FAT32 and exFAT partitions"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.6.4.625
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/fatsort/fatsort-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=9a6f89a0640bb782d82ff23a780c9f0aec3dfbe4682c0a8eda157e0810642ead
TERMUX_PKG_DEPENDS="libiconv"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_MAKE_ARGS="
MANDIR=$TERMUX_PREFIX/share/man/man1
SBINDIR=$TERMUX_PREFIX/bin
"
termux_step_pre_configure() {
CFLAGS+=" $CPPFLAGS"
LDFLAGS+=" -liconv"
}

View File

@ -0,0 +1,10 @@
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,5 +1,5 @@
-CC=gcc
-LD=gcc
+CC?=gcc
+LD?=gcc
ifdef DEBUG
CFLAGS += -g -DDEBUG=$(DEBUG) -fstack-protector-all