libprotozero: Bump to 1.7.1

This commit is contained in:
Tee KOBAYASHI 2022-11-16 17:18:39 +09:00 committed by xtkoba
parent 8bd6194bbf
commit 500dbc8392
2 changed files with 2 additions and 37 deletions

View File

@ -3,9 +3,8 @@ TERMUX_PKG_DESCRIPTION="Minimalistic protocol buffer decoder and encoder in C++"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_LICENSE_FILE="LICENSE.md"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.7.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=1.7.1
TERMUX_PKG_SRCURL=https://github.com/mapbox/protozero/archive/v${TERMUX_PKG_VERSION}.zip
TERMUX_PKG_SHA256=b1dc381cdf75bc6531f1fee13c76a72bae432660984b3316f104c74c355766fd
TERMUX_PKG_SHA256=eb45bbad4c5e881e55f0d2c5175cc4a5068e9fff613a7c37479b0b94f94a7392
TERMUX_PKG_GROUPS="science"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-DPYBIND11_FINDPYTHON=OFF"

View File

@ -1,34 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9702d6..2b870c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
#-----------------------------------------------------------------------------
+option(BUILD_TESTING "Build the tests" ON)
option(WERROR "Add -Werror flag to build (turns warnings into errors)" ON)
if(MSVC)
@@ -71,7 +72,9 @@ if(CLANG_TIDY)
${CMAKE_SOURCE_DIR}/test/unit/*.cpp
${CMAKE_SOURCE_DIR}/tools/*.cpp
)
- add_dependencies(clang-tidy writer_tests)
+ if(BUILD_TESTING)
+ add_dependencies(clang-tidy writer_tests)
+ endif()
else()
message(STATUS "Looking for clang-tidy - not found")
message(STATUS " Build target 'clang-tidy' will not be available.")
@@ -140,7 +143,8 @@ add_subdirectory(doc)
add_subdirectory(tools)
-add_subdirectory(test)
-
+if(BUILD_TESTING)
+ add_subdirectory(test)
+endif()
#-----------------------------------------------------------------------------