crawl: Bump to 0.30-a0

This commit is contained in:
Tee KOBAYASHI 2022-11-20 21:02:21 +09:00 committed by xtkoba
parent 5a5b700fe1
commit 95a9013884
4 changed files with 58 additions and 12 deletions

View File

@ -1,6 +1,6 @@
--- a/crawl-ref/source/Makefile
+++ b/crawl-ref/source/Makefile
@@ -165,8 +165,8 @@ endif
@@ -165,12 +165,12 @@
#
AR = ar
RANLIB = ranlib
@ -11,6 +11,11 @@
RM = rm -f
COPY = cp
COPY_R = cp -r
-STRIP = strip -s
+STRIP = :
SED = sed
WINDRES = windres
CHMOD = chmod 2>/dev/null
@@ -474,10 +474,10 @@ ifdef MACOSX_MIN_VERSION
CFLAGS_ARCH += -mmacosx-version-min=$(MACOSX_MIN_VERSION)
CFLAGS_DEPCC_ARCH += -mmacosx-version-min=$(MACOSX_MIN_VERSION)

View File

@ -2,20 +2,28 @@ TERMUX_PKG_HOMEPAGE=https://crawl.develz.org/
TERMUX_PKG_DESCRIPTION="Roguelike adventure through dungeons filled with dangerous monsters"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_SRCURL=https://github.com/crawl/crawl.git
TERMUX_PKG_VERSION=0.29-a0
TERMUX_PKG_GIT_BRANCH=0.29-a0
TERMUX_PKG_DEPENDS="libc++, ncurses, zlib"
TERMUX_PKG_VERSION=0.30-a0
TERMUX_PKG_SRCURL=https://github.com/crawl/crawl/archive/refs/tags/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1f2c2d30f5cbde71da551ccc75bbc803ac01dd2507f66ecb19911dc81c49a59b
TERMUX_PKG_DEPENDS="libc++, liblua51, libsqlite, ncurses, zlib"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_MAKE_ARGS="
FHS=yes
--debug
"
termux_step_post_get_source() {
echo "Applying util-gen_ver.pl.diff"
sed "s|@VERSION@|${TERMUX_PKG_VERSION#*:}|g" \
$TERMUX_PKG_BUILDER_DIR/util-gen_ver.pl.diff \
| patch --silent -p1
sed -i 's|\(__ANDROID_\)_|\1_NO_TERMUX__|g' crawl-ref/source/syscalls.cc
}
termux_step_pre_configure() {
export CROSSHOST="$TERMUX_HOST_PLATFORM"
export TERMUX_PKG_BUILDDIR="$TERMUX_PKG_SRCDIR/crawl-ref/source"
TERMUX_PKG_SRCDIR+="/crawl-ref/source"
TERMUX_PKG_BUILDDIR=$TERMUX_PKG_SRCDIR
export INCLUDES_L="-I$TERMUX_PREFIX/include"
export DEFINES_L="-DHAVE_STAT"
export LIBS="-llog -Wl,--rpath=$TERMUX_PREFIX/lib"
}
termux_step_post_configure() {
sed -i 's,#ifdef __ANDROID__,#ifdef __NO_THANKS__,g' "$TERMUX_PKG_BUILDDIR/syscalls.cc"
}

View File

@ -0,0 +1,22 @@
--- a/crawl-ref/source/AppHdr.h
+++ b/crawl-ref/source/AppHdr.h
@@ -144,7 +144,7 @@
#ifdef TARGET_OS_MACOSX
# define GDB_PATH "/usr/local/bin/gdb"
#else
-# define GDB_PATH "/usr/bin/gdb"
+# define GDB_PATH "@TERMUX_PREFIX@/bin/gdb"
#endif
--- a/crawl-ref/source/crash.cc
+++ b/crawl-ref/source/crash.cc
@@ -428,7 +428,7 @@
"-ex", "bt full",
0
};
- execv("/usr/bin/nice", (char* const*)argv);
+ execv("@TERMUX_PREFIX@/bin/nice", (char* const*)argv);
printf("Failed to start gdb: %s\n", strerror(errno));
fflush(stdout);
_exit(0);

View File

@ -0,0 +1,11 @@
--- a/crawl-ref/source/util/gen_ver.pl
+++ b/crawl-ref/source/util/gen_ver.pl
@@ -20,7 +20,7 @@
#
# Source tarbells distributed as part of a release include this file already
# generated with the release version.
-$_ = `git describe --tags $mergebase 2> /dev/null`
+$_ = "@VERSION@"
|| (open(IN, "<", "$scriptpath/release_ver") ? <IN>
: die "Can't get version information: `git describe --tags` failed (no git, no repository, or shallow clone), and $scriptpath/release_ver doesn't exist.\n")
or die "couldn't get the version information\n";