glib: don't use hasmntopt

This commit is contained in:
Yaksh Bariya 2021-12-31 11:29:19 +05:30 committed by Leonid Pliushch
parent ef8dd69f85
commit a4a0fa97af
3 changed files with 12 additions and 19 deletions

View File

@ -1,15 +0,0 @@
--- ./usr/include/mntent.h.orig 2021-12-10 16:17:07.041722648 +0530
+++ ./usr/include/mntent.h 2021-12-10 16:17:41.171722635 +0530
@@ -70,9 +70,9 @@
#endif /* __ANDROID_API__ >= 21 */
-#if __ANDROID_API__ >= 26
-char* hasmntopt(const struct mntent* __entry, const char* __option) __INTRODUCED_IN(26);
-#endif /* __ANDROID_API__ >= 26 */
+#if __ANDROID_API__ >= 21
+char* hasmntopt(const struct mntent* __entry, const char* __option) __INTRODUCED_IN(21);
+#endif /* __ANDROID_API__ >= 21 */
__END_DECLS

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="Library providing core building blocks for libraries and
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.70.2
TERMUX_PKG_REVISION=2
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/gnome/sources/glib/${TERMUX_PKG_VERSION:0:4}/glib-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=0551459c85cd3da3d58ddc9016fd28be5af503f5e1615a71ba5b512ac945806f
TERMUX_PKG_DEPENDS="libffi, libiconv, pcre, libandroid-support, zlib"

View File

@ -1,5 +1,5 @@
--- ./meson.build.orig 2021-12-10 06:56:41.609999906 +0530
+++ ./meson.build 2021-12-11 17:23:07.992103796 +0530
--- ./meson.build.orig 2021-12-03 15:29:15.000000000 +0530
+++ ./meson.build 2021-12-31 12:02:24.204785929 +0530
@@ -443,7 +443,6 @@
# A zero-length format string shouldn't be considered an issue.
'-Wno-format-zero-length',
@ -8,7 +8,15 @@
'-Werror=implicit-function-declaration',
'-Werror=init-self',
'-Werror=missing-include-dirs',
@@ -2047,9 +2046,8 @@
@@ -511,7 +510,6 @@
'getresuid',
'getvfsstat',
'gmtime_r',
- 'hasmntopt',
'inotify_init1',
'issetugid',
'kevent',
@@ -2047,9 +2045,8 @@
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []