source/overlays.nix

24 lines
626 B
Nix

let
overlay = self: super: {
# Create symlink named "sr-foo" for each surfraw module (elvi).
# Unlike "sr foo" they are nicely auto-completed without
# programmable completion interface.
surfraw = super.surfraw.overrideAttrs (_: {
postInstall = ''
for elvi in $out/lib/surfraw/* ; do
name=$(basename $elvi)
ln -sf ../lib/surfraw/$name $out/bin/sr-$name
done
'';
});
python3 = super.python3.override {
packageOverrides = import ./config/flake/universe/python3/overrides.nix;
};
};
in
[
overlay
(import ./config/flake/default.nix)
]