nix_templates/flake.nix

20 lines
429 B
Nix

{
description = "My Flake templates";
inputs = {
official-templates.url = github:NixOS/templates;
};
outputs = { official-templates, ... }: rec {
templates = {
talk_org_revealjs = {
path = ./talk_org_revealjs;
description = "A template for a talk built with org-mode, Pandoc and reveal.js";
};
} // official-templates.templates;
defaultTemplate = templates.trivial;
};
}