the-powder-toy: Bump to 97.0.352

This commit is contained in:
Tee KOBAYASHI 2023-01-09 20:06:37 +09:00 committed by xtkoba
parent 2f64adf172
commit 0b8e501b3a
3 changed files with 25 additions and 17 deletions

View File

@ -38,19 +38,6 @@
std::ofstream stampsStream;
--- a/src/Config.template.h
+++ b/src/Config.template.h
@@ -73,11 +73,7 @@
#define IDENT_PLATFORM "WIN32"
#endif
#elif defined(LIN)
-#if defined(_64BIT)
-#define IDENT_PLATFORM "LIN64"
-#else
-#define IDENT_PLATFORM "LIN32"
-#endif
+#define IDENT_PLATFORM "TERMUX"
#elif defined(MACOSX)
#define IDENT_PLATFORM "MACOSX"
#else
@@ -101,11 +97,11 @@
#define STATICSCHEME "https://"
#define ENFORCE_HTTPS
@ -105,7 +92,7 @@
- if (!cwd.empty())
- Platform::OpenURI(cwd);
- else
- fprintf(stderr, "cannot open data folder: getcwd(...) failed\n");
- fprintf(stderr, "cannot open data folder: Platform::GetCwd(...) failed\n");
+ Platform::OpenURI("@TERMUX_HOME@/.powdertoy");
} });
scrollPanel->AddChild(dataFolderButton);

View File

@ -0,0 +1,19 @@
--- a/meson.build
+++ b/meson.build
@@ -46,7 +46,7 @@
elif host_platform in [ 'darwin' ]
host_libc = 'macos'
elif host_platform in [ 'android' ]
- host_platform = 'android'
+ host_platform = 'linux'
host_libc = 'bionic'
else
host_libc = 'gnu'
@@ -315,6 +315,7 @@
else
ident_platform = 'UNKNOWN'
endif
+ident_platform = 'TERMUX'
app_exe = get_option('app_exe')
app_id = get_option('app_id')

View File

@ -2,12 +2,14 @@ TERMUX_PKG_HOMEPAGE=https://powdertoy.co.uk/
TERMUX_PKG_DESCRIPTION="The Powder Toy is a free physics sandbox game"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=96.2.350
TERMUX_PKG_VERSION=97.0.352
TERMUX_PKG_SRCURL=https://github.com/ThePowderToy/The-Powder-Toy/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=d95cbadee22632687661e8fc488bd64405d81c0dca737e16420f26e93ea5bf58
TERMUX_PKG_DEPENDS="fftw, libc++, libcurl, libluajit, sdl2, zlib"
TERMUX_PKG_SHA256=3ab27e1b9a84db1da7342e61232ad5be981ca1ddf001c4924fd08b61cc8d287a
TERMUX_PKG_DEPENDS="fftw, jsoncpp, libbz2, libc++, libcurl, libluajit, libpng, sdl2"
TERMUX_PKG_GROUPS="games"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dworkaround_elusive_bzip2_lib_dir=$TERMUX_PREFIX/lib
-Dworkaround_elusive_bzip2_include_dir=$TERMUX_PREFIX/include
-Db_pie=true
"