mympd: Bump to 10.1.6

This commit is contained in:
Tee KOBAYASHI 2022-12-12 12:22:49 +09:00 committed by xtkoba
parent daf3d936ca
commit 0c531d2101
2 changed files with 22 additions and 4 deletions

View File

@ -1,6 +1,14 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,7 +125,6 @@
@@ -71,7 +71,6 @@
# cmake modules
include(CheckCCompilerFlag)
include(CheckCSourceCompiles)
-include(CheckIPOSupported)
include(GNUInstallDirs)
# custom cmake modules
@@ -123,7 +122,6 @@
# required dependencies
find_package(Threads REQUIRED)
find_package(PCRE2 REQUIRED)
@ -8,7 +16,7 @@
# optional dependencies
if(MYMPD_ENABLE_SSL)
@@ -229,7 +228,7 @@
@@ -227,7 +225,7 @@
configure_file(contrib/initscripts/mympd.sysVinit.in contrib/initscripts/mympd.sysVinit @ONLY)
configure_file(contrib/initscripts/mympd.openrc.in contrib/initscripts/mympd.openrc @ONLY)
@ -17,3 +25,13 @@
# set strict global compile flags
add_compile_options(
"-fdata-sections"
@@ -317,8 +315,7 @@
add_compile_options("-g")
endif()
# IPO/LTO support
- check_ipo_supported()
- set(CMAKE_INTERPROCEDURAL_OPTIMIZATION TRUE)
+ set(CMAKE_INTERPROCEDURAL_OPTIMIZATION FALSE)
elseif(CMAKE_BUILD_TYPE STREQUAL "Debug")
add_compile_options(
"-ggdb"

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://jcorporation.github.io/myMPD/
TERMUX_PKG_DESCRIPTION="A standalone and lightweight web-based MPD client"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=10.1.3
TERMUX_PKG_VERSION=10.1.6
TERMUX_PKG_SRCURL=https://github.com/jcorporation/myMPD/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=2c289666a7bace1c5cf66fef0979f008761482c777cf9c7e6443db6cfdead48e
TERMUX_PKG_SHA256=75d347dcbfabf17c516780c8cbbf7e5494423ba41693d1f7d567549d29990ddd
TERMUX_PKG_DEPENDS="libflac, libid3tag, openssl, pcre2, resolv-conf"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DMATH_LIB=m