neovim: update tree-sitter dependency

Otherwise tree-sitter build fails due to that libmpack-lua cannot be
downloaded.
This commit is contained in:
Henrik Grimler 2022-02-08 01:18:06 +01:00
parent 5d797d416f
commit 0d309d5745
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
2 changed files with 14 additions and 1 deletions

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="Ambitious Vim-fork focused on extensibility and agility
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.6.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://github.com/neovim/neovim/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=dd882c21a52e5999f656cae3f336b5fc702d52addd4d9b5cd3dc39cfff35e864
TERMUX_PKG_AUTO_UPDATE=true

View File

@ -0,0 +1,13 @@
--- ../CMakeLists.txt.orig 2022-02-08 00:13:34.710245380 +0000
+++ ./third-party/CMakeLists.txt 2022-02-08 00:13:21.483520494 +0000
@@ -203,8 +203,8 @@
set(TREESITTER_C_URL https://github.com/tree-sitter/tree-sitter-c/archive/v0.20.1.tar.gz)
set(TREESITTER_C_SHA256 ffcc2ef0eded59ad1acec9aec4f9b0c7dd209fc1a85d85f8b0e81298e3dddcc2)
-set(TREESITTER_URL https://github.com/tree-sitter/tree-sitter/archive/v0.20.1.tar.gz)
-set(TREESITTER_SHA256 12a3f7206af3028dbe8a0de50d8ebd6d7010bf762db918acae76fc7585f1258d)
+set(TREESITTER_URL https://github.com/tree-sitter/tree-sitter/archive/v0.20.3.tar.gz)
+set(TREESITTER_SHA256 ab52fe93e0c658cff656b9d10d67cdd29084247052964eba13ed6f0e9fa3bd36)
if(USE_BUNDLED_UNIBILIUM)
include(BuildUnibilium)