qemu: Bump to 7.1.0

This commit is contained in:
Tee KOBAYASHI 2022-09-21 05:44:39 +09:00 committed by buttaface
parent ec31679ef4
commit 1083a2a433
8 changed files with 64 additions and 108 deletions

View File

@ -49,18 +49,17 @@ diff -uNr qemu-6.1.0/hw/usb/ccid-card-emulated.c qemu-6.1.0.mod/hw/usb/ccid-card
#define CERTIFICATES_ARGS_TEMPLATE\
"db=\"%s\" use_hw=no soft=(,Virtual Reader,CAC,,%s,%s,%s)"
diff -uNr qemu-6.1.0/linux-user/syscall.c qemu-6.1.0.mod/linux-user/syscall.c
--- qemu-6.1.0/linux-user/syscall.c 2021-08-24 20:35:41.000000000 +0300
+++ qemu-6.1.0.mod/linux-user/syscall.c 2021-08-25 15:22:26.477952648 +0300
@@ -8018,7 +8018,7 @@
/* create temporary file to map stat to */
tmpdir = getenv("TMPDIR");
if (!tmpdir)
- tmpdir = "/tmp";
+ tmpdir = "@TERMUX_PREFIX@/tmp";
snprintf(filename, sizeof(filename), "%s/qemu-open.XXXXXX", tmpdir);
fd = mkstemp(filename);
if (fd < 0) {
--- a/linux-user/syscall.c
+++ b/linux-user/syscall.c
@@ -8363,7 +8363,7 @@ static int do_openat(CPUArchState *cpu_e
/* create temporary file to map stat to */
tmpdir = getenv("TMPDIR");
if (!tmpdir)
- tmpdir = "/tmp";
+ tmpdir = "@TERMUX_PREFIX@/tmp";
snprintf(filename, sizeof(filename), "%s/qemu-open.XXXXXX", tmpdir);
fd = mkstemp(filename);
if (fd < 0) {
diff -uNr qemu-6.1.0/migration/exec.c qemu-6.1.0.mod/migration/exec.c
--- qemu-6.1.0/migration/exec.c 2021-08-24 20:35:41.000000000 +0300
+++ qemu-6.1.0.mod/migration/exec.c 2021-08-25 15:22:26.477952648 +0300

View File

@ -12,48 +12,17 @@ diff -uNr qemu-5.2.0/include/qapi/util.h qemu-5.2.0.mod/include/qapi/util.h
typedef struct QEnumLookup {
const char *const *array;
int size;
diff -uNr qemu-5.2.0/meson.build qemu-5.2.0.mod/meson.build
--- qemu-5.2.0/meson.build 2020-12-08 18:59:44.000000000 +0200
+++ qemu-5.2.0.mod/meson.build 2020-12-09 17:18:04.165911853 +0200
@@ -185,38 +185,6 @@
--- a/meson.build
+++ b/meson.build
@@ -201,7 +201,7 @@
# Specify linker-script with add_project_link_arguments so that it is not placed
# within a linker --start-group/--end-group pair
-if get_option('fuzzing')
- add_project_link_arguments(['-Wl,-T,',
- (meson.current_source_dir() / 'tests/qtest/fuzz/fork_fuzz.ld')],
- native: false, language: ['c', 'cpp', 'objc'])
-
- # Specify a filter to only instrument code that is directly related to
- # virtual-devices.
- configure_file(output: 'instrumentation-filter',
- input: 'scripts/oss-fuzz/instrumentation-filter-template',
- copy: true)
- add_global_arguments(
- cc.get_supported_arguments('-fsanitize-coverage-allowlist=instrumentation-filter'),
- native: false, language: ['c', 'cpp', 'objc'])
-
- if get_option('fuzzing_engine') == ''
- # Add CFLAGS to tell clang to add fuzzer-related instrumentation to all the
- # compiled code. To build non-fuzzer binaries with --enable-fuzzing, link
- # everything with fsanitize=fuzzer-no-link. Otherwise, the linker will be
- # unable to bind the fuzzer-related callbacks added by instrumentation.
- add_global_arguments('-fsanitize=fuzzer-no-link',
- native: false, language: ['c', 'cpp', 'objc'])
- add_global_link_arguments('-fsanitize=fuzzer-no-link',
- native: false, language: ['c', 'cpp', 'objc'])
- # For the actual fuzzer binaries, we need to link against the libfuzzer
- # library. They need to be configurable, to support OSS-Fuzz
- fuzz_exe_ldflags = ['-fsanitize=fuzzer']
- else
- # LIB_FUZZING_ENGINE was set; assume we are running on OSS-Fuzz, and
- # the needed CFLAGS have already been provided
- fuzz_exe_ldflags = get_option('fuzzing_engine').split()
- endif
-endif
add_global_arguments(qemu_cflags, native: false, language: ['c'])
add_global_arguments(qemu_cxxflags, native: false, language: ['cpp'])
+if false
add_project_link_arguments(['-Wl,-T,',
(meson.current_source_dir() / 'tests/qtest/fuzz/fork_fuzz.ld')],
native: false, language: ['c', 'cpp', 'objc'])
@@ -1575,8 +1575,8 @@
specific_ss.add_all(when: 'CONFIG_LINUX_USER', if_true: linux_user_ss)

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.qemu.org
TERMUX_PKG_DESCRIPTION="A generic and open source machine emulator and virtualizer (headless)"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1:7.0.0
TERMUX_PKG_REVISION=4
TERMUX_PKG_VERSION=1:7.1.0
TERMUX_PKG_SRCURL=https://download.qemu.org/qemu-${TERMUX_PKG_VERSION:2}.tar.xz
TERMUX_PKG_SHA256=f6b375c7951f728402798b0baabb2d86478ca53d44cedbefabbe1c46bf46f839
TERMUX_PKG_SHA256=a0634e536bded57cf38ec8a751adb124b89c776fe0846f21ab6c6728f1cbbbe6
TERMUX_PKG_DEPENDS="glib, libbz2, libc++, libcurl, libgnutls, libiconv, libjpeg-turbo, liblzo, libnettle, libnfs, libpixman, libpng, libspice-server, libssh, libusb, libusbredir, ncurses, pulseaudio, qemu-common, resolv-conf, zlib, zstd"
# Required by configuration script, but I can't find any binary that uses it.
@ -78,7 +77,7 @@ termux_step_configure() {
--enable-vnc \
--disable-vnc-sasl \
--enable-vnc-jpeg \
--enable-vnc-png \
--enable-png \
--disable-xen \
--disable-xen-pci-passthrough \
--enable-virtfs \

View File

@ -0,0 +1,11 @@
--- a/linux-user/mmap.c
+++ b/linux-user/mmap.c
@@ -838,7 +838,7 @@
static bool can_passthrough_madv_dontneed(abi_ulong start, abi_ulong end)
{
- ulong addr;
+ abi_ulong addr;
if ((start | end) & ~qemu_host_page_mask) {
return false;

View File

@ -49,18 +49,17 @@ diff -uNr qemu-6.1.0/hw/usb/ccid-card-emulated.c qemu-6.1.0.mod/hw/usb/ccid-card
#define CERTIFICATES_ARGS_TEMPLATE\
"db=\"%s\" use_hw=no soft=(,Virtual Reader,CAC,,%s,%s,%s)"
diff -uNr qemu-6.1.0/linux-user/syscall.c qemu-6.1.0.mod/linux-user/syscall.c
--- qemu-6.1.0/linux-user/syscall.c 2021-08-24 20:35:41.000000000 +0300
+++ qemu-6.1.0.mod/linux-user/syscall.c 2021-08-25 15:22:26.477952648 +0300
@@ -8018,7 +8018,7 @@
/* create temporary file to map stat to */
tmpdir = getenv("TMPDIR");
if (!tmpdir)
- tmpdir = "/tmp";
+ tmpdir = "@TERMUX_PREFIX@/tmp";
snprintf(filename, sizeof(filename), "%s/qemu-open.XXXXXX", tmpdir);
fd = mkstemp(filename);
if (fd < 0) {
--- a/linux-user/syscall.c
+++ b/linux-user/syscall.c
@@ -8363,7 +8363,7 @@ static int do_openat(CPUArchState *cpu_e
/* create temporary file to map stat to */
tmpdir = getenv("TMPDIR");
if (!tmpdir)
- tmpdir = "/tmp";
+ tmpdir = "@TERMUX_PREFIX@/tmp";
snprintf(filename, sizeof(filename), "%s/qemu-open.XXXXXX", tmpdir);
fd = mkstemp(filename);
if (fd < 0) {
diff -uNr qemu-6.1.0/migration/exec.c qemu-6.1.0.mod/migration/exec.c
--- qemu-6.1.0/migration/exec.c 2021-08-24 20:35:41.000000000 +0300
+++ qemu-6.1.0.mod/migration/exec.c 2021-08-25 15:22:26.477952648 +0300

View File

@ -12,48 +12,17 @@ diff -uNr qemu-5.2.0/include/qapi/util.h qemu-5.2.0.mod/include/qapi/util.h
typedef struct QEnumLookup {
const char *const *array;
int size;
diff -uNr qemu-5.2.0/meson.build qemu-5.2.0.mod/meson.build
--- qemu-5.2.0/meson.build 2020-12-08 18:59:44.000000000 +0200
+++ qemu-5.2.0.mod/meson.build 2020-12-09 17:18:04.165911853 +0200
@@ -185,38 +185,6 @@
--- a/meson.build
+++ b/meson.build
@@ -201,7 +201,7 @@
# Specify linker-script with add_project_link_arguments so that it is not placed
# within a linker --start-group/--end-group pair
-if get_option('fuzzing')
- add_project_link_arguments(['-Wl,-T,',
- (meson.current_source_dir() / 'tests/qtest/fuzz/fork_fuzz.ld')],
- native: false, language: ['c', 'cpp', 'objc'])
-
- # Specify a filter to only instrument code that is directly related to
- # virtual-devices.
- configure_file(output: 'instrumentation-filter',
- input: 'scripts/oss-fuzz/instrumentation-filter-template',
- copy: true)
- add_global_arguments(
- cc.get_supported_arguments('-fsanitize-coverage-allowlist=instrumentation-filter'),
- native: false, language: ['c', 'cpp', 'objc'])
-
- if get_option('fuzzing_engine') == ''
- # Add CFLAGS to tell clang to add fuzzer-related instrumentation to all the
- # compiled code. To build non-fuzzer binaries with --enable-fuzzing, link
- # everything with fsanitize=fuzzer-no-link. Otherwise, the linker will be
- # unable to bind the fuzzer-related callbacks added by instrumentation.
- add_global_arguments('-fsanitize=fuzzer-no-link',
- native: false, language: ['c', 'cpp', 'objc'])
- add_global_link_arguments('-fsanitize=fuzzer-no-link',
- native: false, language: ['c', 'cpp', 'objc'])
- # For the actual fuzzer binaries, we need to link against the libfuzzer
- # library. They need to be configurable, to support OSS-Fuzz
- fuzz_exe_ldflags = ['-fsanitize=fuzzer']
- else
- # LIB_FUZZING_ENGINE was set; assume we are running on OSS-Fuzz, and
- # the needed CFLAGS have already been provided
- fuzz_exe_ldflags = get_option('fuzzing_engine').split()
- endif
-endif
add_global_arguments(qemu_cflags, native: false, language: ['c'])
add_global_arguments(qemu_cxxflags, native: false, language: ['cpp'])
+if false
add_project_link_arguments(['-Wl,-T,',
(meson.current_source_dir() / 'tests/qtest/fuzz/fork_fuzz.ld')],
native: false, language: ['c', 'cpp', 'objc'])
@@ -1575,8 +1575,8 @@
specific_ss.add_all(when: 'CONFIG_LINUX_USER', if_true: linux_user_ss)

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.qemu.org
TERMUX_PKG_DESCRIPTION="A generic and open source machine emulator and virtualizer"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1:7.0.0
TERMUX_PKG_REVISION=4
TERMUX_PKG_VERSION=1:7.1.0
TERMUX_PKG_SRCURL=https://download.qemu.org/qemu-${TERMUX_PKG_VERSION:2}.tar.xz
TERMUX_PKG_SHA256=f6b375c7951f728402798b0baabb2d86478ca53d44cedbefabbe1c46bf46f839
TERMUX_PKG_SHA256=a0634e536bded57cf38ec8a751adb124b89c776fe0846f21ab6c6728f1cbbbe6
TERMUX_PKG_DEPENDS="glib, gtk3, libbz2, libc++, libcurl, libgnutls, libiconv, libjpeg-turbo, liblzo, libnettle, libnfs, libpixman, libpng, libspice-server, libssh, libusb, libusbredir, libx11, ncurses, pulseaudio, qemu-common, resolv-conf, sdl2, sdl2-image, zlib, zstd"
# Required by configuration script, but I can't find any binary that uses it.
@ -92,7 +91,7 @@ termux_step_configure() {
--enable-vnc \
--disable-vnc-sasl \
--enable-vnc-jpeg \
--enable-vnc-png \
--enable-png \
--disable-xen \
--disable-xen-pci-passthrough \
--enable-virtfs \

View File

@ -0,0 +1,11 @@
--- a/linux-user/mmap.c
+++ b/linux-user/mmap.c
@@ -838,7 +838,7 @@
static bool can_passthrough_madv_dontneed(abi_ulong start, abi_ulong end)
{
- ulong addr;
+ abi_ulong addr;
if ((start | end) & ~qemu_host_page_mask) {
return false;