lfortran: update to 0.16.0

This commit is contained in:
Li Chong Yun 2022-07-20 16:43:53 +08:00 committed by buttaface
parent 641a1d28da
commit 11579b1c00
2 changed files with 9 additions and 9 deletions

View File

@ -1,11 +1,11 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,7 +82,7 @@
+++ b/CMakeLists.mod.txt
@@ -107,7 +107,7 @@
# Find ZLIB with our custom finder before including LLVM since the finder for LLVM
# might search for ZLIB again and find the shared libraries instead of the static ones
- find_package(StaticZLIB REQUIRED)
+ find_package(ZLIB REQUIRED)
endif()
# Find ZLIB with our custom finder before including LLVM since the finder for LLVM
# might search for ZLIB again and find the shared libraries instead of the static ones
-find_package(StaticZLIB REQUIRED)
+find_package(ZLIB)
# LLVM
set(WITH_LLVM no CACHE BOOL "Build with LLVM support")

View File

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://lfortran.org/
TERMUX_PKG_DESCRIPTION="A modern open-source interactive Fortran compiler"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.15.0
TERMUX_PKG_VERSION=0.16.0
TERMUX_PKG_SRCURL=https://gitlab.com/lfortran/lfortran.git
TERMUX_PKG_DEPENDS="clang, libc++, libkokkos, zlib"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-DBUILD_SHARED_LIBS=ON"