package updates & build issue fixes (#6919)

aptly: fix build failure

dpkg: fix $TERMUX_ARCH in configure script

gotty: switch to up-to-date upstream

minicom: update source url

ncurses: force build with -fPIC

newsboat: update to 2.23

ovmf: update to 20210421.18.g15ee7b7689

pforth: update to 20210315

pup: build with GO111MODULE=off

rcshell: update source url

remind: update to 03.03.07

tweego: update to 2.1.1

virustotal-cli: update to 0.9.6

docker image: install some missing build tools
This commit is contained in:
vhqtvn 2021-05-29 18:41:04 +07:00 committed by GitHub
parent 7d66a3e782
commit 124efc9dd9
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
24 changed files with 205 additions and 93 deletions

View File

@ -15,6 +15,8 @@ termux_step_make() {
cp -a "$TERMUX_PKG_SRCDIR" "$GOPATH"/src/github.com/aptly-dev/aptly
cd "$GOPATH"/src/github.com/aptly-dev/aptly
go mod init
go mod vendor
make install VERSION=$TERMUX_PKG_VERSION
}

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="Debian package management system"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.20.9
TERMUX_PKG_REVISION=4
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/debian/pool/main/d/dpkg/dpkg_${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=5ce242830f213b5620f08e6c4183adb1ef4dc9da28d31988a27c87c71fe534ce
# with the extract.c.patch we remove the -p and --warning=no-timestamp tar options so we can use busybox tar
@ -73,6 +74,7 @@ share/polkit-1
termux_step_pre_configure() {
export TAR=tar # To make sure dpkg tries to use "tar" instead of e.g. "gnutar" (which happens when building on OS X)
perl -p -i -e "s/TERMUX_ARCH/$TERMUX_ARCH/" $TERMUX_PKG_SRCDIR/configure
sed -i 's/$req_vars = \$arch_vars.$varname./if ($varname eq "DEB_HOST_ARCH_CPU" or $varname eq "DEB_HOST_ARCH"){ print("'$TERMUX_ARCH'");exit; }; $req_vars = $arch_vars{$varname}/' scripts/dpkg-architecture.pl
}
termux_step_post_massage() {

View File

@ -1,11 +1,10 @@
TERMUX_PKG_HOMEPAGE=https://github.com/yudai/gotty
TERMUX_PKG_HOMEPAGE=https://github.com/sorenisanerd/gotty
TERMUX_PKG_DESCRIPTION="Share your terminal as a web application"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.0.1
TERMUX_PKG_REVISION=6
TERMUX_PKG_SRCURL=https://github.com/yudai/gotty/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=32695d70a79f55efdf4fba6f06f830515a2055abc58fc15e2124dff5be75695b
TERMUX_PKG_VERSION=1.2.0
TERMUX_PKG_SRCURL=https://github.com/sorenisanerd/gotty/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=f27ae51056298cd114b844929160393a8b389e9ed99238e6e9cb30e6206ca542
termux_step_make() {
termux_setup_golang
@ -15,8 +14,8 @@ termux_step_make() {
ln -sf "$TERMUX_PKG_SRCDIR" "$GOPATH"/src/github.com/yudai/gotty
cd "$GOPATH"/src/github.com/yudai/gotty
go mod init
go mod tidy
go mod init || go mod download
#go mod tidy
go build
}

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="Secure communications library implementing the SSL, TLS
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.6.15
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://www.gnupg.org/ftp/gcrypt/gnutls/v${TERMUX_PKG_VERSION:0:3}/gnutls-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=0ea8c3283de8d8335d7ae338ef27c53a916f15f382753b174c18b45ffd481558
TERMUX_PKG_DEPENDS="libgmp, libnettle, ca-certificates, libidn2, libunistring"
@ -17,8 +18,10 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--with-default-trust-store-file=$TERMUX_PREFIX/etc/tls/cert.pem
--with-system-priority-file=${TERMUX_PREFIX}/etc/gnutls/default-priorities
--with-included-libtasn1
--enable-local-libopts
--without-p11-kit
--disable-guile
--disable-doc
"
termux_step_pre_configure() {

View File

@ -4,8 +4,8 @@ TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.7.1
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://fossies.org/linux/misc/minicom-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=890875220458e1dd4c27ecb8cec508b06365159bfe7adb8f408a07b0a48763e9
TERMUX_PKG_SRCURL=https://alioth-archive.debian.org/releases/minicom/Source/$TERMUX_PKG_VERSION/minicom-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=532f836b7a677eb0cb1dca8d70302b73729c3d30df26d58368d712e5cca041f1
TERMUX_PKG_DEPENDS="libiconv, ncurses"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="

View File

@ -48,6 +48,7 @@ share/man/man7
termux_step_pre_configure() {
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --with-pkg-config-libdir=$PKG_CONFIG_LIBDIR"
export CPPFLAGS+=" -fPIC"
}
termux_step_post_make_install() {

View File

@ -1,34 +1,24 @@
diff -uNr newsboat-2.22/Makefile newsboat-2.22.mod/Makefile
--- newsboat-2.22/Makefile 2020-12-21 21:56:47.000000000 +0200
+++ newsboat-2.22.mod/Makefile 2021-01-07 16:01:58.247353229 +0200
@@ -47,7 +47,7 @@
--- ./Makefile.orig 2021-05-17 17:50:10.616157051 +0000
+++ ./Makefile 2021-05-17 17:50:26.808091973 +0000
@@ -51,7 +51,7 @@
WARNFLAGS=-Werror -Wall -Wextra -Wunreachable-code -Wno-unknown-warning-option -Wno-unknown-pragmas
WARNFLAGS=-Werror -Wall -Wextra -Wunreachable-code
INCLUDES=-Iinclude -Istfl -Ifilter -I. -Irss -I$(relative_cargo_target_dir)/cxxbridge/libnewsboat-ffi/src/
-BARE_CXXFLAGS=-std=c++11 -O2 -ggdb $(INCLUDES)
+BARE_CXXFLAGS=-std=c++11 -O2 $(INCLUDES)
LDFLAGS+=-L.
# Constants
@@ -65,7 +65,7 @@
LDFLAGS+=-fprofile-arcs -ftest-coverage
endif
-CXXFLAGS:=$(BARE_CXXFLAGS) $(WARNFLAGS) $(DEFINES) $(CXXFLAGS)
+CXXFLAGS:=$(BARE_CXXFLAGS) $(WARNFLAGS) $(DEFINES) $(CXXFLAGS) $(CPPFLAGS)
CXXFLAGS_FOR_BUILD?=$(CXXFLAGS)
LIB_SOURCES:=$(shell cat mk/libboat.deps)
@@ -79,7 +79,7 @@
@@ -83,7 +83,7 @@
NEWSBOAT=newsboat
NEWSBOAT_SOURCES:=$(shell cat mk/newsboat.deps)
NEWSBOAT_OBJS:=$(patsubst %.cpp,%.o,$(NEWSBOAT_SOURCES))
-NEWSBOAT_LIBS=-lboat -lnewsboat -lfilter -lpthread -lrsspp -ldl
+NEWSBOAT_LIBS=-lboat -lnewsboat -lfilter -lrsspp -landroid-glob
+NEWSBOAT_LIBS=-lboat -lnewsboat -lfilter -lrsspp -ldl -landroid-glob
RSSPPLIB_SOURCES=$(sort $(wildcard rss/*.cpp))
RSSPPLIB_OBJS=$(patsubst rss/%.cpp,rss/%.o,$(RSSPPLIB_SOURCES))
@@ -105,7 +105,7 @@
@@ -109,7 +109,7 @@
PODBOAT=podboat
PODBOAT_SOURCES:=$(shell cat mk/podboat.deps)
PODBOAT_OBJS:=$(patsubst %.cpp,%.o,$(PODBOAT_SOURCES))

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://newsboat.org/
TERMUX_PKG_DESCRIPTION="RSS/Atom feed reader for the text console"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.22.1
TERMUX_PKG_VERSION=2.23
TERMUX_PKG_SRCURL=https://newsboat.org/releases/${TERMUX_PKG_VERSION}/newsboat-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=8920f41cc53776b67c0e85ad1696b0967f6ac248f3b8913d977942c15d75e690
TERMUX_PKG_SHA256=b997b139d41db2cc5f54346f27c448bee47d6c6228a12ce9cb91c3ffaec7dadc
TERMUX_PKG_DEPENDS="libc++, libiconv, libandroid-support, libandroid-glob, json-c, libsqlite, libcurl, libxml2, stfl, ncurses, openssl"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"

View File

@ -1,26 +1,24 @@
diff -u -r ../newsboat-2.21/rust/libnewsboat/Cargo.toml ./rust/libnewsboat/Cargo.toml
--- ../newsboat-2.21/rust/libnewsboat/Cargo.toml 2020-09-20 19:14:02.000000000 +0000
+++ ./rust/libnewsboat/Cargo.toml 2020-10-21 22:26:52.328755304 +0000
@@ -18,8 +18,7 @@
--- ./rust/libnewsboat/Cargo.toml.orig 2021-05-17 16:44:12.665188034 +0000
+++ ./rust/libnewsboat/Cargo.toml 2021-05-17 16:44:22.377378220 +0000
@@ -17,7 +17,7 @@
backtrace = "= 0.3"
unicode-width = "0.1.8"
nom = "5"
curl-sys = "0.4.5"
nom = "6"
-libc = "0.2"
-gettext-rs = "0.5.0"
+libc = { git = "https://github.com/fornwall/libc", branch = "android-lockf-operations" }
+libc = "0.2.94"
natord = "1.0.9"
lazy_static = "1.4.0"
@@ -34,12 +33,6 @@
[dependencies.clap]
@@ -31,12 +31,6 @@
# I want as little dependencies as practically possible.
default-features = false
-[dependencies.gettext-sys]
-version = "0.19.9"
-[dependencies.gettext-rs]
-version = "0.6.0"
-# Don't let the crate build its own copy of gettext; force it to use the one
-# built into glibc.
-features = [ "gettext-system" ]
-
[dev-dependencies]
tempfile = "3"
# 0.9.6 fixes build failures on Nightly >=2020-04-08: https://github.com/newsboat/newsboat/issues/870
[dependencies.curl-sys]
version = "0.4.5"
# This disables the only default feature, "ssl". It doesn't affect the

View File

@ -1,6 +1,5 @@
diff -uNr newsboat-2.22/rust/libnewsboat/src/filterparser.rs newsboat-2.22.mod/rust/libnewsboat/src/filterparser.rs
--- newsboat-2.22/rust/libnewsboat/src/filterparser.rs 2020-12-21 21:56:47.000000000 +0200
+++ newsboat-2.22.mod/rust/libnewsboat/src/filterparser.rs 2021-01-07 16:15:19.150160249 +0200
--- ./rust/libnewsboat/src/filterparser.rs.orig 2021-05-17 15:52:16.226226704 +0000
+++ ./rust/libnewsboat/src/filterparser.rs 2021-05-17 15:53:32.474081081 +0000
@@ -1,6 +1,5 @@
//! Parses filter expressions.
@ -8,20 +7,22 @@ diff -uNr newsboat-2.22/rust/libnewsboat/src/filterparser.rs newsboat-2.22.mod/r
use nom::{
branch::alt,
bytes::complete::{escaped, is_not, tag, take, take_while, take_while1},
@@ -60,9 +59,9 @@
@@ -126,11 +125,11 @@
/// indicating the thing thah was expected.
fn translate_expected(expected: Expected) -> String {
match expected {
- Expected::AttributeName => gettext("attribute name"),
- Expected::Operators => gettext("one of: =~, ==, =, !~, !=, <=, >=, <, >, between, #, !#"),
- Expected::Value => gettext("one of: quoted string, range, number"),
+ Expected::AttributeName => "attribute name".to_string(),
// Don't translate "between" -- it's a keyword, not an English word.
- Expected::Operators => gettext("one of: =~, ==, =, !~, !=, <=, >=, <, >, between, #, !#"),
+ Expected::Operators => "one of: =~, ==, =, !~, !=, <=, >=, <, >, between, #, !#".to_string(),
// The options ("quoted string" etc.) are not keywords, so please translate them.
- Expected::Value => gettext("one of: quoted string, range, number"),
+ Expected::Value => "one of: quoted string, range, number".to_string(),
}
}
@@ -353,19 +352,19 @@
@@ -425,19 +424,19 @@
let err = match error {
Error::TrailingCharacters(pos, tail) => fmt!(
// The "%{}" thing is a number, a zero-based offset into a string.

View File

@ -1,6 +1,5 @@
diff -uNr newsboat-2.22/rust/libnewsboat/src/fslock.rs newsboat-2.22.mod/rust/libnewsboat/src/fslock.rs
--- newsboat-2.22/rust/libnewsboat/src/fslock.rs 2020-12-21 21:56:47.000000000 +0200
+++ newsboat-2.22.mod/rust/libnewsboat/src/fslock.rs 2021-01-07 16:16:48.102924240 +0200
--- ./rust/libnewsboat/src/fslock.rs.orig 2021-05-17 16:33:46.781835254 +0000
+++ ./rust/libnewsboat/src/fslock.rs 2021-05-17 16:34:30.623855213 +0000
@@ -1,5 +1,4 @@
use crate::logger::{self, Level};
-use gettextrs::gettext;
@ -11,8 +10,8 @@ diff -uNr newsboat-2.22/rust/libnewsboat/src/fslock.rs newsboat-2.22.mod/rust/li
Ok(file) => file,
Err(reason) => {
return Err(fmt!(
- &gettext("Failed to open lock file: '%s' (%s)"),
+ "Failed to open lock file: '%s' (%s)",
- &gettext("Failed to open lock file '%s': %s"),
+ "Failed to open lock file '%s': %s",
new_lock_path
.to_str()
- .unwrap_or(&gettext("<filename containing invalid UTF-8 codepoint>")),
@ -24,8 +23,8 @@ diff -uNr newsboat-2.22/rust/libnewsboat/src/fslock.rs newsboat-2.22.mod/rust/li
{
log!(Level::Debug, "FsLock: Failed to write PID");
return Err(fmt!(
- &gettext("Failed to write PID to lock file: '%s' (%s)"),
+ "Failed to write PID to lock file: '%s' (%s)",
- &gettext("Failed to write PID to lock file '%s': %s"),
+ "Failed to write PID to lock file '%s': %s",
new_lock_path
.to_str()
- .unwrap_or(&gettext("<filename containing invalid UTF-8 codepoint>")),

View File

@ -0,0 +1,90 @@
--- ./rust/libnewsboat/src/utils.rs.orig 2021-05-17 17:24:43.019948076 +0000
+++ ./rust/libnewsboat/src/utils.rs 2021-05-17 17:45:43.814961688 +0000
@@ -891,6 +891,7 @@
// On FreeBSD, link with GNU libiconv; the iconv implementation in libc doesn't support //TRANSLIT
// and WCHAR_T. This is also why we change the symbol names from "iconv" to "libiconv" below.
+/*
#[cfg_attr(target_os = "freebsd", link(name = "iconv"))]
extern "C" {
#[cfg_attr(target_os = "freebsd", link_name = "libiconv_open")]
@@ -906,7 +907,7 @@
#[cfg_attr(target_os = "freebsd", link_name = "libiconv_close")]
pub fn iconv_close(cd: iconv_t) -> c_int;
}
-
+*/
/// Annotates the target encoding (`tocode`) with `//TRANSLIT` if conversion between `fromcode` and
/// `tocode` might require transliterating some characters.
pub fn translit(tocode: &str, fromcode: &str) -> String {
@@ -920,7 +921,7 @@
// However, in our case it's okay: even if multiple threads run this function, they will all
// arrive at the same result, so we don't care if those threads race to write that result into
// the variable.
- static mut STATE: TranslitState = TranslitState::Unknown;
+ static mut STATE: TranslitState = TranslitState::Unsupported;
// TRANSLIT is not needed when converting to unicode encodings
if tocode == "utf-8" || tocode == "WCHAR_T" {
@@ -931,6 +932,7 @@
unsafe {
if STATE == TranslitState::Unknown {
+ /*
// The three calls to expect() can't panic because the input strings come from either:
//
// - our code, and we won't deliberately put a NUL byte inside an encoding name; or
@@ -968,6 +970,7 @@
STATE = TranslitState::Supported;
iconv_close(cd);
}
+ */
}
}
@@ -987,7 +990,9 @@
let mut result = vec![];
let tocode_translit = translit(tocode, fromcode);
-
+
+ result = tocode_translit.as_bytes().to_vec();
+ /*
// Illegal and incomplete multi-byte sequences will be replaced by this
// placeholder. By default, we use an ASCII value for "question mark".
let question_mark = {
@@ -1078,21 +1083,25 @@
iconv_close(cd);
}
-
+ */
result
}
fn get_locale_encoding() -> String {
unsafe {
- use libc::{nl_langinfo, CODESET};
+ use libc::{setlocale, LC_CTYPE};
use std::ffi::CStr;
-
- let codeset = CStr::from_ptr(nl_langinfo(CODESET));
- // Codeset names are ASCII, so the below expect() should never panic.
- codeset
- .to_str()
- .expect("Locale codeset name is not a valid UTF-8 string")
- .to_owned()
+ // reimplement from C version https://github.com/crystax/android-vendor-gnu-grep/blob/master/lib/nl_langinfo.c
+ let mut locale = CStr::from_ptr(setlocale(LC_CTYPE, std::ptr::null())).to_str().expect("Null locale found").to_owned();
+ locale = match locale.find(".") {
+ Some(pos) => locale[(pos+1)..].to_string(),
+ None => locale
+ };
+ locale = match locale.find("@") {
+ Some(pos) => locale[..pos].to_string(),
+ None => locale
+ };
+ locale
}
}

View File

@ -1,8 +1,7 @@
diff -u -r ../newsboat-2.21/rust/regex-rs/Cargo.toml ./rust/regex-rs/Cargo.toml
--- ../newsboat-2.21/rust/regex-rs/Cargo.toml 2020-09-20 19:14:02.000000000 +0000
+++ ./rust/regex-rs/Cargo.toml 2020-10-21 22:09:31.909107906 +0000
--- ./rust/regex-rs/Cargo.toml.orig 2021-05-17 15:54:50.865965562 +0000
+++ ./rust/regex-rs/Cargo.toml 2021-05-17 15:54:57.293957473 +0000
@@ -12,4 +12,3 @@
bitflags = "1.2"
libc = ">=0.2.69"
-gettext-rs = "0.5.0"
-gettext-rs = "0.6.0"

View File

@ -1,15 +1,14 @@
diff -u -r ../newsboat-2.20.1/rust/regex-rs/src/lib.rs ./rust/regex-rs/src/lib.rs
--- ../newsboat-2.20.1/rust/regex-rs/src/lib.rs 2020-06-24 09:51:43.000000000 +0000
+++ ./rust/regex-rs/src/lib.rs 2020-08-12 07:26:30.707888000 +0000
@@ -29,7 +29,6 @@
//! ```
--- ./rust/regex-rs/src/lib.rs.orig 2021-05-17 15:55:52.477895886 +0000
+++ ./rust/regex-rs/src/lib.rs 2021-05-17 15:57:01.485837117 +0000
@@ -32,7 +32,6 @@
#![allow(clippy::unreadable_literal)]
use bitflags::bitflags;
-use gettextrs::gettext;
use libc::{regcomp, regerror, regex_t, regexec, regfree, regmatch_t};
use std::ffi::{CString, OsString};
use std::mem;
@@ -155,12 +154,12 @@
@@ -158,12 +157,12 @@
} else {
match regex_error_to_str(errcode, &regex) {
Some(regcomp_errmsg) => {
@ -24,7 +23,7 @@ diff -u -r ../newsboat-2.20.1/rust/regex-rs/src/lib.rs ./rust/regex-rs/src/lib.r
}
}
}
@@ -240,11 +239,11 @@
@@ -243,11 +242,11 @@
_ => unsafe {
match regex_error_to_str(errcode, &self.regex) {
Some(regexec_errmsg) => {

View File

@ -2,15 +2,15 @@ TERMUX_PKG_HOMEPAGE=https://www.tianocore.org/
TERMUX_PKG_DESCRIPTION="Open Virtual Machine Firmware"
TERMUX_PKG_LICENSE="BSD"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=20210421.14.g5531fd48de
TERMUX_PKG_VERSION=20210421.18.g15ee7b7689
TERMUX_PKG_SRCURL=(https://www.kraxel.org/repos/jenkins/edk2/edk2.git-aarch64-0-${TERMUX_PKG_VERSION}.noarch.rpm
https://www.kraxel.org/repos/jenkins/edk2/edk2.git-arm-0-${TERMUX_PKG_VERSION}.noarch.rpm
https://www.kraxel.org/repos/jenkins/edk2/edk2.git-ovmf-ia32-0-${TERMUX_PKG_VERSION}.noarch.rpm
https://www.kraxel.org/repos/jenkins/edk2/edk2.git-ovmf-x64-0-${TERMUX_PKG_VERSION}.noarch.rpm)
TERMUX_PKG_SHA256=(17995b69b3eac21ba2cb27c0cbaf79ddb21b74b0588f9fd49c19e0c1ad2cec9c
f8b3e5ed0e81073841a08ac2a7fee9abe5dae7b4c2a8536a600aa86a383fb308
66206ddad3c6cc6ea370494934573627f0d9d6077924fd094c0bdd9bde3bf588
d0bd82a566fc162601fdd92f08b1b7df11a3f1d99bcb34171a80cb68b07140a7)
TERMUX_PKG_SHA256=(f8666aeb0edc5ce05991df47be2511b42edc4e0288dc9096f05e64dbd3778767
b7ae09af4d887c1ee949814b1f9f7b1b61cf84040a7e9302f20c0cf6b0ba5f38
1008d9536f89ac484d8b703914f35e1181be9ffd1a65578fdc5f9dd2f613a750
db231a5026ac0d9b82c97920c509f06176b1fd73158158f26157487781bac62c)
TERMUX_PKG_SKIP_SRC_EXTRACT=true
TERMUX_PKG_PLATFORM_INDEPENDENT=true

View File

@ -2,11 +2,10 @@ TERMUX_PKG_HOMEPAGE=http://www.softsynth.com/pforth/
TERMUX_PKG_DESCRIPTION="Portable Forth in C"
TERMUX_PKG_LICENSE="Public Domain"
TERMUX_PKG_MAINTAINER="@termux"
_COMMIT=ee8dc9e9e0f59b8e38dec3732caefe9f3af2b431
TERMUX_PKG_VERSION=20180513
TERMUX_PKG_REVISION=1
_COMMIT=fad6b12e3aa8d52d9ee1f32ab7d2f198f8362173
TERMUX_PKG_VERSION=20210315
TERMUX_PKG_SRCURL=https://github.com/philburk/pforth/archive/${_COMMIT}.zip
TERMUX_PKG_SHA256=3cf472bb944aa53b0eb0b93d021c8c2c0eff18dd2e3e54daddaf4af342e441ea
TERMUX_PKG_SHA256=82d60ce9ce119607c34432101acf57e12d6c7f9af4f130adf0100b468280e649
TERMUX_PKG_HOSTBUILD=true
termux_step_post_configure() {
@ -35,6 +34,7 @@ termux_step_pre_configure() {
export TERMUX_PKG_BUILDDIR=$TERMUX_PKG_SRCDIR/build/unix
export CC="$CC $CFLAGS $LDFLAGS"
}
termux_step_make_install() {
cp $TERMUX_PKG_BUILDDIR/pforth_standalone $TERMUX_PREFIX/bin/pforth
}

View File

@ -23,5 +23,5 @@ etc/proot-distro/ubuntu-20.04.sh
"
termux_step_make_install() {
./install.sh
TERMUX_PREFIX="$TERMUX_PREFIX" TERMUX_ANDROID_HOME="$TERMUX_ANDROID_HOME" ./install.sh
}

View File

@ -16,6 +16,8 @@ termux_step_make() {
mkdir -p "${GOPATH}/src/github.com/ericchiang/"
cp -a "${TERMUX_PKG_SRCDIR}" "${GOPATH}/src/github.com/ericchiang/pup"
cd "${GOPATH}/src/github.com/ericchiang/pup"
export GO111MODULE=off
go get -d -v
go build
}

View File

@ -4,7 +4,7 @@ TERMUX_PKG_LICENSE="ZLIB"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.7.4
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://sources.voidlinux.org/rc-${TERMUX_PKG_VERSION}/rc-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SRCURL=https://sources.voidlinux-ppc.org/rc-${TERMUX_PKG_VERSION}/rc-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=5ed26334dd0c1a616248b15ad7c90ca678ae3066fa02c5ddd0e6936f9af9bfd8
TERMUX_PKG_DEPENDS="readline"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://dianne.skoll.ca/projects/remind/
TERMUX_PKG_DESCRIPTION="Sophisticated calendar and alarm program"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1:03.03.06
TERMUX_PKG_SRCURL=https://fossies.org/linux/misc/remind-${TERMUX_PKG_VERSION:2}.tar.gz
TERMUX_PKG_SHA256=969a0c0170c9c70383634fdaa28db9191058585844e2e7f5d69479fc84d95f5b
TERMUX_PKG_VERSION=1:03.03.07
TERMUX_PKG_SRCURL=https://dianne.skoll.ca/projects/remind/download/remind-${TERMUX_PKG_VERSION:2}.tar.gz
TERMUX_PKG_SHA256=87c94e29d1e18954ff5d22247d7eca307ce621e11d22c14208f903f68a3b8a3d
TERMUX_PKG_DEPENDS="libandroid-glob"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_RM_AFTER_INSTALL="bin/tkremind share/man/man1/tkremind.1 bin/cm2rem.tcl share/man/man1/cm2rem.1"

View File

@ -1,19 +1,37 @@
diff -u -r ../serf-1.3.9/SConstruct ./SConstruct
--- ../serf-1.3.9/SConstruct 2015-09-17 08:46:24.000000000 -0400
+++ ./SConstruct 2016-09-26 10:32:22.315215335 -0400
--- src/SConstruct 2021-05-17 10:52:36.910193982 +0000
+++ src/SConstruct 2021-05-17 10:53:54.856878859 +0000
@@ -155,6 +155,7 @@
env = Environment(variables=opts,
tools=('default', 'textfile',),
CPPPATH=['.', ],
+ PLATFORM='posix'
+ PLATFORM='posix'
)
env.Append(BUILDERS = {
@@ -216,7 +217,7 @@
@@ -166,7 +167,7 @@
match = re.search('SERF_MAJOR_VERSION ([0-9]+).*'
'SERF_MINOR_VERSION ([0-9]+).*'
'SERF_PATCH_VERSION ([0-9]+)',
- env.File('serf.h').get_contents(),
+ str(env.File('serf.h').get_contents()),
re.DOTALL)
MAJOR, MINOR, PATCH = [int(x) for x in match.groups()]
env.Append(MAJOR=str(MAJOR))
@@ -183,7 +184,7 @@
unknown = opts.UnknownVariables()
if unknown:
- print 'Warning: Used unknown variables:', ', '.join(unknown.keys())
+ print('Warning: Used unknown variables:', ', '.join(unknown.keys()))
apr = str(env['APR'])
apu = str(env['APU'])
@@ -216,7 +217,8 @@
# from current_version, so don't use the PATCH level to avoid that build and
# runtime patch levels have to be identical.
if sys.platform != 'sunos5':
- env['SHLIBVERSION'] = '%d.%d.%d' % (MAJOR, MINOR, 0)
+ #env['SHLIBVERSION'] = '%d.%d.%d' % (MAJOR, MINOR, 0)
+ env['SHLIBSUFFIX'] = '.so'
LIBNAME = 'libserf-%d' % (MAJOR,)

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://bitbucket.org/tmedwards/tweego
TERMUX_PKG_DESCRIPTION="A free command line compiler for Twine/Twee story formats"
TERMUX_PKG_LICENSE="BSD"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.1.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=2.1.1
TERMUX_PKG_SRCURL=https://github.com/tmedwards/tweego/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=73c2f00e6b19bd7339b2c431a32f51f4514f7b32130dd5738ece6efbf0664343
TERMUX_PKG_SHA256=f58991ff0b5b344ebebb5677b7c21209823fa6d179397af4a831e5ef05f28b02
termux_step_make() {
termux_setup_golang
@ -21,6 +20,6 @@ termux_step_make() {
termux_step_make_install() {
install -Dm700 \
"$GOPATH"/src/bitbucket.org/tmedwards/tweego/tweego \
"$GOPATH"/src/github.com/tmedwards/tweego/tweego \
"$TERMUX_PREFIX"/bin/
}

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/VirusTotal/vt-cli
TERMUX_PKG_DESCRIPTION="Command line interface for VirusTotal"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=0.9.4
TERMUX_PKG_VERSION=0.9.6
TERMUX_PKG_SRCURL=https://github.com/VirusTotal/vt-cli/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=b3c097b79067a251f0175d0e6ac7cb12431fb707e84ac9d0e6ef188707211bb0
TERMUX_PKG_SHA256=468ee45eba6234be1bfdfae9421b0b87bce3768d9cb09c777ca6bc1735d5af67
TERMUX_PKG_BREAKS="vt-cli"
TERMUX_PKG_REPLACES="vt-cli"

View File

@ -25,6 +25,7 @@ PACKAGES+=" unzip"
PACKAGES+=" autoconf"
PACKAGES+=" automake"
PACKAGES+=" autopoint"
PACKAGES+=" autogen"
PACKAGES+=" bison"
PACKAGES+=" flex"
PACKAGES+=" g++"
@ -70,6 +71,15 @@ PACKAGES+=" bsdmainutils"
# Needed by package ccnet.
PACKAGES+=" valac"
# Needed by package libgcrypt.
PACKAGES+=" fig2dev"
# Needed by package libidn2.
PACKAGES+=" gengetopt"
# Needed by package proxmark3-git.
PACKAGES+=" swig"
# Needed by package dbus-glib.
PACKAGES+=" libdbus-1-dev"