atuin: bump to 17.0.0

This commit is contained in:
Chongyun Lee 2023-10-29 02:35:14 +08:00 committed by Uchiha Kakashi
parent 6eee19e2f2
commit 23445aeba0
2 changed files with 45 additions and 2 deletions

View File

@ -3,9 +3,9 @@ TERMUX_PKG_DESCRIPTION="Magical shell history"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_LICENSE_FILE="../LICENSE"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="16.0.0"
TERMUX_PKG_VERSION="17.0.0"
TERMUX_PKG_SRCURL=https://github.com/ellie/atuin/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=28d469e452086481f64293390ba0736a082623d49b5064a01b2e2106cc1e8fef
TERMUX_PKG_SHA256=9c1bd5e180f53dd98248f582a36a4ead0670d3e155874a7217ec87cab3cea51a
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_HOSTBUILD=true

View File

@ -0,0 +1,43 @@
Revert https://github.com/atuinsh/atuin/pull/1249
--- a/atuin/Cargo.toml
+++ b/atuin/Cargo.toml
@@ -72,7 +72,6 @@
colored = "2.0.4"
ratatui = "0.23"
tracing = "0.1"
-cli-clipboard = "0.4.0"
[dependencies.tracing-subscriber]
--- a/atuin/src/command/client/search/interactive.rs
+++ b/atuin/src/command/client/search/interactive.rs
@@ -39,7 +39,6 @@
const RETURN_ORIGINAL: usize = usize::MAX;
const RETURN_QUERY: usize = usize::MAX - 1;
-const COPY_QUERY: usize = usize::MAX - 2;
struct State {
history_count: i64,
@@ -142,9 +141,6 @@
return Some(self.results_state.selected());
}
- KeyCode::Char('y') if ctrl => {
- return Some(COPY_QUERY);
- }
KeyCode::Char(c @ '1'..='9') if modfr => {
let c = c.to_digit(10)? as usize;
return Some(self.results_state.selected() + c);
@@ -711,10 +707,6 @@
Ok(command)
} else if index == RETURN_ORIGINAL {
Ok(String::new())
- } else if index == COPY_QUERY {
- let cmd = results.swap_remove(app.results_state.selected()).command;
- cli_clipboard::set_contents(cmd).unwrap();
- Ok(String::new())
} else {
// Either:
// * index == RETURN_QUERY, in which case we should return the input