json-c: disable locale

This commit is contained in:
Chongyun Lee 2022-07-10 14:46:16 +08:00 committed by Henrik Grimler
parent 4b4dcdd1df
commit 24a92a971f
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
2 changed files with 22 additions and 0 deletions

View File

@ -0,0 +1,21 @@
Disable locale. See https://github.com/termux/termux-packages/discussions/11209.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,7 +143,7 @@
check_include_file("dlfcn.h" HAVE_DLFCN_H)
check_include_file("endian.h" HAVE_ENDIAN_H)
check_include_file("limits.h" HAVE_LIMITS_H)
-check_include_file("locale.h" HAVE_LOCALE_H)
+# check_include_file("locale.h" HAVE_LOCALE_H)
check_include_file("memory.h" HAVE_MEMORY_H)
check_include_file(stdint.h HAVE_STDINT_H)
@@ -152,7 +152,7 @@
check_include_file(sys/param.h HAVE_SYS_PARAM_H)
check_include_file(sys/random.h HAVE_SYS_RANDOM_H)
check_include_file(sys/stat.h HAVE_SYS_STAT_H)
-check_include_file(xlocale.h HAVE_XLOCALE_H)
+# check_include_file(xlocale.h HAVE_XLOCALE_H)
if (HAVE_INTTYPES_H)
# Set a json-c specific var to stamp into json_config.h

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="A JSON implementation in C"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.16
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://s3.amazonaws.com/json-c_releases/releases/json-c-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=8e45ac8f96ec7791eaf3bb7ee50e9c2100bbbc87b8d0f1d030c5ba8a0288d96b
TERMUX_PKG_BREAKS="json-c-dev"