freeimage: improve patches and disable PNG optimisation for arm arch's only

This commit is contained in:
Aditya Alok 2021-08-26 22:57:20 +05:30 committed by Henrik Grimler
parent b782c7da0e
commit 2821bdc9ba
3 changed files with 24 additions and 24 deletions

View File

@ -1,13 +1,15 @@
--- FreeImage/Makefile.gnu 2021-08-20 21:04:25.244999878 +0530
+++ FreeImage-patch/Makefile.gnu 2021-08-21 10:28:21.714786780 +0530
@@ -5,19 +5,19 @@
--- FreeImage/Makefile.gnu 2015-03-10 09:04:00.000000000 +0530
+++ FreeImage-patch/Makefile.gnu 2021-08-26 23:29:19.300999788 +0530
@@ -5,17 +5,20 @@
# General configuration variables:
DESTDIR ?= /
-INCDIR ?= $(DESTDIR)/usr/include
-INSTALLDIR ?= $(DESTDIR)/usr/lib
+INCDIR ?= @TERMUX_PREFIX@/include
+INSTALLDIR ?= @TERMUX_PREFIX@/lib
+INCDIR ?= @TERMUX_PREFIX@/usr/include
+INSTALLDIR ?= @TERMUX_PREFIX@/usr/lib
+
+SRCS += Source/LibRawLite/internal/swab.cpp
# Converts cr/lf to just lf
DOS2UNIX = dos2unix
@ -18,14 +20,22 @@
MODULES = $(SRCS:.c=.o)
MODULES := $(MODULES:.cpp=.o)
-CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
+CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -fstack-protector-strong -Oz
+CFLAGS ?=
+CFLAGS += -O3 -fPIC -fexceptions -fvisibility=hidden
# OpenJPEG
-CFLAGS += -DOPJ_STATIC
+CFLAGS += -DOPJ_STATIC -DPNG_ARM_NEON_OPT=0
CFLAGS += -DOPJ_STATIC
# LibRaw
CFLAGS += -DNO_LCMS
@@ -23,7 +26,8 @@
# LibJXR
@@ -71,9 +71,9 @@
CFLAGS += -DDISABLE_PERF_MEASUREMENT -D__ANSI__
CFLAGS += $(INCLUDE)
-CXXFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
+CXXFLAGS ?=
+CXXFLAGS += -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
# LibJXR
CXXFLAGS += -D__ANSI__
CXXFLAGS += $(INCLUDE)
@@ -71,9 +75,9 @@
install:
install -d $(INCDIR) $(INSTALLDIR)

File diff suppressed because one or more lines are too long

View File

@ -11,8 +11,9 @@ TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
cp -f "${TERMUX_PKG_BUILDER_DIR}/license-bsd-2-clause.txt" "${TERMUX_PKG_SRCDIR}"
}
termux_step_make() {
make LDFLAGS="${LDFLAGS}"
if [ "${TERMUX_ARCH}" = "aarch64" ] || [ "${TERMUX_ARCH}" = "arm" ]; then
CFLAGS+=" -DPNG_ARM_NEON_OPT=0"
fi
}