graphviz: Build with CMake

This commit is contained in:
Yaksh Bariya 2021-12-08 15:10:13 +05:30
parent f018bf2cb7
commit 290ae05f35
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
5 changed files with 14 additions and 70 deletions

View File

@ -0,0 +1,13 @@
--- ./CMakeLists.txt 2021-10-23 05:32:14.000000000 +0530
+++ ./CMakeLists.txt.mod 2021-12-08 15:09:15.324372847 +0530
@@ -115,9 +115,7 @@
find_package(ZLIB)
endif()
-if (UNIX)
- find_library(MATH_LIB m)
-endif ()
+set(MATH_LIB -lm)
if (WIN32)
# Find Windows specific dependencies

View File

@ -9,34 +9,9 @@ TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl,
TERMUX_PKG_BREAKS="graphviz-dev"
TERMUX_PKG_REPLACES="graphviz-dev"
TERMUX_PKG_BUILD_DEPENDS="libtool"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--enable-guile=no
--enable-java=no
--enable-lua=no
--enable-ocaml=no
--enable-perl=no
--enable-php=no
--enable-python=no
--enable-r=no
--enable-ruby=no
--enable-sharp=no
--enable-swig=no
--enable-tcl=no
--with-ltdl-include=$TERMUX_PREFIX/include
--with-ltdl-lib=$TERMUX_PREFIX/lib
--with-pangocairo=yes
--with-pic
--with-poppler=no
--with-x=no
"
TERMUX_PKG_FORCE_CMAKE=true
TERMUX_PKG_RM_AFTER_INSTALL="bin/*-config share/man/man1/*-config.1"
termux_step_pre_configure() {
./autogen.sh NOCONFIG
export HOSTCC="gcc"
}
termux_step_post_make_install() {
# Some binaries (dot_builtins, gvpack) links against these:
cd $TERMUX_PREFIX/lib

View File

@ -1,15 +0,0 @@
--- ./configure.ac.orig 2021-12-02 18:23:18.329044250 +0530
+++ ./configure.ac 2021-12-02 18:24:54.019044213 +0530
@@ -279,9 +279,9 @@
AC_CHECK_PROGS(SED,gsed sed,false)
AC_CHECK_PROGS(SORT,gsort sort,false)
-AC_CHECK_PROG(EGREP,egrep,egrep,false)
-AC_CHECK_PROG(GROFF,groff,groff,false)
-AC_CHECK_PROGS(PS2PDF,ps2pdf pstopdf,false)
+AC_CHECK_PROG(EGREP,egrep,egrep,echo)
+AC_CHECK_PROG(GROFF,groff,groff,echo)
+AC_CHECK_PROGS(PS2PDF,ps2pdf pstopdf,echo)
AM_CONDITIONAL(HAVE_PS2PDF,[test "x$PS2PDF" != xfalse])
AC_ARG_ENABLE([man-pdfs],

View File

@ -1,19 +0,0 @@
--- ../lib-gvc-Makefile.am.orig 2020-03-28 12:32:54.035832411 +0100
+++ ./lib/gvc/Makefile.am 2020-03-28 12:37:57.988619047 +0100
@@ -47,6 +47,7 @@
$(top_builddir)/lib/xdot/libxdot_C.la \
$(top_builddir)/lib/label/liblabel_C.la \
$(top_builddir)/lib/common/libcommon_C.la
+libgvc_C_la_LDFLAGS = -landroid-glob
if WITH_ORTHO
libgvc_C_la_LIBADD += $(top_builddir)/lib/ortho/libortho_C.la
libgvc_C_la_DEPENDENCIES += $(top_builddir)/lib/ortho/libortho_C.la
@@ -55,7 +56,7 @@
libgvc_C_la_LIBADD += @LIBLTDL@ $(LIBLTDL_LDFLAGS)
endif
-libgvc_la_LDFLAGS = -version-info $(GVC_VERSION) -no-undefined
+libgvc_la_LDFLAGS = -version-info $(GVC_VERSION) -no-undefined -landroid-glob
libgvc_la_SOURCES = $(libgvc_C_la_SOURCES)
libgvc_la_LIBADD = $(libgvc_C_la_LIBADD) \
$(top_builddir)/lib/xdot/libxdot.la \

View File

@ -1,10 +0,0 @@
--- ./cmd/dot/Makefile.am.orig 2021-12-02 18:35:30.719043970 +0530
+++ ./cmd/dot/Makefile.am 2021-12-02 18:36:09.779043955 +0530
@@ -76,7 +76,6 @@
# run "dot -c", if possible, to create plugin config
install-exec-hook:
(cd $(DESTDIR)$(bindir); if test -x dot$(EXEEXT); then for i in $(linkedprogram); do rm -f $$i; $(LN_S) dot$(EXEEXT) $$i; done; fi;)
- if test "x$(DESTDIR)" = "x"; then if test -x $(bindir)/dot$(EXEEXT); then if test -x /sbin/ldconfig; then /sbin/ldconfig 2>/dev/null; fi; cd $(bindir); ./dot$(EXEEXT) -c; else cd $(bindir); ./dot_static$(EXEEXT) -c; fi; fi
uninstall-hook:
(cd $(DESTDIR)$(man1dir); for i in $(linkedman); do rm -f $$i; done;)