new package: qtutilities

This commit is contained in:
Tee KOBAYASHI 2022-11-29 19:15:04 +09:00 committed by xtkoba
parent aae9fec90c
commit 2df948d06c
2 changed files with 62 additions and 0 deletions

View File

@ -0,0 +1,12 @@
TERMUX_PKG_HOMEPAGE=https://github.com/Martchus/qtutilities
TERMUX_PKG_DESCRIPTION="Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=6.10.0
TERMUX_PKG_SRCURL=https://github.com/Martchus/qtutilities/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=420dfea8864271bc8bac080edb7b8ba2aab1efd2f723e33793d2c8049a2ef935
TERMUX_PKG_DEPENDS="libc++, libc++utilities, qt5-qtbase"
TERMUX_PKG_BUILD_DEPENDS="qt5-qtbase-cross-tools, qt5-qttools-cross-tools"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_SHARED_LIBS=ON
"

View File

@ -0,0 +1,50 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,7 +85,7 @@
cmake/modules/QtLinkage.cmake cmake/modules/QtWebViewProviderConfig.cmake cmake/modules/QtJsProviderConfig.cmake)
set(CMAKE_TEMPLATE_FILES cmake/templates/qtconfig.h.in cmake/templates/webviewdefs.h.in cmake/templates/webviewincludes.h.in
cmake/templates/jsdefs.h.in cmake/templates/jsincludes.h.in)
-if (ANDROID)
+if (FALSE)
list(APPEND CMAKE_MODULE_FILES)
list(APPEND CMAKE_TEMPLATE_FILES cmake/templates/android-deployment.json.in)
endif ()
@@ -120,7 +120,7 @@
if (WIN32
OR (UNIX
AND NOT APPLE
- AND NOT ANDROID))
+ AND NOT FALSE))
set(ENABLE_CAPSLOCK_DETECTION_BY_DEFAULT ON)
else ()
set(ENABLE_CAPSLOCK_DETECTION_BY_DEFAULT OFF)
@@ -150,7 +150,7 @@
# configure support for D-Bus notifications
if (UNIX
AND NOT APPLE
- AND NOT ANDROID)
+ AND NOT FALSE)
set(ENABLE_DBUS_NOTIFICATIONS_BY_DEFAULT ON)
else ()
set(ENABLE_DBUS_NOTIFICATIONS_BY_DEFAULT OFF)
--- a/cmake/modules/QtGuiConfig.cmake
+++ b/cmake/modules/QtGuiConfig.cmake
@@ -81,6 +81,6 @@
CACHE STRING "specifies the image format plugins to link against (only relevant when using static Qt)")
# always enable the Svg module under Android
-if (ANDROID)
+if (FALSE)
list(APPEND ADDITIONAL_QT_MODULES Svg)
endif ()
--- a/cmake/modules/QtLinkage.cmake
+++ b/cmake/modules/QtLinkage.cmake
@@ -24,7 +24,7 @@
# avoid "add_custom_target cannot create target "apk" because another target…" errors produced by Qt's Android support module
# (which can not cope with Qt CMake modules already pulled in by a dependency)
-if (ANDROID AND NOT ${PROJECT_NAME}-MultiAbiBuild)
+if (FALSE AND NOT ${PROJECT_NAME}-MultiAbiBuild)
set(${PROJECT_NAME}-MultiAbiBuild ON)
endif ()