exa: Update to latest git master

This commit is contained in:
Fredrik Fornwall 2019-01-19 03:00:29 +01:00
parent aaf2131242
commit 34d20ff6db
4 changed files with 3 additions and 39 deletions

View File

@ -1,12 +0,0 @@
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml ./Cargo.toml
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml 2018-10-14 15:21:13.000000000 +0000
+++ ./Cargo.toml 2018-10-18 03:04:56.228613011 +0000
@@ -41,7 +41,7 @@
term_grid = "0.1.6"
term_size = "0.3.0"
unicode-width = "0.1.4"
-users = "0.7"
+users = "0.8.1"
zoneinfo_compiled = "0.4.7"
[build-dependencies]

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://the.exa.website
TERMUX_PKG_DESCRIPTION="A modern replacement for ls"
TERMUX_PKG_VERSION=0.9~pre2
TERMUX_PKG_SHA256=df558e74aed27425b9dd2fbca4ee14eee672677722b93b77984d1b9b5265e023
TERMUX_PKG_SRCURL=https://github.com/ogham/exa/archive/485611e7c97d2043731ae83653a70eee2eb69a4b.zip
TERMUX_PKG_VERSION=0.9~pre3
TERMUX_PKG_SHA256=9931ad1c593096e69a1f0f7615e3857b1d422b7e74f63408385c663aeb2c12db
TERMUX_PKG_SRCURL=https://github.com/ogham/exa/archive/058b4a57bdb1e25cbdacc0fbd1eefc09bc5f1e95.zip
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--no-default-features --features default"
TERMUX_PKG_BUILD_IN_SRC=yes

View File

@ -1,12 +0,0 @@
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs ./src/output/render/groups.rs
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs 2018-10-14 15:21:13.000000000 +0000
+++ ./src/output/render/groups.rs 2018-10-18 03:12:48.223359766 +0000
@@ -24,7 +24,7 @@
}
}
- TextCell::paint(style, group.name().to_owned())
+ TextCell::paint(style, group.name().to_str().unwrap().to_owned())
}
}

View File

@ -1,12 +0,0 @@
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs ./src/output/render/users.rs
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs 2018-10-14 15:21:13.000000000 +0000
+++ ./src/output/render/users.rs 2018-10-18 03:13:18.959014671 +0000
@@ -9,7 +9,7 @@
impl f::User {
pub fn render<C: Colours, U: Users>(&self, colours: &C, users: &U) -> TextCell {
let user_name = match users.get_user_by_uid(self.0) {
- Some(user) => user.name().to_owned(),
+ Some(user) => user.name().to_str().unwrap().to_owned(),
None => self.0.to_string(),
};