irssi: update to 1.4.1

force meson build system
This commit is contained in:
Ailin Nemui 2022-06-11 17:19:11 +02:00 committed by Henrik Grimler
parent c90eac3bb9
commit 3c59e0d170
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
5 changed files with 108 additions and 255 deletions

View File

@ -2,48 +2,39 @@ TERMUX_PKG_HOMEPAGE=https://irssi.org/
TERMUX_PKG_DESCRIPTION="Terminal based IRC client"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.2.3
TERMUX_PKG_REVISION=8
TERMUX_PKG_VERSION=1.4.1
TERMUX_PKG_SRCURL=https://github.com/irssi/irssi/releases/download/$TERMUX_PKG_VERSION/irssi-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=a647bfefed14d2221fa77b6edac594934dc672c4a560417b1abcbbc6b88d769f
TERMUX_PKG_SHA256=6a7692741bba16f3ba6f97cf7246421ac57055dcedcca9a4d21663f8efe47501
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="glib, libandroid-glob, libiconv, libotr, ncurses, openssl, perl, utf8proc"
TERMUX_PKG_BREAKS="irssi-dev"
TERMUX_PKG_REPLACES="irssi-dev"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_MESON_PERL_CROSS_FILE=$TERMUX_PKG_TMPDIR/meson-perl-cross-$TERMUX_ARCH.txt
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
ac_cv_path_perlpath=$TERMUX_PREFIX/bin/perl
--enable-true-color
--with-socks
--with-otr=static
--with-perl=static
-Dfhs-prefix=$TERMUX_PREFIX
--cross-file $TERMUX_MESON_PERL_CROSS_FILE
"
termux_step_configure() {
termux_step_configure_meson
}
termux_step_pre_configure() {
local perl_version=$(. $TERMUX_SCRIPTDIR/packages/perl/build.sh; echo $TERMUX_PKG_VERSION)
# Irssi has no support for cross-compiling perl module,
# so we add it ourselves.
sed -e "s|@TERMUX_PREFIX@|$TERMUX_PREFIX|g" \
-e "s|@TERMUX_PERL_VERSION@|$perl_version|g" \
-e "s|@TERMUX_PERL_TARGET@|${TERMUX_ARCH}-android|g" \
$TERMUX_PKG_BUILDER_DIR/perl_config_support.diff | \
patch -p1
autoconf
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --with-perl-lib=$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android"
LDFLAGS+=" -landroid-glob"
# Make build log less noisy.
CFLAGS+=" -Wno-deprecated-declarations"
CFLAGS+=" -Wno-compound-token-split-by-macro"
# Make sure that perl stuff is reinstalled.
rm -rf $TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android/x86_64-linux-gnu-thread-multi
}
termux_step_post_massage() {
local perl_version=$(. $TERMUX_SCRIPTDIR/packages/perl/build.sh; echo $TERMUX_PKG_VERSION)
mv $TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android/x86_64-linux-gnu-thread-multi/* \
$TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android/
rm -rf $TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android/x86_64-linux-gnu-thread-multi
cat <<- MESON_PERL_CROSS >$TERMUX_MESON_PERL_CROSS_FILE
[properties]
perl_version = '$perl_version'
perl_ccopts = ['-I$TERMUX_PREFIX/include', '-D_LARGEFILE_SOURCE', '-D_FILE_OFFSET_BITS=64', '-I$TERMUX_PREFIX/lib/perl5/$perl_version/${TERMUX_ARCH}-android/CORE']
perl_ldopts = ['-Wl,-E', '-I$TERMUX_PREFIX/include', '-L$TERMUX_PREFIX/lib/perl5/$perl_version/${TERMUX_ARCH}-android/CORE', '-lperl', '-lm', '-ldl']
perl_archname = '${TERMUX_ARCH}-android'
perl_installsitearch = '$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android'
perl_installvendorarch = ''
perl_inc = ['$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version/${TERMUX_ARCH}-android', '$TERMUX_PREFIX/lib/perl5/site_perl/$perl_version', '$TERMUX_PREFIX/lib/perl5/$perl_version/${TERMUX_ARCH}-android', '$TERMUX_PREFIX/lib/perl5/$perl_version']
MESON_PERL_CROSS
}

View File

@ -1,42 +0,0 @@
diff -uNr irssi-1.2.0/src/fe-common/core/fe-exec.c irssi-1.2.0.mod/src/fe-common/core/fe-exec.c
--- irssi-1.2.0/src/fe-common/core/fe-exec.c 2019-02-11 19:27:58.000000000 +0200
+++ irssi-1.2.0.mod/src/fe-common/core/fe-exec.c 2019-03-01 20:46:39.912473788 +0200
@@ -281,7 +281,7 @@
static void process_exec(PROCESS_REC *rec, const char *cmd)
{
- const char *shell_args[4] = { "/bin/sh", "-c", NULL, NULL };
+ const char *shell_args[4] = { "@TERMUX_PREFIX@/bin/sh", "-c", NULL, NULL };
char **args;
int in[2], out[2];
int n;
@@ -339,7 +339,7 @@
if (rec->shell) {
execvp(shell_args[0], (char **) shell_args);
- fprintf(stderr, "Exec: /bin/sh: %s\n", g_strerror(errno));
+ fprintf(stderr, "Exec: @TERMUX_PREFIX@/bin/sh: %s\n", g_strerror(errno));
} else {
args = g_strsplit(cmd, " ", -1);
execvp(args[0], args);
diff -uNr irssi-1.2.0/src/fe-fuzz/fe-common/core/theme-load.c irssi-1.2.0.mod/src/fe-fuzz/fe-common/core/theme-load.c
--- irssi-1.2.0/src/fe-fuzz/fe-common/core/theme-load.c 2019-02-11 19:27:58.000000000 +0200
+++ irssi-1.2.0.mod/src/fe-fuzz/fe-common/core/theme-load.c 2019-03-01 20:47:09.179339329 +0200
@@ -38,7 +38,7 @@
int LLVMFuzzerInitialize(int *argc, char ***argv) {
core_register_options();
fe_common_core_register_options();
- char *irssi_argv[] = {*argv[0], "--home", "/tmp/irssi", NULL};
+ char *irssi_argv[] = {*argv[0], "--home", "@TERMUX_PREFIX@/tmp/irssi", NULL};
int irssi_argc = sizeof(irssi_argv) / sizeof(char *) - 1;
args_execute(irssi_argc, irssi_argv);
core_preinit((*argv)[0]);
@@ -52,7 +52,7 @@
int LLVMFuzzerTestOneInput(const uint8_t* data, size_t size) {
gchar *copy = g_strndup((const gchar *)data, size);
- FILE *fp = fopen("/tmp/irssi/fuzz.theme", "wb");
+ FILE *fp = fopen("@TERMUX_PREFIX@/tmp/irssi/fuzz.theme", "wb");
if (fp) {
fwrite(copy, strlen(copy), 1, fp);
fclose(fp);

View File

@ -0,0 +1,87 @@
diff --git a/meson.build b/meson.build
index 71dacead..d90b20c3 100644
--- a/meson.build
+++ b/meson.build
@@ -55,6 +55,9 @@ want_static_dependency = get_option('static-dependency') == 'yes'
package_version = get_option('PACKAGE_VERSION') != '' ? get_option('PACKAGE_VERSION') : meson.project_version()
+UNSET = '=INVALID='
+UNSET_ARR = [UNSET]
+
chat_modules = ['irc']
run_command('mkdir', meson.current_build_dir() / incdir)
@@ -331,8 +334,8 @@ if want_perl
perl_rpath = ''
#### ccopts ####
- perl_ccopts = meson.get_cross_property('perl_ccopts', false)
- if perl_ccopts == false
+ perl_ccopts = meson.get_cross_property('perl_ccopts', UNSET_ARR)
+ if perl_ccopts == UNSET_ARR
res = run_command(cross_perl, '-MExtUtils::Embed', '-e', 'ccopts')
perl_ccopts = res.stdout().strip().split()
endif
@@ -345,8 +348,8 @@ if want_perl
perl_cflags += cc.get_supported_arguments('-fPIC')
#### ldopts ####
- perl_ldopts = meson.get_cross_property('perl_ldopts', false)
- if perl_ldopts == false
+ perl_ldopts = meson.get_cross_property('perl_ldopts', UNSET_ARR)
+ if perl_ldopts == UNSET_ARR
res = run_command(cross_perl, '-MExtUtils::Embed', '-e', 'ldopts')
perl_ldopts = res.stdout().strip().split()
endif
@@ -362,8 +365,8 @@ if want_perl
endif
endforeach
- perl_version = meson.get_cross_property('perl_version', false)
- if perl_version == false
+ perl_version = meson.get_cross_property('perl_version', UNSET)
+ if perl_version == UNSET
perl_version = run_command(cross_perl, '-V::version:').stdout().split('\'')[1]
endif
perl_dep = declare_dependency(compile_args : perl_cflags, link_args : perl_ldflags,
@@ -386,8 +389,8 @@ int main()
warning('error linking with perl libraries')
endif
else
- xsubpp_file_c = meson.get_cross_property('perl_xsubpp', false)
- if xsubpp_file_c == false
+ xsubpp_file_c = meson.get_cross_property('perl_xsubpp', UNSET)
+ if xsubpp_file_c == UNSET
xsubpp_file_c = run_command(build_perl, '-MExtUtils::ParseXS', '-Eprint $INC{"ExtUtils/ParseXS.pm"} =~ s{ParseXS\\.pm$}{xsubpp}r').stdout()
endif
xsubpp = generator(build_perl,
@@ -415,13 +418,13 @@ int main()
set_perl_use_lib = false
perl_library_dir = with_perl_lib + ' default'
if with_perl_lib in ['site', 'vendor']
- perlmoddir = meson.get_cross_property('perl_install' + with_perl_lib + 'arch', false)
- if perlmoddir == false
+ perlmoddir = meson.get_cross_property('perl_install' + with_perl_lib + 'arch', UNSET)
+ if perlmoddir == UNSET
perlmoddir = run_command(cross_perl, '-V::install' + with_perl_lib + 'arch:').stdout().split('\'')[1]
endif
elif with_perl_lib == 'module'
- perl_archname = meson.get_cross_property('perl_archname', false)
- if perl_archname == false
+ perl_archname = meson.get_cross_property('perl_archname', UNSET)
+ if perl_archname == UNSET
perl_archname = run_command(cross_perl, '-V::archname:').stdout().split('\'')[1]
endif
perlmoddir = perl_install_base / 'lib' / 'perl5' / perl_archname
@@ -441,8 +444,8 @@ int main()
perl_use_lib = get_option('prefix') / perlmoddir
if set_perl_use_lib
- perl_inc = meson.get_cross_property('perl_inc', false)
- if perl_inc == false
+ perl_inc = meson.get_cross_property('perl_inc', UNSET_ARR)
+ if perl_inc == UNSET_ARR
set_perl_use_lib = run_command(cross_perl, '-e', 'exit ! grep $_ eq $ARGV[0], grep /^\\//, @INC', perl_use_lib).returncode() != 0
else
set_perl_use_lib = not perl_inc.contains(perl_use_lib)

View File

@ -1,83 +0,0 @@
diff -uNr irssi-1.2.2/configure.ac irssi-1.2.2.mod/configure.ac
--- irssi-1.2.2/configure.ac 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/configure.ac 2020-01-03 15:41:11.485918924 +0200
@@ -119,11 +119,7 @@
elif test "x$withval" = xvendor; then
want_perl=yes
perl_prefix_note=no
- if test -z "`$perlpath -v|grep '5\.0'`"; then
- PERL_MM_PARAMS="INSTALLDIRS=vendor"
- else
- PERL_MM_PARAMS="INSTALLDIRS=perl PREFIX=`$perlpath -e 'use Config; print $Config{prefix}'`"
- fi
+ PERL_MM_PARAMS="INSTALLDIRS=perl PREFIX=@TERMUX_PREFIX@"
perl_set_use_lib=no
else
want_perl=yes
@@ -401,24 +397,10 @@
if test "$want_perl" != "no"; then
AC_MSG_CHECKING(for working Perl support)
- if test -z "$perlpath"; then
- perl_check_error="perl binary not found"
- else
- PERL_CFLAGS=`$perlpath -MExtUtils::Embed -e ccopts 2>/dev/null`
- fi
+ PERL_CFLAGS="-I@TERMUX_PREFIX@/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I@TERMUX_PREFIX@/lib/perl5/@TERMUX_PERL_VERSION@/@TERMUX_PERL_TARGET@/CORE"
- if test "x$ac_cv_prog_gcc" = "xyes" -a -z "`echo $host_os|grep 'bsd\|linux'`"; then
- dnl * several systems have Perl compiled with native compiler
- dnl * but irssi is being compiled with GCC. Here we try to
- dnl * fix those command line options a bit so GCC won't
- dnl * complain about them. Normally there's only few options
- dnl * that we want to keep:
- dnl * -Ddefine -Uundef -I/path -fopt -mopt -iwithsysroot
- PERL_CFLAGS=`echo $PERL_CFLAGS | $perlpath -pe 's/^(.* )?-@<:@^DUIifm@:>@@<:@^ @:>@+/\1/g; s/^(.* )?\+@<:@^ @:>@+/\1/g'`
-
- PERL_EXTRA_OPTS="CCCDLFLAGS=\"-fPIC\""
- AC_SUBST(PERL_EXTRA_OPTS)
- fi
+ PERL_EXTRA_OPTS="CCCDLFLAGS=\"-fPIC\""
+ AC_SUBST(PERL_EXTRA_OPTS)
if test -z "$PERL_CFLAGS"; then
if test -n "$perl_check_error"; then
@@ -427,7 +409,7 @@
AC_MSG_RESULT([not found, building without Perl])
want_perl=no
else
- PERL_LDFLAGS=`$perlpath -MExtUtils::Embed -e ldopts 2>/dev/null`
+ PERL_LDFLAGS="-Wl,-E -I@TERMUX_PREFIX@/include -L@TERMUX_PREFIX@/lib/perl5/@TERMUX_PERL_VERSION@/@TERMUX_PERL_TARGET@/CORE -lperl -lm -ldl"
dnl * remove all database stuffs
dnl * nsl is already in ldflags
@@ -500,13 +482,8 @@
# remove any prefix from PERL_MM_OPT
PERL_MM_OPT=`perl -MText::ParseWords -e 'sub qu{$_=shift;s{^(.*?)=(.*)$}{($a,$b)=($1,$2);$b=~s/"/\\\\"/g;qq{$a="$b"}}ge if /@<:@\s"@:>@/;$_} local $,=" "; print map qu($_), grep !/^(INSTALL_BASE|PREFIX)=/, shellwords(@ARGV)' "$PERL_MM_OPT"`
- # figure out the correct @INC path - we'll need to do this
- # through MakeMaker since it's difficult to get it right
- # otherwise.
- $perlpath -MExtUtils::MakeMaker -e 'WriteMakefile(NAME => "test", MAKEFILE => "Makefile.test", FIRST_MAKEFILE => "/dev/null", NO_META => 1, NO_MYMETA => 1);' $PERL_MM_PARAMS >/dev/null
- echo 'show-INSTALLDIRS:' >> Makefile.test
- echo ' @echo $(INSTALLDIRS)' >> Makefile.test
- perl_INSTALLDIRS=`$am_make -s -f Makefile.test show-INSTALLDIRS`
+
+ perl_INSTALLDIRS=site
if test "x$perl_INSTALLDIRS" = "xsite"; then
perl_library_dir="site default"
perl_INSTALL_VAR=INSTALLSITEARCH
@@ -517,10 +494,9 @@
perl_library_dir="module default"
perl_INSTALL_VAR=INSTALLARCHLIB
fi
- echo 'show-ARCHLIB:' >> Makefile.test
- echo ' @echo $('"$perl_INSTALL_VAR"')' >> Makefile.test
- perl_use_lib=`$am_make -s -f Makefile.test show-ARCHLIB`
- rm -f Makefile.test
+
+ perl_use_lib="@TERMUX_PREFIX@/lib/perl5/site_perl/@TERMUX_PERL_VERSION@/@TERMUX_PERL_TARGET@"
+
if test "x$perl_set_use_lib" = "xyes"; then
if $perlpath -e 'exit ! grep $_ eq $ARGV@<:@0@:>@, grep /^\//, @INC' "$perl_use_lib"; then
perl_library_dir="other path in @INC"

View File

@ -1,100 +0,0 @@
diff -uNr irssi-1.2.2/src/perl/common/Makefile.PL.in irssi-1.2.2.mod/src/perl/common/Makefile.PL.in
--- irssi-1.2.2/src/perl/common/Makefile.PL.in 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/common/Makefile.PL.in 2020-01-03 17:29:11.576800661 +0200
@@ -1,7 +1,7 @@
use ExtUtils::MakeMaker;our $AM_DEFAULT_VERBOSITY='@AM_DEFAULT_VERBOSITY@';require "@top_srcdir@/src/perl/Makefile_silent.pm";
WriteMakefile('NAME' => 'Irssi',
- 'LIBS' => '',
+ 'LIBS' => '-L@TERMUX_PREFIX@/lib -lperl -lglib-2.0',
'OBJECT' => '$(O_FILES)',
'INC' => '-I../../.. -I@top_srcdir@ -I@top_srcdir@/src -I@top_srcdir@/src/core @GLIB_CFLAGS@',
'VERSION_FROM' => '@srcdir@/Irssi.pm');
diff -uNr irssi-1.2.2/src/perl/irc/Makefile.PL.in irssi-1.2.2.mod/src/perl/irc/Makefile.PL.in
--- irssi-1.2.2/src/perl/irc/Makefile.PL.in 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/irc/Makefile.PL.in 2020-01-03 17:29:19.232854109 +0200
@@ -1,7 +1,7 @@
use ExtUtils::MakeMaker;our $AM_DEFAULT_VERBOSITY='@AM_DEFAULT_VERBOSITY@';require "@top_srcdir@/src/perl/Makefile_silent.pm";
WriteMakefile('NAME' => 'Irssi::Irc',
- 'LIBS' => '',
+ 'LIBS' => '-L@TERMUX_PREFIX@/lib -lperl -lglib-2.0',
'OBJECT' => '$(O_FILES)',
'TYPEMAPS' => ['../common/typemap'],
'INC' => '-I../../.. -I@top_srcdir@/src -I@top_srcdir@/src/core -I@top_srcdir@/src/irc/core -I@top_srcdir@/src/irc @GLIB_CFLAGS@',
diff -uNr irssi-1.2.2/src/perl/Makefile.am irssi-1.2.2.mod/src/perl/Makefile.am
--- irssi-1.2.2/src/perl/Makefile.am 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/Makefile.am 2020-01-03 17:00:24.640885164 +0200
@@ -56,7 +56,7 @@
$(perl_fe_sources)
perl-signals-list.h: $(top_srcdir)/docs/signals.txt $(srcdir)/get-signals.pl
- cat $(top_srcdir)/docs/signals.txt | $(perlpath) $(srcdir)/get-signals.pl > perl-signals-list.h
+ cat $(top_srcdir)/docs/signals.txt | perl $(srcdir)/get-signals.pl > perl-signals-list.h
irssi-core.pl.h: irssi-core.pl
$(top_srcdir)/utils/file2header.sh $(srcdir)/irssi-core.pl irssi_core_code > irssi-core.pl.h
@@ -136,10 +136,10 @@
$(AM_V_GEN)for dir in $(perl_dirs); do \
cd $$dir && \
if [ ! -f Makefile ]; then \
- $(am_v_pl__show_gen)$(perlpath) Makefile.PL $(PERL_MM_PARAMS) $(am_v_pl__hide_gen); \
+ $(am_v_pl__show_gen)perl Makefile.PL $(PERL_MM_PARAMS) $(am_v_pl__hide_gen); \
fi && \
- ($(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
- $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
+ ($(MAKE) CC="$(CC)" LD="$(CC) -Wl,-rpath=@TERMUX_PREFIX@/lib,--enable-new-dtags" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
+ $(MAKE) CC="$(CC)" LD="$(CC) -Wl,-rpath=@TERMUX_PREFIX@/lib,--enable-new-dtags" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
cd ..; \
done
diff -uNr irssi-1.2.2/src/perl/Makefile.in irssi-1.2.2.mod/src/perl/Makefile.in
--- irssi-1.2.2/src/perl/Makefile.in 2019-08-29 16:49:03.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/Makefile.in 2020-01-03 17:00:24.641885171 +0200
@@ -880,7 +880,7 @@
perl-signals.lo: perl-signals-list.h
perl-signals-list.h: $(top_srcdir)/docs/signals.txt $(srcdir)/get-signals.pl
- cat $(top_srcdir)/docs/signals.txt | $(perlpath) $(srcdir)/get-signals.pl > perl-signals-list.h
+ cat $(top_srcdir)/docs/signals.txt | perl $(srcdir)/get-signals.pl > perl-signals-list.h
irssi-core.pl.h: irssi-core.pl
$(top_srcdir)/utils/file2header.sh $(srcdir)/irssi-core.pl irssi_core_code > irssi-core.pl.h
@@ -889,10 +889,10 @@
$(AM_V_GEN)for dir in $(perl_dirs); do \
cd $$dir && \
if [ ! -f Makefile ]; then \
- $(am_v_pl__show_gen)$(perlpath) Makefile.PL $(PERL_MM_PARAMS) $(am_v_pl__hide_gen); \
+ $(am_v_pl__show_gen)perl Makefile.PL $(PERL_MM_PARAMS) $(am_v_pl__hide_gen); \
fi && \
- ($(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
- $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
+ ($(MAKE) CC="$(CC)" LD="$(CC) -Wl,-rpath=@TERMUX_PREFIX@/lib,--enable-new-dtags" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS) || \
+ $(MAKE) CC="$(CC)" LD="$(CC) -Wl,-rpath=@TERMUX_PREFIX@/lib,--enable-new-dtags" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
cd ..; \
done
diff -uNr irssi-1.2.2/src/perl/textui/Makefile.PL.in irssi-1.2.2.mod/src/perl/textui/Makefile.PL.in
--- irssi-1.2.2/src/perl/textui/Makefile.PL.in 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/textui/Makefile.PL.in 2020-01-03 17:29:04.152748835 +0200
@@ -1,7 +1,7 @@
use ExtUtils::MakeMaker;our $AM_DEFAULT_VERBOSITY='@AM_DEFAULT_VERBOSITY@';require "@top_srcdir@/src/perl/Makefile_silent.pm";
WriteMakefile('NAME' => 'Irssi::TextUI',
- 'LIBS' => '',
+ 'LIBS' => '-L@TERMUX_PREFIX@/lib -lperl -lglib-2.0',
'OBJECT' => '$(O_FILES)',
'TYPEMAPS' => ['../common/typemap', '../ui/typemap'],
'INC' => '-I../../.. -I@top_srcdir@/src -I@top_srcdir@/src/core -I@top_srcdir@/src/fe-common/core -I@top_srcdir@/src/fe-text @GLIB_CFLAGS@',
diff -uNr irssi-1.2.2/src/perl/ui/Makefile.PL.in irssi-1.2.2.mod/src/perl/ui/Makefile.PL.in
--- irssi-1.2.2/src/perl/ui/Makefile.PL.in 2019-08-29 16:48:46.000000000 +0300
+++ irssi-1.2.2.mod/src/perl/ui/Makefile.PL.in 2020-01-03 17:28:55.488688351 +0200
@@ -1,7 +1,7 @@
use ExtUtils::MakeMaker;our $AM_DEFAULT_VERBOSITY='@AM_DEFAULT_VERBOSITY@';require "@top_srcdir@/src/perl/Makefile_silent.pm";
WriteMakefile('NAME' => 'Irssi::UI',
- 'LIBS' => '',
+ 'LIBS' => '-L@TERMUX_PREFIX@/lib -lperl -lglib-2.0',
'OBJECT' => '$(O_FILES)',
'TYPEMAPS' => ['../common/typemap'],
'INC' => '-I../../.. -I@top_srcdir@/src -I@top_srcdir@/src/core -I@top_srcdir@/src/fe-common/core @GLIB_CFLAGS@',