nextcloud-client: new package

This commit is contained in:
ZhymabekRoman 2024-04-02 12:43:17 +05:00 committed by TomIO
parent 15cb234cac
commit 44daa020c6
6 changed files with 81 additions and 0 deletions

View File

@ -0,0 +1,10 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,6 +221,7 @@ if(BUILD_CLIENT)
find_package(ZLIB REQUIRED)
find_package(SQLite3 3.9.0 REQUIRED)
+ find_package(Qt5 CONFIG REQUIRED Core DBus)
if(NOT WIN32 AND NOT APPLE)
find_package(PkgConfig REQUIRED)

View File

@ -0,0 +1,11 @@
--- a/cmake/modules/FindInotify.cmake
+++ b/cmake/modules/FindInotify.cmake
@@ -34,7 +34,7 @@ find_path(Inotify_INCLUDE_DIRS sys/inotify.h)
if(Inotify_INCLUDE_DIRS)
# On Linux there is no library to link against, on the BSDs there is.
# On the BSD's, inotify is implemented through a library, libinotify.
- if( CMAKE_SYSTEM_NAME MATCHES "Linux")
+ if( CMAKE_SYSTEM_NAME MATCHES "Android")
set(Inotify_FOUND TRUE)
set(Inotify_LIBRARIES "")
set(Inotify_INCLUDE_DIRS "")

View File

@ -0,0 +1,16 @@
TERMUX_PKG_HOMEPAGE=https://nextcloud.com/
TERMUX_PKG_DESCRIPTION="Command-line client tool for Nextcloud."
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Zhymabek Roman <robanokssamit@yandex.ru>"
TERMUX_PKG_VERSION=3.12.3
TERMUX_PKG_SRCURL="https://github.com/nextcloud/desktop/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz"
TERMUX_PKG_SHA256=9466abfc663dd12bd9fc8e6812fd9c3ef9a685c773a473532294c638c460c00b
TERMUX_PKG_DEPENDS="dbus, dbus-glib, libdbusmenu-qt, qtkeychain, qt5-qtbase, qt5-qttools, inotify-tools, libsqlite, karchive, qt5-qtwebsockets, qt5-qtsvg, qt5-qtwebengine"
TERMUX_PKG_BUILD_DEPENDS="qt5-qtbase-cross-tools, qt5-qttools-cross-tools, pkg-config, qt5-qmake, qt5-qtbase, qt5-qttools"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_GUI=OFF
-DBUILD_SHELL_INTEGRATION=OFF
-DBUILD_UPDATER=OFF
-DTOKEN_AUTH_ONLY=OFF
-DBUILD_TESTING=OFF
"

View File

@ -0,0 +1,15 @@
--- a/src/libsync/ocsprofileconnector.cpp
+++ b/src/libsync/ocsprofileconnector.cpp
@@ -55,9 +55,9 @@ OCC::Optional<QPixmap> createPixmapFromSvgData(const QByteArray &iconData)
return {};
}
QSize imageSize{16, 16};
- if (OCC::Theme::isHidpi()) {
- imageSize = QSize{32, 32};
- }
+ // if (OCC::Theme::isHidpi()) {
+ // imageSize = QSize{32, 32};
+ // }
QImage scaledSvg(imageSize, QImage::Format_ARGB32);
scaledSvg.fill("transparent");
QPainter svgPainter{&scaledSvg};

View File

@ -0,0 +1,16 @@
--- a/src/libsync/theme.cpp
+++ b/src/libsync/theme.cpp
@@ -20,11 +20,12 @@
#include "common/vfs.h"
#include <QtCore>
-#ifndef TOKEN_AUTH_ONLY
#include <QtGui>
+#ifndef TOKEN_AUTH_ONLY
#include <QStyle>
#include <QApplication>
#endif
+#include <QPainterPath>
#include <QSslSocket>
#include <QSvgRenderer>

View File

@ -0,0 +1,13 @@
--- a/src/libsync/creds/tokencredentials.cpp
+++ b/src/libsync/creds/tokencredentials.cpp
@@ -62,8 +62,8 @@ protected:
// A pre-authenticated cookie
QByteArray token = _cred->_token.toUtf8();
if (token.length() > 0) {
- setRawCookie(token, request.url());
- }
+ req.setHeader(QNetworkRequest::CookieHeader, QVariant::fromValue(QList<QNetworkCookie>() << QNetworkCookie::parseCookies(token)));
+ }
return AccessManager::createRequest(op, req, outgoingData);
}