ccache: update to 4.1

This commit is contained in:
Leonid Pliushch 2020-11-23 06:34:52 +00:00
parent f58b5c5ec6
commit 454ca9e012
No known key found for this signature in database
GPG Key ID: 45F2964132545795
2 changed files with 16 additions and 32 deletions

View File

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=https://ccache.samba.org
TERMUX_PKG_DESCRIPTION="Compiler cache for fast recompilation of C/C++ code"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=4.0
TERMUX_PKG_VERSION=4.1
TERMUX_PKG_SRCURL=https://github.com/ccache/ccache/releases/download/v$TERMUX_PKG_VERSION/ccache-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=ac1b82fe0a5e39905945c4d68fcb24bd0f32344869faf647a1b8d31e544dcb88
TERMUX_PKG_SHA256=5fdc804056632d722a1182e15386696f0ea6c59cb4ab4d65a54f0b269ae86f99
TERMUX_PKG_DEPENDS="zlib, zstd"

View File

@ -1,33 +1,3 @@
diff -uNr ccache-4.0/src/hashutil.cpp ccache-4.0.mod/src/hashutil.cpp
--- ccache-4.0/src/hashutil.cpp 2020-10-18 18:55:03.000000000 +0000
+++ ccache-4.0.mod/src/hashutil.cpp 2020-11-22 00:34:12.795660441 +0000
@@ -51,7 +51,7 @@
# undef HAVE_AVX2
#endif
-#ifdef HAVE_AVX2
+#if defined(HAVE_AVX2) && !defined(__ANDROID__)
# include <immintrin.h>
#endif
@@ -123,7 +123,7 @@
return result;
}
-#ifdef HAVE_AVX2
+#if defined(HAVE_AVX2) && !defined(__ANDROID__)
int check_for_temporal_macros_avx2(string_view str)
__attribute__((target("avx2")));
@@ -220,7 +220,7 @@
int
check_for_temporal_macros(string_view str)
{
-#ifdef HAVE_AVX2
+#if defined(HAVE_AVX2) && !defined(__ANDROID__)
if (__builtin_cpu_supports("avx2")) {
return check_for_temporal_macros_avx2(str);
}
diff -uNr ccache-4.0/src/third_party/blake3/CMakeLists.txt ccache-4.0.mod/src/third_party/blake3/CMakeLists.txt
--- ccache-4.0/src/third_party/blake3/CMakeLists.txt 2020-10-18 18:55:03.000000000 +0000
+++ ccache-4.0.mod/src/third_party/blake3/CMakeLists.txt 2020-11-22 00:29:11.795911551 +0000
@ -49,3 +19,17 @@ diff -uNr ccache-4.0/src/third_party/blake3/CMakeLists.txt ccache-4.0.mod/src/th
endfunction()
add_source_if_enabled(sse2 "-msse2")
diff -uNr ccache-4.1/src/hashutil.cpp ccache-4.1.mod/src/hashutil.cpp
--- ccache-4.1/src/hashutil.cpp 2020-11-22 20:00:22.000000000 +0000
+++ ccache-4.1.mod/src/hashutil.cpp 2020-11-23 06:32:36.609734222 +0000
@@ -39,6 +39,10 @@
# include "Win32Util.hpp"
#endif
+#ifdef __ANDROID__
+# undef HAVE_AVX2
+#endif
+
#ifdef HAVE_AVX2
# include <immintrin.h>
#endif