bump(main/mu): 1.12.4

This commit is contained in:
tqfx 2024-04-24 00:26:10 +08:00 committed by Twaik Yont
parent c7ae5e972e
commit 4a12977b35
3 changed files with 29 additions and 18 deletions

View File

@ -2,11 +2,12 @@ TERMUX_PKG_HOMEPAGE=https://www.djcbsoftware.nl/code/mu/
TERMUX_PKG_DESCRIPTION="Maildir indexer/searcher and Emacs client (mu4e)"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="1.10.8"
TERMUX_PKG_VERSION="1.12.4"
TERMUX_PKG_SRCURL=https://github.com/djcb/mu/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=761e074ae4bbf995c93150753be55c8490f3e97c19a31e4289832964a8791bb1
TERMUX_PKG_SHA256=3979873e3817292594041715e5e1e86baf2caf092ee851410f258d3ea9136a79
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="emacs, glib, libc++, libxapian, libgmime"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-Dtests=disabled"
termux_step_create_debscripts() {
cat <<- EOF > ./postinst

View File

@ -0,0 +1,11 @@
--- ./lib/mu-scanner.cc 2024-04-24 01:28:29.784265224 +0800
+++ ./lib/mu-scanner.cc 2024-04-24 01:28:49.252970705 +0800
@@ -46,7 +46,7 @@
struct dentry_t {
dentry_t(const struct dirent *dentry):
#if HAVE_DIRENT_D_INO
- d_ino{dentry->d_ino},
+ d_ino{static_cast<ino_t>(dentry->d_ino)},
#endif /*HAVE_DIRENT_D_INO*/
#if HAVE_DIRENT_D_TYPE

View File

@ -1,30 +1,29 @@
# Patch meson to copy mu4e source files even if emacs was not found.
--- ./meson.build.orig 2022-07-06 09:38:17.491018593 +0530
+++ ./meson.build 2022-07-06 09:39:41.161018561 +0530
@@ -196,7 +196,7 @@
message('emacs not found; not generating manpages')
endif
@@ -274,9 +274,7 @@
# emacs -- needed for mu4e compilation
emacs_name=get_option('emacs')
emacs_min_version='26.3'
-emacs=find_program([emacs_name], version: '>='+emacs_min_version, required:false)
-if emacs.found()
- subdir('man')
+if true
subdir('mu4e')
subdir('mu4e')
else
message('emacs not found; not preparing mu4e support')
message('emacs not found; not pre-compiling mu4e / generating manpages')
--- ./mu4e/meson.build.orig 2022-07-06 09:21:53.456610752 +0530
+++ ./mu4e/meson.build 2022-07-06 09:36:08.601018642 +0530
@@ -73,6 +73,7 @@
install_mode: 'r--r--r--')
endforeach
@@ -75,6 +75,7 @@ mu4e_srcs=[
#
#... so let's not do that!
+if false
foreach src : mu4e_srcs
target_name= '@BASENAME@.elc'
target_path = join_paths(meson.current_build_dir(), target_name)
@@ -100,6 +101,7 @@
'--eval', target_func,
'--funcall', 'batch-byte-compile', '@INPUT@'])
endforeach
@@ -117,6 +118,7 @@ mu4e_autoloads = configure_file(
'--load', 'package',
'--eval', '(package-generate-autoloads "mu4e" "' +
meson.current_build_dir() + '" )'])
+endif
# also install the sources and the config
install_data(mu4e_srcs, install_dir: mu4e_lispdir)