mv games to game-repo

This commit is contained in:
Henrik Grimler 2019-03-16 16:55:13 +01:00 committed by Fredrik Fornwall
parent 172a6f9aa9
commit 4f48187eb2
32 changed files with 0 additions and 898 deletions

View File

@ -1,19 +0,0 @@
TERMUX_PKG_HOMEPAGE=http://rephial.org/
TERMUX_PKG_DESCRIPTION="Dungeon exploration adventure game"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=4.1.3
TERMUX_PKG_SHA256=9402c4f8da691edbd4567a948c5663e1066bee3fcb4a62fbcf86b5454918406f
TERMUX_PKG_SRCURL=http://rephial.org/downloads/4.1/angband-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-x11 --bindir=$TERMUX_PREFIX/bin --sysconfdir=$TERMUX_PREFIX/share/angband"
TERMUX_PKG_RM_AFTER_INSTALL="share/angband/xtra share/angband/icons"
termux_step_pre_configure() {
./autogen.sh
perl -p -i -e 's|ncursesw5-config|ncursesw6-config|g' configure
}
termux_step_post_make_install() {
rm -Rf $TERMUX_PREFIX/share/angband/{fonts,sounds}
}

View File

@ -1,25 +0,0 @@
diff -u -r ../angband-master/src/main.c ./src/main.c
--- ../angband-master/src/main.c 2017-06-25 04:10:53.000000000 +0000
+++ ./src/main.c 2017-07-16 16:38:58.187988465 +0000
@@ -35,7 +35,9 @@
* locale junk
*/
#include "locale.h"
+#ifndef __ANDROID__
#include "langinfo.h"
+#endif
/**
* Some machines have a "main()" function in their "main-xxx.c" file,
@@ -466,9 +468,11 @@
ANGBAND_SYS = mstr;
if (setlocale(LC_CTYPE, "")) {
+#ifndef __ANDROID__
/* Require UTF-8 */
if (strcmp(nl_langinfo(CODESET), "UTF-8") != 0)
quit("Angband requires UTF-8 support");
+#endif
}
/* Try the modules in the order specified by modules[] */

View File

@ -1,17 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://sites.google.com/site/broguegame/
TERMUX_PKG_DESCRIPTION="Roguelike dungeon crawling game"
TERMUX_PKG_LICENSE="AGPL-V3"
TERMUX_PKG_VERSION=1.7.5
TERMUX_PKG_SHA256=a74ff18139564c597d047cfb167f74ab1963dd8608b6fb2e034e7635d6170444
TERMUX_PKG_SRCURL=https://sites.google.com/site/broguegame/brogue-${TERMUX_PKG_VERSION}-linux-amd64.tbz2
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_EXTRA_MAKE_ARGS="curses"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS"
}
termux_step_make_install() {
cp bin/brogue $TERMUX_PREFIX/bin
}

View File

@ -1,28 +0,0 @@
In Android the <sys/timeb.h> header and associated ftime(3) has been
removed in android-21 since it is deprecated and removed from POSIX.
diff -u -r ../brogue-1.7.4/src/platform/curses-platform.c ./src/platform/curses-platform.c
--- ../brogue-1.7.4/src/platform/curses-platform.c 2014-07-03 15:19:10.000000000 -0400
+++ ./src/platform/curses-platform.c 2014-12-20 03:47:20.303572495 -0500
@@ -3,7 +3,7 @@
#include <string.h>
#include <time.h>
#include "term.h"
-#include <sys/timeb.h>
+#include <sys/time.h>
#include <stdint.h>
#include <signal.h>
#include "platform.h"
@@ -109,9 +109,9 @@
#define PAUSE_BETWEEN_EVENT_POLLING 34//17
static uint32_t getTime() {
- struct timeb time;
- ftime(&time);
- return 1000 * time.time + time.millitm;
+ struct timeval tv;
+ gettimeofday(&tv, NULL);
+ return 1000 * tv.tv_sec + tv.tv_usec / 1000;
}
static boolean curses_pauseForMilliseconds(short milliseconds) {

View File

@ -1,12 +0,0 @@
--- ../brogue-linux-1.7.3/brogue-1.7.3/Makefile 2013-09-11 07:38:48.000000000 +0200
+++ ./Makefile 2014-01-28 07:57:06.000000000 +0100
@@ -81,7 +81,7 @@
.PHONY : clean both curses tcod tar
bin/brogue : ${DEPENDENCIES} ${BROGUEFILES}
- $(CC) -O2 -march=i586 -o bin/brogue ${BROGUEFILES} ${LIBRARIES} -Wl,-rpath,.
+ $(CC) -o bin/brogue ${BROGUEFILES} ${LIBRARIES} -Wl,-rpath,.
clean :
rm -f src/brogue/*.o src/platform/*.o bin/brogue

View File

@ -1,11 +0,0 @@
diff -u -r ../brogue-1.7.4/src/platform/platformdependent.c ./src/platform/platformdependent.c
--- ../brogue-1.7.4/src/platform/platformdependent.c 2014-07-03 19:19:10.000000000 +0000
+++ ./src/platform/platformdependent.c 2017-07-07 07:09:10.116242335 +0000
@@ -21,6 +21,7 @@
* along with Brogue. If not, see <http://www.gnu.org/licenses/>.
*/
+#include <ctype.h>
#include <stdio.h>
#include <string.h>
#include <time.h>

View File

@ -1,14 +0,0 @@
TERMUX_PKG_HOMEPAGE=http://a-nikolaev.github.io/curseofwar/
TERMUX_PKG_DESCRIPTION="Fast-paced action strategy game focusing on high-level strategic planning"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_VERSION=1.2.0
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://github.com/a-nikolaev/curseofwar/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=91b7781e26341faa6b6999b6baf6e74ef532fa94303ab6a2bf9ff6d614a3f670
termux_step_make_install() {
mkdir -p $TERMUX_PREFIX/share/man/man6
cp curseofwar $TERMUX_PREFIX/bin
cp $TERMUX_PKG_SRCDIR/curseofwar.6 $TERMUX_PREFIX/share/man/man6
}

View File

@ -1,11 +0,0 @@
diff -u -r ../curseofwar-1.2.0/network.h ./network.h
--- ../curseofwar-1.2.0/network.h 2013-08-16 07:57:44.000000000 +0200
+++ ./network.h 2014-01-29 01:09:19.000000000 +0100
@@ -28,6 +28,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <arpa/inet.h>
#define MSG_BUF_SIZE 50000

View File

@ -1,9 +0,0 @@
diff -u -r ../curseofwar-1.2.0/Makefile ./Makefile
--- ../curseofwar-1.2.0/Makefile 2013-08-16 07:57:44.000000000 +0200
+++ ./Makefile 2014-01-29 01:07:04.000000000 +0100
@@ -1,5 +1,4 @@
SHELL = /bin/sh
-CC = gcc
INSTALL = install
EXEC_NCURSES = curseofwar
EXEC_SDL = curseofwar-sdl

View File

@ -1,25 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://github.com/DavidGriffith/frotz
TERMUX_PKG_DESCRIPTION="Interpreter for Infocom and other Z-machine interactive fiction (IF) games"
TERMUX_PKG_LICENSE="GPL-2.0"
# frotz does not depend on dialog or curl, but the zgames script we bundle below in termux_step_make_install() do.
TERMUX_PKG_DEPENDS="ncurses, dialog, curl"
TERMUX_PKG_VERSION=2.44
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/DavidGriffith/frotz/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=dbb5eb3bc95275dcb984c4bdbaea58bc1f1b085b20092ce6e86d9f0bf3ba858f
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
# Pull request submitted to replace rindex() with strrchr() at
# https://github.com/DavidGriffith/frotz/pull/20
CFLAGS+=" -Drindex=strrchr"
}
termux_step_make() {
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS" PREFIX=$TERMUX_PREFIX make -j $TERMUX_MAKE_PROCESSES install
}
termux_step_make_install() {
cp $TERMUX_PKG_BUILDER_DIR/zgames $TERMUX_PREFIX/bin/zgames
chmod +x $TERMUX_PREFIX/bin/zgames
}

View File

@ -1,99 +0,0 @@
diff -u -r ../frotz-2.43d/Makefile ./Makefile
--- ../frotz-2.43d/Makefile 2012-01-03 09:32:58.000000000 +0100
+++ ./Makefile 2014-03-06 22:50:06.580642826 +0100
@@ -1,22 +1,22 @@
# Define your C compiler. I recommend gcc if you have it.
# MacOS users should use "cc" even though it's really "gcc".
#
-CC = gcc
+#CC = gcc
#CC = cc
# Define your optimization flags. Most compilers understand -O and -O2,
# Standard (note: Solaris on UltraSparc using gcc 2.8.x might not like this.)
#
-OPTS = -O2
+OPTS = -Os
# Pentium with gcc 2.7.0 or better
#OPTS = -O2 -fomit-frame-pointer -malign-functions=2 -malign-loops=2 \
#-malign-jumps=2
# Define where you want Frotz installed. Usually this is /usr/local
-PREFIX = /usr/local
+#PREFIX = /usr/local
-MAN_PREFIX = $(PREFIX)
+MAN_PREFIX = $(PREFIX)/share
#MAN_PREFIX = /usr/local/share
CONFIG_DIR = $(PREFIX)/etc
@@ -24,7 +24,7 @@
# Define where you want Frotz to look for frotz.conf.
#
-CONFIG_DIR = /usr/local/etc
+#CONFIG_DIR = /usr/local/etc
#CONFIG_DIR = /etc
#CONFIG_DIR = /usr/pkg/etc
#CONFIG_DIR =
@@ -73,8 +73,8 @@
# curses library won't work, comment out the first option and uncomment
# the second.
#
-CURSES = -lcurses
-#CURSES = -lncurses
+#CURSES = -lcurses
+CURSES = -lncurses
# Uncomment this if your need to use ncurses instead of the
# vendor-supplied curses library. This just tells the compile process
@@ -187,24 +187,24 @@
$(COMMON_TARGET): $(COMMON_OBJECT)
@echo
@echo "Archiving common code..."
- ar rc $(COMMON_TARGET) $(COMMON_OBJECT)
- ranlib $(COMMON_TARGET)
+ $(AR) rc $(COMMON_TARGET) $(COMMON_OBJECT)
+ $(RANLIB) $(COMMON_TARGET)
@echo
curses_lib: config_curses $(CURSES_TARGET)
$(CURSES_TARGET): $(CURSES_OBJECT)
@echo
@echo "Archiving curses interface code..."
- ar rc $(CURSES_TARGET) $(CURSES_OBJECT)
- ranlib $(CURSES_TARGET)
+ $(AR) rc $(CURSES_TARGET) $(CURSES_OBJECT)
+ $(RANLIB) $(CURSES_TARGET)
@echo
dumb_lib: $(DUMB_TARGET)
$(DUMB_TARGET): $(DUMB_OBJECT)
@echo
@echo "Archiving dumb interface code..."
- ar rc $(DUMB_TARGET) $(DUMB_OBJECT)
- ranlib $(DUMB_TARGET)
+ $(AR) rc $(DUMB_TARGET) $(DUMB_OBJECT)
+ $(RANLIB) $(DUMB_TARGET)
@echo
soundcard.h:
@@ -213,7 +213,7 @@
fi
install: $(NAME)
- strip $(BINNAME)$(EXTENSION)
+ $(STRIP) $(BINNAME)$(EXTENSION)
install -d $(PREFIX)/bin
install -d $(MAN_PREFIX)/man/man6
install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
@@ -226,7 +226,7 @@
deinstall: uninstall
install_dumb: d$(NAME)
- strip d$(BINNAME)$(EXTENSION)
+ $(STRIP) d$(BINNAME)$(EXTENSION)
install -d $(PREFIX)/bin
install -d $(MAN_PREFIX)/man/man6
install -c -m 755 d$(BINNAME)$(EXTENSION) $(PREFIX)/bin

View File

@ -1,88 +0,0 @@
# Lots of resources at: http://www.ifarchive.org/indexes/if-archiveXgamesXzcode.html
set -e -u
FG_FOLDER=$HOME/.zgames
mkdir -p $FG_FOLDER
FG_TMPFILE=$FG_FOLDER/tmp
#--backtitle "Frotz games" \
set +e
dialog \
--title "Select Game" --clear \
--radiolist "Select game to play" 0 0 0 \
"Adventure" "Welcome to Adventure" off \
"Castle Adventure!" "Old-school style" off \
"Zork I" "The game that started it all" off \
"Zork II" "The next step downward to danger" off \
"Zork III" "It all comes down to this" off \
"Super Z Trek" "The classic Star Trek" off \
"The Hitchhiker's Guide to the Galaxy" "Don't Panic!" off \
"zRogue" "Port of the classic game Rogue" off \
"Z Racer" "Real-time racing game" off \
2> $FG_TMPFILE
retval=$?
set -e
clear
case $retval in
0)
FG_GAME=`cat $FG_TMPFILE`;;
1)
# Cancel pressed
exit;;
255)
# Esc pressed
exit;;
esac
case $FG_GAME in
"Adventure")
FG_FILEDOWNLOAD=http://www.dwheeler.com/adventure/Advent.z5
FG_GAMEFOLDER=$FG_FOLDER/adventure;;
"Castle Adventure!")
FG_FILEDOWNLOAD=http://www.ifarchive.org/if-archive/games/zcode/castle.z8
FG_GAMEFOLDER=$FG_FOLDER/castle_adventure;;
"Zork I")
FG_FILEDOWNLOAD=http://www.infocom-if.org/downloads/zork1.zip
FG_GAMEFILE=DATA/ZORK1.DAT
FG_GAMEFOLDER=$FG_FOLDER/zork1;;
"Zork II")
FG_FILEDOWNLOAD=http://www.infocom-if.org/downloads/zork2.zip
FG_GAMEFILE=DATA/ZORK2.DAT
FG_GAMEFOLDER=$FG_FOLDER/zork2;;
"Zork III")
FG_FILEDOWNLOAD=http://www.infocom-if.org/downloads/zork3.zip
FG_GAMEFILE=DATA/ZORK3.DAT
FG_GAMEFOLDER=$FG_FOLDER/zork3;;
"Super Z Trek")
FG_FILEDOWNLOAD=http://www.ifarchive.org/if-archive/games/zcode/ztrek.z5
FG_GAMEFOLDER=$FG_FOLDER/superztrek;;
"The Hitchhiker's Guide to the Galaxy")
FG_FILEDOWNLOAD=http://www.douglasadams.com/creations/hhgg.z3
FG_GAMEFOLDER=$FG_FOLDER/hhgg;;
"zRogue")
FG_FILEDOWNLOAD=http://www.ifarchive.org/if-archive/games/zcode/rogue.z5
FG_GAMEFOLDER=$FG_FOLDER/zrogue;;
"Z Racer")
FG_FILEDOWNLOAD=http://www.ifarchive.org/if-archive/games/zcode/zracer.z5
FG_GAMEFOLDER=$FG_FOLDER/zracer;;
*)
exit;;
esac
FG_FILENAME=`basename $FG_FILEDOWNLOAD`
mkdir -p $FG_GAMEFOLDER/saves
cd $FG_GAMEFOLDER
if [ ! -f $FG_FILENAME ]; then
curl $FG_FILEDOWNLOAD -o $FG_FILENAME
if [ "${FG_FILENAME#*.}" = "zip" ]; then
unzip $FG_FILENAME;
fi
fi
if [ "${FG_FILENAME#*.}" != "zip" ]; then FG_GAMEFILE=`basename $FG_FILEDOWNLOAD`; fi
cd saves
frotz ../$FG_GAMEFILE

View File

@ -1,29 +0,0 @@
TERMUX_PKG_HOMEPAGE=http://www.eblong.com/zarf/glulx/
TERMUX_PKG_DESCRIPTION="Interpreter for the Glulx portable VM for interactive fiction (IF) games"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=0.5.4
TERMUX_PKG_SRCURL=http://www.eblong.com/zarf/glulx/glulxe-051.tar.gz
TERMUX_PKG_SHA256=33c563bdbd0fdbae625e1a2441e9a6f40f1491f1cdc2a197bbd6cf2c32c3830d
TERMUX_PKG_BUILD_IN_SRC="yes"
TERMUX_PKG_DEPENDS="ncurses"
termux_step_configure() {
termux_download http://eblong.com/zarf/glk/glktermw-104.tar.gz \
$TERMUX_PKG_CACHEDIR/glktermw-104.tar.gz \
5968630b45e2fd53de48424559e3579db0537c460f4dc2631f258e1c116eb4ea
tar xf $TERMUX_PKG_CACHEDIR/glktermw-104.tar.gz
}
termux_step_make() {
cd $TERMUX_PKG_SRCDIR/glkterm
patch -p1 < $TERMUX_PKG_BUILDER_DIR/glkterm.patch.special
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS" PREFIX=$TERMUX_PREFIX make -j 1
cd ..
make
cp glulxe $TERMUX_PREFIX/bin
}
termux_step_make_install() {
echo "Do nothing..."
}

View File

@ -1,80 +0,0 @@
diff -u -r ../../glkterm/Makefile ./Makefile
--- ../../glkterm/Makefile 2012-10-14 19:21:09.000000000 +0200
+++ ./Makefile 2014-02-15 13:43:48.000000000 +0100
@@ -10,21 +10,21 @@
# Pick a C compiler.
#CC = cc
-CC = gcc -ansi
+#CC = gcc -ansi
# You may need to set directories to pick up the ncursesw library.
#INCLUDEDIRS = -I/usr/5include
#LIBDIRS = -L/usr/5lib
-LIBS = -lncursesw
+LIBS = $(LDFLAGS) -lncursesw
# Use this LIBS line instead of the above if you do not have ncursesw
# available. For example, on a standard Mac OSX setup. (You will
# probably also have to set LOCAL_NCURSESW in CFLAGS or in gtoption.h.)
#LIBS = -lncurses
-OPTIONS = -g -Wall
+#OPTIONS = -g -Wall
-CFLAGS = $(OPTIONS) $(INCLUDEDIRS)
+#CFLAGS = $(OPTIONS) $(INCLUDEDIRS)
GLKLIB = libglktermw.a
@@ -44,8 +44,8 @@
cgunicod.o: cgunigen.c
$(GLKLIB): $(GLKTERM_OBJS)
- ar r $(GLKLIB) $(GLKTERM_OBJS)
- ranlib $(GLKLIB)
+ $(AR) r $(GLKLIB) $(GLKTERM_OBJS)
+ $(RANLIB) $(GLKLIB)
Make.glktermw:
echo LINKLIBS = $(LIBDIRS) $(LIBS) > Make.glktermw
diff -u -r ../../glkterm/cgdate.c ./cgdate.c
--- ../../glkterm/cgdate.c 2012-10-14 19:21:09.000000000 +0200
+++ ./cgdate.c 2014-02-15 13:45:27.000000000 +0100
@@ -7,6 +7,24 @@
#include "glk.h"
#include "glkterm.h"
+#ifdef __ANDROID__
+time_t timegm (struct tm *tm) {
+ time_t ret;
+ char *tz;
+
+ tz = getenv("TZ");
+ setenv("TZ", "", 1);
+ tzset();
+ ret = mktime(tm);
+ if (tz)
+ setenv("TZ", tz, 1);
+ else
+ unsetenv("TZ");
+ tzset();
+ return ret;
+}
+#endif
+
/* This file is copied directly from the cheapglk package.
(Except that warning string constants are changed to L"..." constants.) */
diff -u -r ../../glkterm/gtncursesw.c ./gtncursesw.c
--- ../../glkterm/gtncursesw.c 2012-10-14 19:21:09.000000000 +0200
+++ ./gtncursesw.c 2014-02-15 13:43:48.000000000 +0100
@@ -92,7 +92,7 @@
#else /* LOCAL_NCURSESW */
#define _XOPEN_SOURCE_EXTENDED /* ncursesw *wch* and *wstr* functions */
-#include <ncursesw/ncurses.h>
+#include <ncurses.h>
int local_get_wch (wint_t *ch)
{

View File

@ -1,27 +0,0 @@
diff -u -r ../glulxe/Makefile ./Makefile
--- ../glulxe/Makefile 2013-03-11 03:09:38.000000000 +0100
+++ ./Makefile 2014-02-15 13:42:39.000000000 +0100
@@ -7,9 +7,9 @@
# sets of values appear below; uncomment one of them and change the
# directories appropriately.
-GLKINCLUDEDIR = ../cheapglk
-GLKLIBDIR = ../cheapglk
-GLKMAKEFILE = Make.cheapglk
+GLKINCLUDEDIR = glkterm
+GLKLIBDIR = glkterm
+GLKMAKEFILE = Make.glktermw
#GLKINCLUDEDIR = ../glkterm
#GLKLIBDIR = ../glkterm
@@ -25,9 +25,8 @@
# Pick a C compiler.
#CC = cc
-CC = gcc
-OPTIONS = -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused -DOS_UNIX
+OPTIONS := $(CFLAGS) -DOS_UNIX
include $(GLKINCLUDEDIR)/$(GLKMAKEFILE)

View File

@ -1,23 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/gnugo/
TERMUX_PKG_DESCRIPTION="Program that plays the game of Go"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=3.8
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/gnugo/gnugo-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=da68d7a65f44dcf6ce6e4e630b6f6dd9897249d34425920bfdd4e07ff1866a72
TERMUX_PKG_DEPENDS="ncurses, readline"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-readline"
TERMUX_PKG_HOSTBUILD=yes
termux_step_pre_configure() {
CFLAGS+=" -Wno-overflow"
}
termux_step_post_configure() {
cp $TERMUX_PKG_HOSTBUILD_DIR/patterns/mkeyes $TERMUX_PKG_BUILDDIR/patterns/mkeyes
cp $TERMUX_PKG_HOSTBUILD_DIR/patterns/uncompress_fuseki $TERMUX_PKG_BUILDDIR/patterns/uncompress_fuseki
cp $TERMUX_PKG_HOSTBUILD_DIR/patterns/joseki $TERMUX_PKG_BUILDDIR/patterns/joseki
cp $TERMUX_PKG_HOSTBUILD_DIR/patterns/mkmcpat $TERMUX_PKG_BUILDDIR/patterns/mkmcpat
cp $TERMUX_PKG_HOSTBUILD_DIR/patterns/mkpat $TERMUX_PKG_BUILDDIR/patterns/mkpat
touch -d "next hour" $TERMUX_PKG_BUILDDIR/patterns/*
}

View File

@ -1,21 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/gnushogi/
TERMUX_PKG_DESCRIPTION="Program that plays the game of Shogi, also known as Japanese Chess"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=1.4.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/gnushogi/gnushogi-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1ecc48a866303c63652552b325d685e7ef5e9893244080291a61d96505d52b29
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_lib_curses_clrtoeol=yes --with-curses"
TERMUX_PKG_RM_AFTER_INSTALL="info/gnushogi.info"
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_HOSTBUILD=yes
termux_step_pre_configure() {
CFLAGS+=" $CPPFLAGS"
}
termux_step_post_configure() {
cp $TERMUX_PKG_HOSTBUILD_DIR/gnushogi/pat2inc $TERMUX_PKG_BUILDDIR/gnushogi/pat2inc
# Update timestamps so that the binaries does not get rebuilt:
touch -d "next hour" $TERMUX_PKG_BUILDDIR/gnushogi/pat2inc
}

View File

@ -1,21 +0,0 @@
diff -u -r ../gnushogi-1.4.2/gnushogi/Makefile.in ./gnushogi/Makefile.in
--- ../gnushogi-1.4.2/gnushogi/Makefile.in 2014-02-17 21:26:59.000000000 +0100
+++ ./gnushogi/Makefile.in 2014-03-10 00:07:58.821997498 +0100
@@ -54,7 +54,7 @@
LIBDIR = $(prefix)/lib/$(PROGNAME)
# Where the man page goes.
-MANDIR = $(prefix)/man/man6
+MANDIR = @mandir@/man6
# Where the info file goes.
INFODIR = $(prefix)/info
@@ -241,7 +241,7 @@
#
install: $(PROGNAME)
- strip $(PROGNAME)
+ $(STRIP) $(PROGNAME)
$(INSTALL_PROGRAM) -d $(BINDIR)
$(INSTALL_PROGRAM) -d $(LIBDIR)
$(INSTALL_PROGRAM) -d $(MANDIR)

View File

@ -1,12 +0,0 @@
diff -u -r ../gnushogi-1.4.2/configure ./configure
--- ../gnushogi-1.4.2/configure 2014-02-17 21:30:14.000000000 +0100
+++ ./configure 2014-02-25 23:37:49.000000000 +0100
@@ -3315,7 +3315,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_curses_clrtoeol" >&5
$as_echo "$ac_cv_lib_curses_clrtoeol" >&6; }
if test "x$ac_cv_lib_curses_clrtoeol" = xyes; then :
- LIBCURSES=-lcurses
+ LIBCURSES=-lncurses
CURSESDSP=cursesdsp.o

View File

@ -1,8 +0,0 @@
TERMUX_PKG_HOMEPAGE=http://www.catb.org/~esr/greed/
TERMUX_PKG_DESCRIPTION="Game where you try to eat as much as possible of the board before munching yourself into a corner"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=4.2
TERMUX_PKG_SRCURL=http://www.catb.org/~esr/greed/greed-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=702bc0314ddedb2ba17d4b55d873384a1606886e8d69f35ce67f6e3024a8d3fd
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes

View File

@ -1,12 +0,0 @@
diff -u -r ../greed-3.9/greed.c ./greed.c
--- ../greed-3.9/greed.c 2013-10-23 18:40:41.000000000 +0200
+++ ./greed.c 2014-02-22 11:00:49.000000000 +0100
@@ -69,7 +69,7 @@
/* rnd() returns a random number between 1 and x */
#define rnd(x) (int) ((lrand48() % (x))+1)
-#define LOCKPATH "/tmp/Greed.lock" /* lock path for high score file */
+#define LOCKPATH "@TERMUX_PREFIX@/tmp/Greed.lock" /* lock path for high score file */
/*
* changing stuff in this struct

View File

@ -1,29 +0,0 @@
diff -u -r ../greed-3.9/Makefile ./Makefile
--- ../greed-3.9/Makefile 2013-10-23 18:57:16.000000000 +0200
+++ ./Makefile 2014-02-12 14:33:14.000000000 +0100
@@ -2,12 +2,12 @@
VERS=3.9
-SFILE=/usr/games/lib/greed.hs
+SFILE=@TERMUX_PREFIX@/var/greed.hs
# Location of game executable
-BIN=/usr/games
+BIN=@TERMUX_PREFIX@/bin
greed: greed.c
- $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -DSCOREFILE=\"$(SFILE)\" -DRELEASE=\"$(VERS)\" -o greed greed.c -O3 -lcurses
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -DSCOREFILE=\"$(SFILE)\" -DRELEASE=\"$(VERS)\" -o greed greed.c -lncurses
greed.6: greed.xml
xmlto man greed.xml
@@ -17,7 +17,8 @@
install: greed.6 uninstall
cp greed $(BIN)
- cp greed.6 /usr/share/man/man6/greed.6
+ mkdir -p @TERMUX_PREFIX@/share/man/man6
+ cp greed.6 @TERMUX_PREFIX@/share/man/man6/greed.6
uninstall:
rm -f $(BIN)/install /usr/share/man/man6/greed.6

View File

@ -1,17 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://github.com/seehuhn/moon-buggy
TERMUX_PKG_DESCRIPTION="Simple game where you drive a car across the moon's surface"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_VERSION=1.0.51
TERMUX_PKG_REVISION=1
# Main site down 2017-01-06.
# TERMUX_PKG_SRCURL=http://m.seehuhn.de/programs/moon-buggy-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SRCURL=ftp://ftp.netbsd.org/pub/pkgsrc/distfiles/moon-buggy-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=352dc16ccae4c66f1e87ab071e6a4ebeb94ff4e4f744ce1b12a769d02fe5d23f
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--sharedstatedir=$TERMUX_PREFIX/var"
termux_step_make_install() {
mkdir -p $TERMUX_PREFIX/share/man/man6
cp moon-buggy $TERMUX_PREFIX/bin
cp moon-buggy.6 $TERMUX_PREFIX/share/man/man6
}

View File

@ -1,25 +0,0 @@
diff -u -r ../moon-buggy-1.0.51/realname.c ./realname.c
--- ../moon-buggy-1.0.51/realname.c 2006-03-19 20:28:18.000000000 +0100
+++ ./realname.c 2014-02-22 18:14:49.000000000 +0100
@@ -37,18 +37,9 @@
char *tmp;
if (buffer[0] == '\0') {
- uid_t me = geteuid ();
- struct passwd *my_passwd = getpwuid (me);
- if (my_passwd) {
- int i;
- strncpy (buffer, my_passwd->pw_gecos, size);
- for (i=0; i<size; ++i) {
- if (buffer[i] == ',') {
- buffer[i] = '\0';
- break;
- }
- }
- }
+ char* name_default = getenv("USER");
+ if (name_default == NULL) name_default = "Droid";
+ strncpy(buffer, name_default, size);
}
werase (message);

View File

@ -1,24 +0,0 @@
TERMUX_PKG_HOMEPAGE=http://remarque.org/~grabiner/moria.html
TERMUX_PKG_DESCRIPTION="Rogue-like game with an infinite dungeon"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=5.6
TERMUX_PKG_MAINTAINER="Oliver Schmidhauser @Neo-Oli"
# This seems to be a pretty good mirror
TERMUX_PKG_SRCURL=https://github.com/HunterZ/umoria/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1ee52ec001539945139b2960e8441f490d2b7f5fe6dce5a070686a178515d182
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
ln -s $TERMUX_PKG_SRCDIR/source/* $TERMUX_PKG_SRCDIR/
ln -s $TERMUX_PKG_SRCDIR/unix/* $TERMUX_PKG_SRCDIR/
mkdir -p $TERMUX_PREFIX/share/man/man6/
cp $TERMUX_PKG_SRCDIR/doc/moria.man $TERMUX_PREFIX/share/man/man6/moria.6
}
termux_step_create_debscripts() {
# Create scores file in a debscript, so an update to the package wouldn't erease any scores
echo "mkdir -p $TERMUX_PREFIX/var/games/moria/" > postinst
echo "touch $TERMUX_PREFIX/var/games/moria/scores" >> postinst
chmod 0755 postinst
}

View File

@ -1,45 +0,0 @@
diff --git a/source/config.h b/source/config.h
index bd64c8f..b0b7911 100644
--- a/source/config.h
+++ b/source/config.h
@@ -41,7 +41,7 @@ some of the system defines set up here.
/* If compiling on Debian (also works on other versions of Linux),
define this. */
-#define DEBIAN_LINUX
+//#define DEBIAN_LINUX
/* If you are compiling on an ultrix/4.2BSD/Dynix/etc. version of UNIX,
define this. It is not needed for SUNs. */
@@ -221,20 +221,20 @@ some of the system defines set up here.
#else
-#if 0
+#if 1
/* Debian standards for file location */
/* This must be unix; change file names as appropriate. */
#define MORIA_SAV ".moria-save"
-#define MORIA_HOU "/etc/moria-hours"
-#define MORIA_MOR "/usr/lib/games/moria/news"
-#define MORIA_GPL "/usr/lib/games/moria/COPYING"
-#define MORIA_TOP "/var/games/moria/scores"
-#define MORIA_HELP "/usr/lib/games/moria/roglcmds.hlp"
-#define MORIA_ORIG_HELP "/usr/lib/games/moria/origcmds.hlp"
-#define MORIA_WIZ_HELP "/usr/lib/games/moria/rwizcmds.hlp"
-#define MORIA_OWIZ_HELP "/usr/lib/games/moria/owizcmds.hlp"
-#define MORIA_WELCOME "/usr/lib/games/moria/welcome.hlp"
-#define MORIA_VER "/usr/lib/games/moria/version.hlp"
+#define MORIA_HOU "@TERMUX_PREFIX@/etc/moria-hours"
+#define MORIA_MOR "@TERMUX_PREFIX@/lib/games/moria/news"
+#define MORIA_GPL "@TERMUX_PREFIX@lib/games/moria/COPYING"
+#define MORIA_TOP "@TERMUX_PREFIX@/var/games/moria/scores"
+#define MORIA_HELP "@TERMUX_PREFIX@/lib/games/moria/roglcmds.hlp"
+#define MORIA_ORIG_HELP "@TERMUX_PREFIX@/lib/games/moria/origcmds.hlp"
+#define MORIA_WIZ_HELP "@TERMUX_PREFIX@/lib/games/moria/rwizcmds.hlp"
+#define MORIA_OWIZ_HELP "@TERMUX_PREFIX@/lib/games/moria/owizcmds.hlp"
+#define MORIA_WELCOME "@TERMUX_PREFIX@/lib/games/moria/welcome.hlp"
+#define MORIA_VER "@TERMUX_PREFIX@/lib/games/moria/version.hlp"
#else

View File

@ -1,16 +0,0 @@
diff --git a/source/death.c b/source/death.c
index 87102eb..e5c951b 100644
--- a/source/death.c
+++ b/source/death.c
@@ -214,9 +214,9 @@ int f, l;
sbuf.st_ino);
#else
#ifdef __linux__
- (void) sprintf (lockname, "/tmp/moria.%ld", sbuf.st_ino);
+ (void) sprintf (lockname, "@TERMUX_PREFIX@/tmp/moria.%ld", sbuf.st_ino);
#else
- (void) sprintf (lockname, "/tmp/moria.%d", sbuf.st_ino);
+ (void) sprintf (lockname, "@TERMUX_PREFIX@/tmp/moria.%d", sbuf.st_ino);
#endif
#endif
if (l & LOCK_UN)

View File

@ -1,22 +0,0 @@
diff --git a/source/signals.c b/source/signals.c
index 0deddde..4124b2e 100644
--- a/source/signals.c
+++ b/source/signals.c
@@ -136,7 +136,7 @@ int sig;
{
if(++signal_count > 10) /* Be safe. We will die if persistent enough. */
(void) MSIGNAL(sig, SIG_DFL);
- return;
+ return 0;
}
error_sig = sig;
@@ -167,7 +167,7 @@ int sig;
if (wait_for_more)
put_buffer(" -more-", MSG_LINE, 0);
put_qio();
- return; /* OK. We don't quit. */
+ return 0; /* OK. We don't quit. */
}
(void) strcpy(died_from, "Interrupting");
}

View File

@ -1,85 +0,0 @@
diff --git a/unix/Makefile b/unix/Makefile
index e65338f..e169edf 100644
--- a/unix/Makefile
+++ b/unix/Makefile
@@ -1,5 +1,5 @@
# Edited for Debian GNU/Linux.
-DESTDIR =
+DESTDIR = @TERMUX_PREFIX@
# DEBIAN NOTE: This file diverges significantly from the original Makefile
# for obvious reasons. The original Makefile is Makefile.unix and should
@@ -16,9 +16,9 @@ DESTDIR =
# Edited for Debian GNU/Linux: LIBVARDIR is where the score file is kept
# OWNER is who you want the game to be chown to.
# GROUP is who you wnat the game to be chgrp to.
-BINDIR = $(DESTDIR)/usr/games
+BINDIR = $(DESTDIR)/bin
ETCDIR = $(DESTDIR)/etc
-LIBSTATICDIR = $(DESTDIR)/usr/lib/games/moria
+LIBSTATICDIR = $(DESTDIR)/lib/games/moria
LIBVARDIR = $(DESTDIR)/var/games/moria
OWNER = root
GROUP = games
@@ -26,7 +26,7 @@ GROUP = games
# For testing and debugging the program, it is best to use this line.
# CFLAGS = -g
# For playing the game, you may want to use this line
-CFLAGS = -O2
+CFLAGS += -O2
# Debian GNU/Linux addition
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
@@ -36,7 +36,7 @@ endif
# For BSD Systems
# CURSES = -lcurses -ltermcap
# For SYS V Systems
-CURSES = -lcurses
+CURSES = -lncurses
# For XENIX, some XENIX systems may need -ltinfo
# CURSES = -ltcap -ltermcap -lx
@@ -44,9 +44,9 @@ CURSES = -lcurses
# config.h if you use this.
#LFLAGS = -lbsd
# Normal systems don't require anything here.
-LFLAGS =
+LFLAGS ?=
-CC = cc
+CC ?= cc
SRCS = main.c misc1.c misc2.c misc3.c misc4.c store1.c files.c io.c \
create.c desc.c generate.c sets.c dungeon.c creature.c death.c \
@@ -66,7 +66,7 @@ LIBSTATICFILES = news origcmds.hlp owizcmds.hlp roglcmds.hlp rwizcmds.hlp \
version.hlp welcome.hlp
moria : $(OBJS)
- $(CC) -o moria $(CFLAGS) $(OBJS) $(CURSES) $(LFLAGS)
+ $(CC) -o moria $(CFLAGS) $(LDFLAGS) $(OBJS) $(CURSES) $(LFLAGS)
lintout : $(SRCS)
lint $(SRCS) $(CURSES) > lintout
@@ -80,21 +80,16 @@ TAGS : $(SRCS)
# you must define BINDIR and LIBDIR before installing
# assumes that BINDIR and LIBDIR exist
install:
- chmod 755 $(BINDIR)
cp moria $(BINDIR)
- chown $(OWNER) $(BINDIR)/moria
- chgrp $(GROUP) $(BINDIR)/moria
chmod 2755 $(BINDIR)/moria
+ mkdir -p $(LIBSTATICDIR)
chmod 755 $(LIBSTATICDIR)
# No longer chmod 755 $(LIBVARDIR)
(cd files; cp $(LIBSTATICFILES) $(LIBSTATICDIR))
- (cd $(LIBSTATICDIR); chmod 444 $(LIBSTATICFILES))
# No longer (cd $(LIBVARDIR); touch scores; chmod 664 scores)
# No longer (cd $(LIBVARDIR); chown $(OWNER) . scores; chgrp $(GROUP) . scores)
(cd files; cp hours $(ETCDIR)/moria-hours)
chmod 644 $(ETCDIR)/moria-hours
- (cd $(LIBSTATICDIR); chown $(OWNER) $(LIBSTATICFILES))
- (cd $(LIBSTATICDIR); chgrp $(GROUP) $(LIBSTATICFILES))
# If you are short on disk space, or aren't interested in debugging moria.
# This is handled by dh_strip, so let's not override its' decision.
# strip $(BINDIR)/moria

View File

@ -1,24 +0,0 @@
diff --git a/unix/unix.c b/unix/unix.c
index 81d543c..af4a672 100644
--- a/unix/unix.c
+++ b/unix/unix.c
@@ -271,19 +271,6 @@ char *p;
}
#endif
-#ifndef DEBIAN_LINUX
-#ifdef USG
-unsigned short getuid();
-#else
-#ifndef SECURE
-#ifdef BSD4_3
-uid_t getuid();
-#else /* other BSD versions */
-int getuid();
-#endif
-#endif
-#endif
-#endif
/* Find a default user name from the system. */
void user_name(buf)

View File

@ -1,12 +0,0 @@
diff -u -r ../tty-solitaire-1.1.0/Makefile ./Makefile
--- ../tty-solitaire-1.1.0/Makefile 2018-08-12 22:05:12.000000000 +0000
+++ ./Makefile 2018-08-13 20:22:37.063193979 +0000
@@ -45,7 +45,7 @@
all: ${EXECUTABLE}
ttysolitaire: $(SRC_OBJECTS)
- $(CC) $(CFLAGS) $(SRC) -o $(EXECUTABLE) $(SRC_OBJECTS) $(LDFLAGS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(SRC) -o $(EXECUTABLE) $(SRC_OBJECTS) $(LDFLAGS)
test: $(SRC_OBJECTS) $(TESTS_OBJECTS)
@$(CC) $(CFLAGS) $(TESTS_SRC) -o $(TESTS_EXECUTABLE) $(TESTS_OBJECTS) $(SRC_OBJECTS) $(LDFLAGS)

View File

@ -1,8 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://github.com/mpereira/tty-solitaire
TERMUX_PKG_DESCRIPTION="Klondike solitaire game"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=1.1.1
TERMUX_PKG_SHA256=146f9ed6ee9d79dfd936c213e3a413a967daba3978fb1021e05a1c52c7684e9c
TERMUX_PKG_SRCURL=https://github.com/mpereira/tty-solitaire/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_DEPENDS="ncurses"