luv: update to 1.36.0-0

This commit is contained in:
Leonid Pliushch 2021-02-05 21:42:00 +00:00
parent 705abf714e
commit 54490c0f79
No known key found for this signature in database
GPG Key ID: 45F2964132545795
2 changed files with 14 additions and 15 deletions

View File

@ -1,7 +1,7 @@
diff -u -r ../luv-1.30.1-1/CMakeLists.txt ./CMakeLists.txt
--- ../luv-1.30.1-1/CMakeLists.txt 2019-09-18 04:33:34.000000000 +0000
+++ ./CMakeLists.txt 2019-09-25 22:23:19.659091635 +0000
@@ -107,7 +107,6 @@
diff -uNr luv-1.36.0-0/CMakeLists.txt luv-1.36.0-0.mod/CMakeLists.txt
--- luv-1.36.0-0/CMakeLists.txt 2020-04-19 08:44:19.000000000 +0000
+++ luv-1.36.0-0.mod/CMakeLists.txt 2021-02-05 22:07:47.397165825 +0000
@@ -108,7 +108,6 @@
include_directories(${LUAJIT_INCLUDE_DIR})
link_directories(${LUAJIT_LIBRARIES})
else (USE_LUAJIT)
@ -9,12 +9,12 @@ diff -u -r ../luv-1.30.1-1/CMakeLists.txt ./CMakeLists.txt
include_directories(${LUA_INCLUDE_DIR})
endif (USE_LUAJIT)
@@ -175,7 +174,7 @@
elseif("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
target_link_libraries(luv ${LIBUV_LIBRARIES} rt)
else()
- target_link_libraries(luv ${LIBUV_LIBRARIES})
+ target_link_libraries(luv m lua5.3 ${LIBUV_LIBRARIES})
endif()
@@ -187,7 +186,7 @@
elseif("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
target_link_libraries(${TARGET_NAME} ${LIBUV_LIBRARIES} rt)
else()
- target_link_libraries(${TARGET_NAME} ${LIBUV_LIBRARIES})
+ target_link_libraries(${TARGET_NAME} ${LIBUV_LIBRARIES} lua5.3)
endif()
endforeach()
if (NOT LUA)

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/luvit/luv
TERMUX_PKG_DESCRIPTION="Bare libuv bindings for lua"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="1.32.0-0"
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION="1.36.0-0"
TERMUX_PKG_SRCURL=https://github.com/luvit/luv/releases/download/$TERMUX_PKG_VERSION/luv-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=25a34b2aecf02d1fd32352c855577dcecd20c756dee9eb7ebecd206bf1de26d3
TERMUX_PKG_SHA256=f2e7eb372574f25c6978c1dc74280d22efdcd7df2dda4a286c7fe7dceda26445
TERMUX_PKG_DEPENDS="liblua53, libuv"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_MODULE=OFF