upgpkg(main/csol): update to 1.5.0

Signed-off-by: 2096779623 <admin@utermux.dev>
This commit is contained in:
2096779623 2022-07-11 17:04:31 +08:00 committed by 2096779623
parent 07a29664cc
commit 594c01a4dd
2 changed files with 10 additions and 6 deletions

View File

@ -1,7 +1,8 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
diff -uNr csol-1.5.0/CMakeLists.txt csol-1.5.0.mod/CMakeLists.txt
--- csol-1.5.0/CMakeLists.txt 2022-03-17 03:21:53.000000000 +0800
+++ csol-1.5.0.mod/CMakeLists.txt 2022-07-11 20:49:58.806999088 +0800
@@ -3,7 +3,7 @@
cmake_minimum_required(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.12)
set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
-set(CMAKE_C_FLAGS "--std=c89 -Wall -pedantic -DUSE_GETOPT")
@ -9,13 +10,15 @@
configure_file(csolrc csolrc COPYONLY)
file(COPY games DESTINATION .)
@@ -22,6 +22,6 @@
@@ -22,7 +22,7 @@
target_link_libraries(csol ${CURSES_LIBRARIES})
install(TARGETS csol DESTINATION bin COMPONENT binaries)
-install(FILES "${CMAKE_BINARY_DIR}/csolrc" DESTINATION /etc/xdg/csol COMPONENT config)
-install(DIRECTORY "${CMAKE_BINARY_DIR}/themes" DESTINATION /etc/xdg/csol COMPONENT config)
-install(DIRECTORY "${CMAKE_BINARY_DIR}/games" DESTINATION /etc/xdg/csol COMPONENT config)
-install(FILES "${CMAKE_BINARY_DIR}/doc/csol.6" DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man6)
+install(FILES "${CMAKE_BINARY_DIR}/csolrc" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(DIRECTORY "${CMAKE_BINARY_DIR}/themes" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(DIRECTORY "${CMAKE_BINARY_DIR}/games" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(FILES "${CMAKE_BINARY_DIR}/doc/csol.6" DESTINATION @TERMUX_PREFIX@/share/man/man6)

View File

@ -2,8 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/nielssp/csol
TERMUX_PKG_DESCRIPTION="A small collection of solitaire games implemented in C using ncurses"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.4.1
TERMUX_PKG_VERSION=1.5.0
TERMUX_PKG_SRCURL=https://github.com/nielssp/csol/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=4117a9b7d6dbddb8549fa7bc8911e4bf8639f275629d428f160e7a824a29ba76
TERMUX_PKG_SHA256=f14ad0756cf7d3ae63fd73e28ae6be7a9f8047380dc4300ff44388aefcfef4f4
TERMUX_PKG_DEPENDS="libandroid-support, ncurses"
TERMUX_CMAKE_BUILD="Unix Makefiles"
TERMUX_PKG_BUILD_IN_SRC=true