upgpkg(main): boinc, boinctui (#11887)

* upgpkg(main/boinc): to 7.20.2
* enhance(main/boinc): enable safe default options for Android
* chore(main/boinc): update patches
* upgpkg(main/boinctui): to 2.7.0
This commit is contained in:
Jia Yuan Lo 2022-09-11 23:12:52 +08:00 committed by GitHub
parent f21346f5d5
commit 627f82333c
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
15 changed files with 59 additions and 60 deletions

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/_autosetup boinc-client_release-7.18-7.18.1.mod/_autosetup
--- boinc-client_release-7.18-7.18.1/_autosetup 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/_autosetup 2021-12-27 20:03:46.335967627 +0800
diff -uNr boinc/_autosetup boinc.mod/_autosetup
--- boinc/_autosetup 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/_autosetup 2022-09-11 21:07:04.995844110 +0800
@@ -19,7 +19,7 @@
check_version()
{

View File

@ -2,20 +2,20 @@ TERMUX_PKG_HOMEPAGE=https://boinc.berkeley.edu/
TERMUX_PKG_DESCRIPTION="Open-source software for volunteer computing"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=7.18.1
TERMUX_PKG_REVISION=5
TERMUX_PKG_VERSION=7.20.2
TERMUX_PKG_SRCURL=https://github.com/BOINC/boinc/archive/client_release/${TERMUX_PKG_VERSION:0:4}/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=274388d9c49e488b6c8502ffc6eb605d5ceae391fb0c2fc56dbb0254d0ceb27e
TERMUX_PKG_SHA256=e577072b06f590d3230c25c94b221dba528b0938681e645bbd870778f8958077
TERMUX_PKG_DEPENDS="libandroid-execinfo, libandroid-shmem, libc++, libcurl, openssl, zlib"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_NO_STATICSPLIT=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-server
--disable-manager
"
TERMUX_PKG_CONFFILES="etc/boinc-client.conf"
# etc/boinc-client.conf is not for Android, extra hooks needed to work
TERMUX_PKG_RM_AFTER_INSTALL="
etc/boinc-client.conf
"
termux_step_pre_configure() {
# for benchmark purposes

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/client/Makefile.am boinc-client_release-7.18-7.18.1.mod/client/Makefile.am
--- boinc-client_release-7.18-7.18.1/client/Makefile.am 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/client/Makefile.am 2021-12-27 20:14:51.115967152 +0800
diff -uNr boinc/client/Makefile.am boinc.mod/client/Makefile.am
--- boinc/client/Makefile.am 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/Makefile.am 2022-09-11 21:07:05.043844110 +0800
@@ -25,7 +25,7 @@
endif

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/client/app_start.cpp boinc-client_release-7.18-7.18.1.mod/client/app_start.cpp
--- boinc-client_release-7.18-7.18.1/client/app_start.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/client/app_start.cpp 2021-12-29 19:46:22.481460428 +0800
diff -uNr boinc/client/app_start.cpp boinc.mod/client/app_start.cpp
--- boinc/client/app_start.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/app_start.cpp 2022-09-11 21:07:05.075844110 +0800
@@ -81,6 +81,10 @@
#include "app.h"
@ -12,7 +12,7 @@ diff -uNr boinc-client_release-7.18-7.18.1/client/app_start.cpp boinc-client_rel
#ifdef _WIN32
// Dynamically link to these functions at runtime;
@@ -1129,6 +1133,49 @@
@@ -1117,6 +1121,49 @@
//
umask(2);
retval = execv(switcher_path, argv);
@ -62,7 +62,7 @@ diff -uNr boinc-client_release-7.18-7.18.1/client/app_start.cpp boinc-client_rel
} else {
argv[0] = buf;
parse_command_line(cmdline, argv+1);
@@ -1151,6 +1198,17 @@
@@ -1139,6 +1186,17 @@
);
}

View File

@ -1,7 +1,7 @@
diff -uNr boinc/client/gui_rpc_server_ops.cpp boinc.mod/client/gui_rpc_server_ops.cpp
--- boinc/client/gui_rpc_server_ops.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc.mod/client/gui_rpc_server_ops.cpp 2022-06-09 06:44:37.271979600 +0800
@@ -414,6 +414,7 @@
--- boinc/client/gui_rpc_server_ops.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/gui_rpc_server_ops.cpp 2022-09-11 21:07:05.111844109 +0800
@@ -415,6 +415,7 @@
safe_strcpy(gstate.host_info.os_name, hi.os_name);
}
@ -9,7 +9,7 @@ diff -uNr boinc/client/gui_rpc_server_ops.cpp boinc.mod/client/gui_rpc_server_op
// We already have the Linux kernel version;
// append the Android version.
//
@@ -424,6 +425,7 @@
@@ -425,6 +426,7 @@
safe_strcat(gstate.host_info.os_version, ")");
}
}

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/client/hostinfo_network.cpp boinc-client_release-7.18-7.18.1.mod/client/hostinfo_network.cpp
--- boinc-client_release-7.18-7.18.1/client/hostinfo_network.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/client/hostinfo_network.cpp 2021-12-29 18:50:29.025462827 +0800
diff -uNr boinc/client/hostinfo_network.cpp boinc.mod/client/hostinfo_network.cpp
--- boinc/client/hostinfo_network.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/hostinfo_network.cpp 2022-09-11 21:07:05.175844109 +0800
@@ -44,6 +44,10 @@
#include <Carbon/Carbon.h>
#endif

View File

@ -1,6 +1,6 @@
diff -uNr boinc/client/hostinfo_unix.cpp boinc.mod/client/hostinfo_unix.cpp
--- boinc/client/hostinfo_unix.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc.mod/client/hostinfo_unix.cpp 2022-07-30 19:04:03.029152379 +0800
--- boinc/client/hostinfo_unix.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/hostinfo_unix.cpp 2022-09-11 21:07:05.211844109 +0800
@@ -169,6 +169,10 @@
#include <OS.h>
#endif

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/client/scripts/Makefile.am boinc-client_release-7.18-7.18.1.mod/client/scripts/Makefile.am
--- boinc-client_release-7.18-7.18.1/client/scripts/Makefile.am 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/client/scripts/Makefile.am 2021-12-27 20:14:58.743967146 +0800
diff -uNr boinc/client/scripts/Makefile.am boinc.mod/client/scripts/Makefile.am
--- boinc/client/scripts/Makefile.am 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/client/scripts/Makefile.am 2022-09-11 21:07:05.251844109 +0800
@@ -2,21 +2,21 @@
install-exec-hook:

View File

@ -1,7 +1,7 @@
diff -uNr boinc-client_release-7.18-7.18.1/configure.ac boinc-client_release-7.18-7.18.1.mod/configure.ac
--- boinc-client_release-7.18-7.18.1/configure.ac 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/configure.ac 2021-12-27 20:13:32.143967208 +0800
@@ -1071,7 +1071,7 @@
diff -uNr boinc/configure.ac boinc.mod/configure.ac
--- boinc/configure.ac 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/configure.ac 2022-09-11 21:07:05.287844109 +0800
@@ -1100,7 +1100,7 @@
AM_CONDITIONAL(OS_WIN32_MINGW, [echo $host_os | grep '^mingw' > /dev/null])
dnl or OS2
AM_CONDITIONAL(OS_OS2, [echo $host_os | grep '^os2' > /dev/null])
@ -9,4 +9,4 @@ diff -uNr boinc-client_release-7.18-7.18.1/configure.ac boinc-client_release-7.1
+AM_CONDITIONAL(OS_ARM_LINUX, [echo $host_alias | grep '^arm-linux-skip' > /dev/null])
AM_CONDITIONAL(OS_ARMV6_LINUX, [echo $host_alias | grep '^armv6-linux' > /dev/null])
AM_CONDITIONAL(ANDROID, [test x"${ANDROID}" = xyes])
AM_CONDITIONAL(BUILD_WITH_VCPKG, [test "${enable_vcpkg}" = yes])
AM_CONDITIONAL(BUILD_WITH_VCPKG, [test "${enable_apps_vcpkg}" = yes])

View File

@ -1,11 +0,0 @@
--- ./lib/crypt.cpp.orig 2022-02-19 18:38:44.955894789 +0530
+++ ./lib/crypt.cpp 2022-02-19 18:39:20.225894775 +0530
@@ -672,7 +672,7 @@
}
#ifdef HAVE_OPAQUE_RSA_DSA_DH
RSA *rsa;
- rsa = EVP_PKEY_get0_RSA(pubKey);
+ rsa = (rsa_st*)EVP_PKEY_get0_RSA(pubKey);
if (!RSA_blinding_on(rsa, c)) {
#else
if (!RSA_blinding_on(pubKey->pkey.rsa, c)) {

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/lib/gui_rpc_client.cpp boinc-client_release-7.18-7.18.1.mod/lib/gui_rpc_client.cpp
--- boinc-client_release-7.18-7.18.1/lib/gui_rpc_client.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/lib/gui_rpc_client.cpp 2021-12-29 19:11:49.145461911 +0800
diff -uNr boinc/lib/gui_rpc_client.cpp boinc.mod/lib/gui_rpc_client.cpp
--- boinc/lib/gui_rpc_client.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/lib/gui_rpc_client.cpp 2022-09-11 21:07:05.339844109 +0800
@@ -416,7 +416,7 @@
char msg_buf[1024];
FILE* f = fopen(GUI_RPC_PASSWD_FILE, "r");

View File

@ -0,0 +1,12 @@
diff -uNr boinc/lib/prefs.cpp boinc.mod/lib/prefs.cpp
--- boinc/lib/prefs.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/lib/prefs.cpp 2022-09-11 21:07:05.387844109 +0800
@@ -221,7 +221,7 @@
max_bytes_sec_down = 0;
max_bytes_sec_up = 0;
max_ncpus = 0;
-#ifdef ANDROID
+#ifdef __ANDROID__
max_ncpus_pct = 50;
#else
max_ncpus_pct = 0;

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/lib/synch.cpp boinc-client_release-7.18-7.18.1.mod/lib/synch.cpp
--- boinc-client_release-7.18-7.18.1/lib/synch.cpp 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/lib/synch.cpp 2021-12-27 20:14:42.835967158 +0800
diff -uNr boinc/lib/synch.cpp boinc.mod/lib/synch.cpp
--- boinc/lib/synch.cpp 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/lib/synch.cpp 2022-09-11 21:07:05.419844109 +0800
@@ -18,7 +18,7 @@
// interfaces for accessing sempahores

View File

@ -1,6 +1,6 @@
diff -uNr boinc-client_release-7.18-7.18.1/version.h.in boinc-client_release-7.18-7.18.1.mod/version.h.in
--- boinc-client_release-7.18-7.18.1/version.h.in 2021-08-03 23:52:19.000000000 +0800
+++ boinc-client_release-7.18-7.18.1.mod/version.h.in 2021-12-29 21:29:50.585455988 +0800
diff -uNr boinc/version.h.in boinc.mod/version.h.in
--- boinc/version.h.in 2022-07-18 18:32:21.000000000 +0800
+++ boinc.mod/version.h.in 2022-09-11 21:07:05.475844109 +0800
@@ -22,7 +22,7 @@
#define BOINC_VERSION_STRING "@BOINC_VERSION_STRING@"

View File

@ -2,15 +2,13 @@ TERMUX_PKG_HOMEPAGE=https://sourceforge.net/projects/boinctui/
TERMUX_PKG_DESCRIPTION="curses based manager for Boinc client"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.6.0
TERMUX_PKG_VERSION=2.7.0
TERMUX_PKG_SRCURL="https://sourceforge.net/projects/boinctui/files/boinctui_${TERMUX_PKG_VERSION}.tar.gz"
TERMUX_PKG_SHA256=a00df7d83e3e35085432052062a2380ea0343258b073d69995107d243a61d0b0
TERMUX_PKG_DEPENDS="glib, libandroid-support, libexpat, ncurses, ncurses-ui-libs, openssl"
TERMUX_PKG_SHA256=22eb46dea8b111e2e16ceb50f2668577216c1563c815b1719b2b680d485d75c9
TERMUX_PKG_DEPENDS="libandroid-support, libc++, libexpat, ncurses, ncurses-ui-libs, openssl"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-gnutls --mandir=$TERMUX_PREFIX/share/man"
termux_step_pre_configure() {
CPPFLAGS+=" -DANDROID"
LDFLAGS+=" -llog"
autoconf
autoreconf -fi
}