hexchat: Bump to 2.16.1

This commit is contained in:
Tee KOBAYASHI 2022-11-23 15:05:46 +09:00 committed by xtkoba
parent d0a376646e
commit 6aaed68c90
4 changed files with 32 additions and 42 deletions

View File

@ -2,30 +2,33 @@ TERMUX_PKG_HOMEPAGE=https://hexchat.github.io/
TERMUX_PKG_DESCRIPTION="A popular and easy to use graphical IRC (chat) client"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.14.3
TERMUX_PKG_REVISION=24
TERMUX_PKG_SRCURL=https://github.com/hexchat/hexchat/archive/v2.14.2.tar.gz
TERMUX_PKG_SHA256=4f2c2137020913513ea559f788c41039ca6230764d8158862d5d1ee8785592d9
TERMUX_PKG_DEPENDS="gdk-pixbuf, glib, gtk2, liblua53, libnotify, libx11, openssl, pango, python"
TERMUX_PKG_VERSION=2.16.1
TERMUX_PKG_SRCURL=https://github.com/hexchat/hexchat/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=f15bc487312a96a902e042e8f197a8494a29bcf4a00bbfd276a5e8154263bfe5
TERMUX_PKG_DEPENDS="gdk-pixbuf, glib, gtk2, liblua53, libx11, openssl, pango, python"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dwith-libproxy=false
-Dwith-libcanberra=false
-Dwith-dbus=false
-Dlibcanberra=disabled
-Ddbus=disabled
-Dwith-lua=lua53
-Dwith-text=true
-Dtext-frontend=true
-Dwith-perl=false
-Dwith-sysinfo=false
"
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"
termux_step_post_make_install() {
## TODO: patch it to force link with libandroid-shmem instead of
## using wrapper.
mkdir -p "${TERMUX_PREFIX}/libexec/"
mv "${TERMUX_PREFIX}/bin/hexchat" "${TERMUX_PREFIX}/libexec/"
sed "s|@TERMUX_PREFIX@|${TERMUX_PREFIX}|g" \
"${TERMUX_PKG_BUILDER_DIR}/hexchat.in" > "${TERMUX_PREFIX}/bin/hexchat"
chmod 700 "${TERMUX_PREFIX}/bin/hexchat"
termux_step_pre_configure() {
local _PYTHON_VERSION=$(. $TERMUX_SCRIPTDIR/packages/python/build.sh; echo $_MAJOR_VERSION)
termux_setup_python_crossenv
pushd $TERMUX_PYTHON_CROSSENV_SRCDIR
_CROSSENV_PREFIX=$TERMUX_PKG_BUILDDIR/python-crossenv-prefix
python${_PYTHON_VERSION} -m crossenv \
$TERMUX_PREFIX/bin/python${_PYTHON_VERSION} \
${_CROSSENV_PREFIX}
popd
. ${_CROSSENV_PREFIX}/bin/activate
build-pip install cffi
}

View File

@ -1,22 +0,0 @@
diff -uNr hexchat-2.14.2/meson_post_install.py hexchat-2.14.2.mod/meson_post_install.py
--- hexchat-2.14.2/meson_post_install.py 2018-08-29 19:41:08.000000000 +0300
+++ hexchat-2.14.2.mod/meson_post_install.py 2018-10-09 21:31:29.201613989 +0300
@@ -7,18 +7,3 @@
prefix = os.environ.get('MESON_INSTALL_PREFIX', '/usr/local')
datadir = os.path.join(prefix, 'share')
with_thememan = sys.argv[1] == 'true'
-
-# Packaging tools define DESTDIR and this isn't needed for them
-if 'DESTDIR' not in os.environ:
- print('Updating icon cache...')
- subprocess.call(['gtk-update-icon-cache', '-qtf',
- os.path.join(datadir, 'icons', 'hicolor')])
-
- print('Updating desktop database...')
- subprocess.call(['update-desktop-database', '-q',
- os.path.join(datadir, 'applications')])
-
- if with_thememan:
- print('Updating mime database...')
- subprocess.call(['update-mime-database',
- os.path.join(datadir, 'mime')])

View File

@ -1,3 +0,0 @@
#!@TERMUX_PREFIX@/bin/sh
export LD_PRELOAD=@TERMUX_PREFIX@/lib/libandroid-shmem.so
exec @TERMUX_PREFIX@/libexec/hexchat "${@}"

View File

@ -0,0 +1,12 @@
--- a/meson.build
+++ b/meson.build
@@ -165,9 +165,6 @@
subdir('data')
subdir('po') # FIXME: build xgettext
- meson.add_install_script('meson_post_install.py',
- '@0@'.format(get_option('theme-manager'))
- )
endif
if meson.version().version_compare('>= 0.53.0')