recordmydesktop: Bump to 0.4.0

This commit is contained in:
Tee KOBAYASHI 2022-11-23 17:25:03 +09:00 committed by xtkoba
parent b17786b75b
commit 6af783bca9
4 changed files with 29 additions and 36 deletions

View File

@ -1,18 +1,23 @@
TERMUX_PKG_HOMEPAGE=http://recordmydesktop.sourceforge.net/
TERMUX_PKG_HOMEPAGE=https://github.com/Enselic/recordmydesktop
TERMUX_PKG_DESCRIPTION="Produces a OGG encapsulated Theora/Vorbis recording of your desktop"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.3.8.1
TERMUX_PKG_REVISION=22
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/recordmydesktop/recordmydesktop-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=33a2e208186ae78e2db2a27b0f5047b50fb7819c47fe15483b0765200b9d738c
TERMUX_PKG_DEPENDS="libandroid-shmem, libsm, libtheora, libvorbis, libxdamage, libxext, zlib"
TERMUX_PKG_VERSION=0.4.0
TERMUX_PKG_SRCURL=https://github.com/Enselic/recordmydesktop/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=69602d32c1be82cd92083152c7c44c0206ca0d6419d76a6144ffcfe07b157a72
TERMUX_PKG_DEPENDS="libandroid-shmem, libice, libogg, libpopt, libsm, libtheora, libvorbis, libx11, libxdamage, libxext, libxfixes, zlib"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
ac_cv_lib_pthread_pthread_mutex_lock=yes
--enable-oss=no
--enable-jack=no
"
termux_step_post_get_source() {
TERMUX_PKG_SRCDIR+="/recordmydesktop"
}
termux_step_pre_configure() {
autoreconf -fi
export LIBS="-landroid-shmem"
}

View File

@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,7 @@
AC_CHECK_LIB([ogg],[ogg_stream_init],,AC_MSG_ERROR([Can't find libogg]))
AC_CHECK_LIB([theora],[theora_encode_YUVin],,
AC_MSG_ERROR([Can't find libtheora]))
-AC_CHECK_LIB([pthread],[pthread_mutex_lock],,
+AC_CHECK_LIB([c],[pthread_mutex_lock],,
AC_MSG_ERROR([Can't find libpthread]))
if test x$jack = xtrue ; then

View File

@ -1,21 +0,0 @@
diff -uNr recordmydesktop-0.3.8.1/configure recordmydesktop-0.3.8.1.mod/configure
--- recordmydesktop-0.3.8.1/configure 2008-12-13 19:40:03.000000000 +0200
+++ recordmydesktop-0.3.8.1.mod/configure 2020-02-11 14:34:18.712282563 +0200
@@ -8580,7 +8580,7 @@
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpthread $LIBS"
+LIBS=" $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -8644,7 +8644,7 @@
#define HAVE_LIBPTHREAD 1
_ACEOF
- LIBS="-lpthread $LIBS"
+ LIBS=" $LIBS"
else
{ { $as_echo "$as_me:$LINENO: error: Can't find libpthread" >&5

View File

@ -1,14 +1,12 @@
diff -uNr recordmydesktop-0.3.8.1/src/rmd_initialize_data.c recordmydesktop-0.3.8.1.mod/src/rmd_initialize_data.c
--- recordmydesktop-0.3.8.1/src/rmd_initialize_data.c 2008-12-13 17:49:09.000000000 +0200
+++ recordmydesktop-0.3.8.1.mod/src/rmd_initialize_data.c 2020-02-11 15:45:12.372308546 +0200
@@ -239,8 +239,8 @@
args->device = (char *) malloc(strlen(DEFAULT_AUDIO_DEVICE) + 1);
strcpy(args->device, DEFAULT_AUDIO_DEVICE);
@@ -239,7 +239,7 @@
- args->workdir = (char *) malloc(5);
- strcpy(args->workdir, "/tmp");
+ args->workdir = (char *) malloc(sizeof("@TERMUX_PREFIX@/tmp"));
+ strcpy(args->workdir, "@TERMUX_PREFIX@/tmp");
char *tmpdir = getenv("TMPDIR");
if (tmpdir == NULL) {
- tmpdir = "/tmp";
+ tmpdir = "@TERMUX_PREFIX@/tmp";
}
args->workdir = strdup(tmpdir);
args->pause_shortcut = (char *) malloc(15);
strcpy(args->pause_shortcut, "Control+Mod1+p");