Add packages: libsearpc, ccnet, seafile-client

This commit is contained in:
jydidier 2018-04-28 12:28:40 +02:00 committed by Leonid Pliushch
parent cac615b22c
commit 6bf43c25a7
5 changed files with 100 additions and 0 deletions

20
packages/ccnet/build.sh Normal file
View File

@ -0,0 +1,20 @@
TERMUX_PKG_HOMEPAGE=https://github.com/haiwen/ccnet
TERMUX_PKG_DESCRIPTION="Ccnet is a framework for writing networked applications in C."
TERMUX_PKG_VERSION=6.1.7
TERMUX_PKG_SHA256=f9c81586181a8f331d3b00f334003e6b3f1af774f647cba30d5c9f9c546f7fce
TERMUX_PKG_SRCURL=https://github.com/haiwen/ccnet/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libuuid, libevent, libsearpc, libsqlite, openssl"
TERMUX_PKG_BUILD_DEPENDS="libtool"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
./autogen.sh
}
termux_step_post_configure() {
# the package has trouble to prepare some headers
cd lib
python $TERMUX_PREFIX/bin/searpc-codegen.py ../lib/rpc_table.py
cd ..
}

View File

@ -0,0 +1,28 @@
--- ../ccnet/configure.ac 2018-04-26 19:00:41.309901710 +0200
+++ ./configure.ac 2018-04-28 10:50:43.956523129 +0200
@@ -76,7 +76,7 @@
fi
fi
-AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
+#AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
AC_CHECK_LIB(sqlite3, sqlite3_open,[echo "found library sqlite3"] , AC_MSG_ERROR([*** Unable to find sqlite3 library]), )
AC_CHECK_LIB(crypto, SHA1_Init, [echo "found library crypto"], AC_MSG_ERROR([*** Unable to find openssl crypto library]), )
@@ -98,6 +98,7 @@
PTHREAD_LIBS=-lpthread
fi
+PTHREAD_LIBS=
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
@@ -153,6 +154,8 @@
LIB_DIRWATCH=
fi
+LIB_RESOLV=""
+
AC_SUBST(LIB_WS32)
AC_SUBST(LIB_GDI32)
AC_SUBST(LIB_RT)

View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://github.com/haiwen/libsearpc
TERMUX_PKG_DESCRIPTION="A simple C language RPC framework (mainly for seafile)"
TERMUX_PKG_VERSION=3.0.7
TERMUX_PKG_SHA256=efee6b495f93e70101c87849c78b135014dfd2f0e5c08dcfed9834def47cb939
TERMUX_PKG_SRCURL=https://github.com/haiwen/libsearpc/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="glib, libjansson"
TERMUX_PKG_BUILD_DEPENDS="libtool, python, pkg-config"
TERMUX_PKG_HOSTBUILD=yes
termux_step_post_extract_package() {
./autogen.sh
}

View File

@ -0,0 +1,19 @@
TERMUX_PKG_HOMEPAGE=http://seafile.com
TERMUX_PKG_DESCRIPTION="Seafile is a file syncinc and sharing software with file encryption and group sharing."
TERMUX_PKG_VERSION=6.1.7
TERMUX_PKG_SHA256=91a4b923155f3ae7c7391d272afec8eebc40866767e45b1ce5a78783a3523fa4
TERMUX_PKG_SRCURL=https://github.com/haiwen/seafile/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="ccnet, libcurl"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
./autogen.sh
}
termux_step_post_configure() {
# the package has trouble to prepare some headers
cd lib
python $TERMUX_PREFIX/bin/searpc-codegen.py $TERMUX_PKG_SRCDIR/lib/rpc_table.py
cd ..
}

View File

@ -0,0 +1,20 @@
--- ../seafile/configure.ac 2018-04-28 11:32:08.357388789 +0200
+++ ./configure.ac 2018-04-28 11:33:03.093385829 +0200
@@ -75,7 +75,7 @@
fi
fi
-AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
+#AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
AC_CHECK_LIB(sqlite3, sqlite3_open,[echo "found library sqlite3"] , AC_MSG_ERROR([*** Unable to find sqlite3 library]), )
dnl Do we need to use AX_LIB_SQLITE3 to check sqlite?
@@ -134,6 +134,8 @@
LIB_CRYPT32=
fi
+LIB_RESOLV=""
+
AC_SUBST(LIB_WS32)
AC_SUBST(LIB_GDI32)
AC_SUBST(LIB_RT)