feroxbuster: Use system OpenSSL

This commit is contained in:
Tee KOBAYASHI 2022-11-25 16:59:18 +09:00 committed by xtkoba
parent 3677f29b56
commit 6ed6bb65d4
2 changed files with 13 additions and 6 deletions

View File

@ -0,0 +1,11 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -47,7 +47,7 @@
uuid = { version = "1.0.0", features = ["v4"] }
indicatif = "0.15"
console = "0.15.2"
-openssl = { version = "0.10.40", features = ["vendored"] }
+openssl = { version = "0.10.40", features = [] }
dirs = "4.0.0"
regex = "1.5.5"
crossterm = "0.25.0"

View File

@ -3,16 +3,12 @@ TERMUX_PKG_DESCRIPTION="A fast, simple, recursive content discovery tool written
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="2.7.2"
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL="https://github.com/epi052/feroxbuster/archive/refs/tags/v$TERMUX_PKG_VERSION.tar.gz"
TERMUX_PKG_SHA256=7120613f966b311d3c7cca888c9f033a48a22edbc7ec4078c3d8dbfd3a327dda
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_BUILD_IN_SRC=true
# FIXME Why building with 'openssl' fails?
# ld: error: undefined symbol: ERR_get_error_all
# >>> referenced by feroxbuster.52795224-cgu.0 >>>
# ... -cgu.0.rcgu.o:(openssl::error::Error::get::hfccd210421e4f03c)
# clang-14: error: linker command failed with exit code 1
TERMUX_PKG_DEPENDS="openssl-1.1"
TERMUX_PKG_DEPENDS="openssl"
termux_step_pre_configure() {
rm -f Makefile