exiftool: update from 12.05 to 12.06

geth: update from 1.9.20 to 1.9.21

glib: update from 2.64.5 to 2.66.0
This commit is contained in:
Butta 2020-09-11 21:47:02 +05:30
parent c3eb5a8313
commit 7042905ca2
4 changed files with 16 additions and 28 deletions

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://exiftool.org/
TERMUX_PKG_DESCRIPTION="Utility for reading, writing and editing meta information in a wide variety of files."
TERMUX_PKG_LICENSE="Artistic-License-2.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=12.05
TERMUX_PKG_VERSION=12.06
TERMUX_PKG_SRCURL="http://www.sno.phy.queensu.ca/~phil/exiftool/Image-ExifTool-$TERMUX_PKG_VERSION.tar.gz"
TERMUX_PKG_SHA256=7c8572c626e6e2eda65038d1533a0f15649dfffc6bdb67a609765d1a81288bbe
TERMUX_PKG_SHA256=792d0aaafbe82ae0188f9900d9c4750d2ed28deaa9ed128eec4923e4adb1e48b
TERMUX_PKG_DEPENDS="perl"
termux_step_make_install() {

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://geth.ethereum.org/
TERMUX_PKG_DESCRIPTION="Go implementation of the Ethereum protocol"
TERMUX_PKG_LICENSE="LGPL-3.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=1.9.20
TERMUX_PKG_VERSION=1.9.21
TERMUX_PKG_SRCURL=https://github.com/ethereum/go-ethereum/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=61669258de88a641585fa268775fab5984e1eda4035cfcc1955f1dd48e7eafbd
TERMUX_PKG_SHA256=532ee58ab6e8505e455a4784f0a7e12297bd28691521209714be0eb4c317ecfd
termux_step_make() {
termux_setup_golang

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://developer.gnome.org/glib/
TERMUX_PKG_DESCRIPTION="Library providing core building blocks for libraries and applications written in C"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_VERSION=2.64.5
TERMUX_PKG_VERSION=2.66.0
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/gnome/sources/glib/${TERMUX_PKG_VERSION:0:4}/glib-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=9cbd5bd2715ead1c28d53c46f7b7b6ff6166f5887b772c1a9e3bf2910cfecc11
TERMUX_PKG_SHA256=c5a66bf143065648c135da4c943d2ac23cce15690fc91c358013b2889111156c
TERMUX_PKG_DEPENDS="libffi, libiconv, pcre, libandroid-support, zlib"
TERMUX_PKG_BREAKS="glib-dev"
TERMUX_PKG_REPLACES="glib-dev"

View File

@ -11,27 +11,15 @@ diff -u -r ../glib-2.60.2/meson.build ./meson.build
'-Werror=missing-include-dirs',
--- ./meson.build.orig 2019-06-11 00:18:20.480045589 +0000
+++ ./meson.build 2019-06-11 00:19:34.408583457 +0000
@@ -1780,23 +1780,8 @@
endif
endif
-# First check in libc, fallback to libintl, and as last chance build
-# proxy-libintl subproject.
-# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
-# implementations. This could be extended if issues are found in some platforms.
@@ -1780,9 +1780,8 @@
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext')
libintl = []
have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
-else
- libintl = cc.find_library('intl', required : false)
- if not libintl.found()
- libintl = subproject('proxy-libintl').get_variable('intl_dep')
- have_bind_textdomain_codeset = true # proxy-libintl supports it
- else
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset',
- dependencies : libintl)
- endif
-endif
glib_conf.set('HAVE_BIND_TEXTDOMAIN_CODESET', have_bind_textdomain_codeset)
+have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+if False
# First just find the bare library.
libintl = cc.find_library('intl', required : false)
# The bare library probably won't link without help if it's static.