qrsspig: Bump to 0.8.0

This commit is contained in:
Tee KOBAYASHI 2022-11-19 14:59:42 +09:00 committed by xtkoba
parent 34389e9aee
commit 725600857b
3 changed files with 24 additions and 14 deletions

View File

@ -1,10 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,5 +24,5 @@
subdirs(src)
-install(FILES systemd/qrsspig.service DESTINATION /lib/systemd/system/)
-install(FILES etc/qrsspig.yaml DESTINATION /etc/qrsspig/)
+install(FILES systemd/qrsspig.service DESTINATION @TERMUX_PREFIX@/lib/systemd/system/)
+install(FILES etc/qrsspig.yaml DESTINATION @TERMUX_PREFIX@/etc/qrsspig/)

View File

@ -2,15 +2,15 @@ TERMUX_PKG_HOMEPAGE=https://gitlab.com/hb9fxx/qrsspig
TERMUX_PKG_DESCRIPTION="Headless QRSS grabber for Raspberry Pi's"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.7.2
TERMUX_PKG_REVISION=5
TERMUX_PKG_VERSION=0.8.0
TERMUX_PKG_SRCURL=https://gitlab.com/hb9fxx/qrsspig/-/archive/v${TERMUX_PKG_VERSION}/qrsspig-v${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_SHA256=4bf0ad0fb9351587ac9bec87d8977d210dad670e32a8fdb62b1dac7b133d79c2
TERMUX_PKG_SHA256=9b3df7723944ef15f99d355ed071f41ace663833afe46703036ead89415372d1
TERMUX_PKG_DEPENDS="boost, fftw, libc++, libcurl, libgd, libliquid-dsp, libssh, libyaml-cpp, pulseaudio"
TERMUX_PKG_BUILD_DEPENDS="boost-headers"
TERMUX_PKG_RM_AFTER_INSTALL="lib/systemd"
termux_step_pre_configure() {
LDFLAGS+=" -llog"
_NEED_DUMMY_LIBPTHREAD_A=
_LIBPTHREAD_A=$TERMUX_PREFIX/lib/libpthread.a
if [ ! -e $_LIBPTHREAD_A ]; then
@ -20,6 +20,9 @@ termux_step_pre_configure() {
}
termux_step_post_make_install() {
install -Dm600 -t $TERMUX_PREFIX/etc/qrsspig \
$TERMUX_PKG_SRCDIR/etc/qrsspig.yaml
if [ $_NEED_DUMMY_LIBPTHREAD_A ]; then
rm -f $_LIBPTHREAD_A
fi

View File

@ -0,0 +1,17 @@
--- a/etc/qrsspig.yaml
+++ b/etc/qrsspig.yaml
@@ -17,7 +17,7 @@
receiver: Marconi MkII
antenna: ShortWire
minutesperframe: 10
- font: "dejavu/DejaVuSans.ttf"
+ font: "DroidSans.ttf"
fontsize: 8
freqmin: 10139800
freqmax: 10140200
@@ -26,4 +26,4 @@
upload:
- type: local
name: local_tmp
- dir: /tmp
+ dir: @TERMUX_PREFIX@/tmp