new package: ceu-lang

This commit is contained in:
Pooya Moradi 2022-09-11 19:04:44 +04:30 committed by Henrik Grimler
parent 6e48dd5c2a
commit 7d2b8d3ee9
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
2 changed files with 36 additions and 0 deletions

View File

@ -0,0 +1,13 @@
diff --git a/Makefile b/Makefile
index f110b150..b7307c5f 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
###############################################################################
LUA_EXE = lua5.3
-CEU_EXE = /usr/local/bin/ceu
+CEU_EXE = @TERMUX_PREFIX@/bin/ceu
CEU_ARGS_ = --ceu-features-trace=true --ceu-err-unused=pass $(CEU_ARGS)
CC_ARGS_ = -llua5.3 -lpthread $(CC_ARGS)

View File

@ -0,0 +1,23 @@
TERMUX_PKG_HOMEPAGE="https://github.com/ceu-lang/ceu"
TERMUX_PKG_DESCRIPTION="The Structured Synchronous Reactive Programming Language Céu"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_SRCURL="https://github.com/ceu-lang/ceu.git"
TERMUX_PKG_GIT_BRANCH="master"
_COMMIT="5e0c8d3004ad98658ffe82823ad8303a8d371064"
TERMUX_PKG_VERSION="2019.07.17"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_BUILD_DEPENDS="lua53, lua-lpeg"
TERMUX_PKG_DEPENDS="lua53, lua-lpeg, liblua53"
termux_step_post_get_source() {
git fetch --unshallow
git checkout $_COMMIT
local version="$(git log -1 --date=format:"%Y.%m.%d" --format="%ad")"
if [ "$version" != "$TERMUX_PKG_VERSION" ]; then
echo -n "ERROR: The specified version \"$TERMUX_PKG_VERSION\""
echo " is different from what is expected to be: \"$version\""
return 1
fi
}