new package: clutter

This commit is contained in:
Tee KOBAYASHI 2022-11-29 02:25:07 +09:00 committed by xtkoba
parent 6774f5f216
commit 82cc4f070e
6 changed files with 1481 additions and 0 deletions

View File

@ -0,0 +1,23 @@
TERMUX_PKG_HOMEPAGE=https://wiki.gnome.org/Projects/Clutter
TERMUX_PKG_DESCRIPTION="An open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
_MAJOR_VERSION=1.26
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.4
TERMUX_PKG_SRCURL=https://download.gnome.org/sources/clutter/${_MAJOR_VERSION}/clutter-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=8b48fac159843f556d0a6be3dbfc6b083fc6d9c58a20a49a6b4919ab4263c4e6
TERMUX_PKG_DEPENDS="atk, cogl, fontconfig, freetype, gdk-pixbuf, glib, gtk3, harfbuzz, json-glib, libcairo, libx11, libxcomposite, libxdamage, libxext, libxfixes, libxi, libxrandr, pango"
TERMUX_PKG_BUILD_DEPENDS="g-ir-scanner"
TERMUX_PKG_DISABLE_GIR=false
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--enable-introspection=yes
"
termux_step_pre_configure() {
termux_setup_gir
export GLIB_GENMARSHAL=glib-genmarshal
export GOBJECT_QUERY=gobject-query
export GLIB_MKENUMS=glib-mkenums
export GLIB_COMPILE_RESOURCES=glib-compile-resources
}

View File

@ -0,0 +1,18 @@
--- a/clutter/Makefile.in
+++ b/clutter/Makefile.in
@@ -3745,13 +3745,8 @@
rm -f $$lib.0.$(CLUTTER_LT_CURRENT).$(CLUTTER_LT_REVISION); \
) ; \
(cd $(DESTDIR)$(libdir) && \
- { ln -s -f libclutter-$(CLUTTER_API_VERSION).so.0.$(CLUTTER_LT_CURRENT).$(CLUTTER_LT_REVISION) $$lib.0 || \
- { rm -f $$lib.0 && ln -s libclutter-1.0.so.0.$(CLUTTER_LT_CURRENT).$(CLUTTER_LT_REVISION) $$lib.0; }; \
- } \
- ) ; \
- (cd $(DESTDIR)$(libdir) && \
- { ln -s -f libclutter-$(CLUTTER_API_VERSION).so.0.$(CLUTTER_LT_CURRENT).$(CLUTTER_LT_REVISION) $$lib || \
- { rm -f $$lib && ln -s libclutter-1.0.so.0.$(CLUTTER_LT_CURRENT).$(CLUTTER_LT_REVISION) $$lib; }; \
+ { ln -s -f libclutter-$(CLUTTER_API_VERSION).so $$lib || \
+ { rm -f $$lib && ln -s libclutter-1.0.so $$lib; }; \
} \
) ; \
done

View File

@ -0,0 +1,38 @@
<?xml version="1.0"?>
<dump>
<class name="CallyActor" get-type="cally_actor_get_type" parents="AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
</class>
<class name="CallyClone" get-type="cally_clone_get_type" parents="CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
</class>
<class name="CallyGroup" get-type="cally_group_get_type" parents="CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
</class>
<class name="CallyRectangle" get-type="cally_rectangle_get_type" parents="CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
</class>
<class name="CallyRoot" get-type="cally_root_get_type" parents="AtkGObjectAccessible,AtkObject,GObject">
</class>
<class name="CallyStage" get-type="cally_stage_get_type" parents="CallyGroup,CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
<implements name="AtkWindow"/>
</class>
<class name="CallyText" get-type="cally_text_get_type" parents="CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
<implements name="AtkText"/>
<implements name="AtkEditableText"/>
</class>
<class name="CallyTexture" get-type="cally_texture_get_type" parents="CallyActor,AtkGObjectAccessible,AtkObject,GObject">
<implements name="AtkComponent"/>
<implements name="AtkAction"/>
</class>
<class name="CallyUtil" get-type="cally_util_get_type" parents="AtkUtil,GObject">
</class>
</dump>

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,3 @@
<?xml version="1.0"?>
<dump>
</dump>

View File

@ -0,0 +1,37 @@
<?xml version="1.0"?>
<dump>
<class name="ClutterX11TexturePixmap" get-type="clutter_x11_texture_pixmap_get_type" parents="ClutterTexture,ClutterActor,GInitiallyUnowned,GObject">
<implements name="ClutterContainer"/>
<implements name="ClutterScriptable"/>
<implements name="ClutterAnimatable"/>
<implements name="AtkImplementorIface"/>
<property name="pixmap" type="gulong" flags="3"/>
<property name="pixmap-width" type="guint" flags="1"/>
<property name="pixmap-height" type="guint" flags="1"/>
<property name="pixmap-depth" type="guint" flags="1"/>
<property name="automatic-updates" type="gboolean" flags="3"/>
<property name="window" type="gulong" flags="3"/>
<property name="window-redirect-automatic" type="gboolean" flags="3"/>
<property name="window-mapped" type="gboolean" flags="1"/>
<property name="destroyed" type="gboolean" flags="1"/>
<property name="window-x" type="gint" flags="1"/>
<property name="window-y" type="gint" flags="1"/>
<property name="window-override-redirect" type="gboolean" flags="1"/>
<signal name="update-area" return="void" when="first">
<param type="gint"/>
<param type="gint"/>
<param type="gint"/>
<param type="gint"/>
</signal>
<signal name="queue-damage-redraw" return="void" when="first">
<param type="gint"/>
<param type="gint"/>
<param type="gint"/>
<param type="gint"/>
</signal>
</class>
<enum name="ClutterX11FilterReturn" get-type="clutter_x11_filter_return_get_type">
<member name="CLUTTER_X11_FILTER_CONTINUE" nick="continue" value="0"/>
<member name="CLUTTER_X11_FILTER_TRANSLATE" nick="translate" value="1"/>
<member name="CLUTTER_X11_FILTER_REMOVE" nick="remove" value="2"/>
</enum></dump>