Added MDK4 for Termux (#236)

This commit is contained in:
gitdebpro 2021-04-17 18:54:47 +05:30 committed by Yaksh Bariya
parent 9b8cb4d83c
commit 843d66d21b
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
5 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,8 @@
--- a/Makefile 2015-12-31 19:42:10.000000000 +0000
+++ b/Makefile 2018-01-11 19:43:11.319604821 +0000
@@ -2,1 +2,1 @@
-PREFIX = /usr/local
+PREFIX ?= /usr/local
#@@ -13,5 +13,5 @@
#-PREFIX:=$(DESTDIR)$(PREFIX) $(MAKE) -C $(SRC) install
#+PREFIX=$(DESTDIR)$(PREFIX) $(MAKE) -C $(SRC) install

View File

@ -0,0 +1,9 @@
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_HOMEPAGE=https://github.com/aircrack-ng/mdk4
TERMUX_PKG_DESCRIPTION="MDK is a proof-of-concept tool to exploit common IEEE 802.11 protocol weaknesses."
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=4.1
TERMUX_PKG_SRCURL=https://github.com/aircrack-ng/mdk4/archive/fc03b0ece893fd8d3f546d915511f01ba3faebc8.zip
TERMUX_PKG_SHA256=fdbefff87b29710374e7bef3682e36dd5cda074091447fd7300bb26ac8a62839
TERMUX_PKG_DEPENDS="aircrack-ng, libnl, libpcap"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -0,0 +1,8 @@
--- ./common.mak 2015-12-31 19:42:10.000000000 +0000
+++ ../common.mak 2018-01-11 19:43:11.319604821 +0000
@@ -124,1 +124,1 @@
-prefix = /usr/local
+prefix ?= /usr/local
bindir = $(prefix)/bin
sbindir = $(prefix)/sbin
mandir = $(prefix)/share/man/man1

View File

@ -0,0 +1,7 @@
--- a/src/Makefile 2015-12-30 08:23:13.000000000 +0000
+++ b/src/Makefile 2018-01-11 19:31:06.217971593 +0000
@@ -7,1 +7,1 @@
-LINKFLAGS = -lpthread -lpcap $(LDFLAGS)
+LINKFLAGS = -lpcap $(LDFLAGS)
#@@ -8,1 +8,1 @@
#+PREFIX ?= /usr/local

View File

@ -0,0 +1,5 @@
--- a/src/attacks/Makefile 2015-12-30 08:23:13.000000000 +0000
+++ b/src/attacks/Makefile 2018-01-11 19:31:06.217971593 +0000
@@ -2,1 +2,1 @@
-LINKFLAGS = -lpthread $(LDFLAGS)
+LINKFLAGS = $(LDFLAGS)