new package: mogan

This commit is contained in:
Tee KOBAYASHI 2023-01-07 09:19:21 +09:00 committed by xtkoba
parent 9f39439abf
commit 84a7d57ef9
4 changed files with 39 additions and 0 deletions

View File

@ -0,0 +1,10 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -523,7 +523,6 @@
### --------------------------------------------------------------------
set (TeXmacs_Libraries
PNG::PNG ZLIB::ZLIB JPEG::JPEG CURL::libcurl Iconv::Iconv
- -lpthread
)
if (WIN32)

View File

@ -0,0 +1,18 @@
TERMUX_PKG_HOMEPAGE=https://github.com/XmacsLabs/mogan
TERMUX_PKG_DESCRIPTION="A structure editor forked from GNU TeXmacs"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.1.1
TERMUX_PKG_SRCURL=https://github.com/XmacsLabs/mogan/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=0d474267b7a777ae0fb22705c8515bfc24eb2de15ed69aa758dc51377fc6d9f9
TERMUX_PKG_DEPENDS="freetype, ghostscript, libandroid-complex-math, libandroid-execinfo, libandroid-spawn, libc++, libcurl, libiconv, libjpeg-turbo, libpng, libsqlite, mogan-data, qt5-qtbase, qt5-qtsvg, zlib"
TERMUX_PKG_BUILD_DEPENDS="qt5-qtbase-cross-tools"
termux_step_pre_configure() {
LDFLAGS+=" -landroid-complex-math -landroid-execinfo -landroid-spawn"
}
termux_step_post_make_install() {
mkdir -p $TERMUX_PREFIX/share/Xmacs/plugins/shell/bin
ln -sfTr $TERMUX_PREFIX/{libexec,share}/Xmacs/plugins/shell/bin/tm_shell
}

View File

@ -0,0 +1,3 @@
TERMUX_SUBPKG_DESCRIPTION="Platform-independent data for mogan"
TERMUX_SUBPKG_PLATFORM_INDEPENDENT=true
TERMUX_SUBPKG_INCLUDE="share/Xmacs/"

View File

@ -0,0 +1,8 @@
--- a/plugins/shell/CMakeLists.txt
+++ b/plugins/shell/CMakeLists.txt
@@ -6,4 +6,4 @@
target_link_libraries(tm_shell -lutil)
-install(TARGETS tm_shell DESTINATION share/Xmacs/plugins/shell/bin)
+install(TARGETS tm_shell DESTINATION libexec/Xmacs/plugins/shell/bin)