libgrpc: Update from 1.17.2 to 1.20.1

This commit is contained in:
Fredrik Fornwall 2019-05-05 22:28:36 +02:00
parent 0ea0d0d2e4
commit 8df789bb53
4 changed files with 8 additions and 35 deletions

View File

@ -1,11 +1,12 @@
--- ./CMakeLists.txt 2017-07-09 09:11:13.314844730 +0530
+++ ../CMakeLists.txt 2017-07-09 09:14:19.309615851 +0530
@@ -322,7 +322,7 @@
COMMAND ${_gRPC_PROTOBUF_PROTOC}
diff -u -r ../cache/checkout-1.20.1/CMakeLists.txt ./CMakeLists.txt
--- ../cache/checkout-1.20.1/CMakeLists.txt 2019-05-05 19:34:14.719680525 +0000
+++ ./CMakeLists.txt 2019-05-05 19:44:36.428274714 +0000
@@ -206,7 +206,7 @@
COMMAND ${_gRPC_PROTOBUF_PROTOC_EXECUTABLE}
ARGS --grpc_out=generate_mock_code=true:${_gRPC_PROTO_GENS_DIR}
--cpp_out=${_gRPC_PROTO_GENS_DIR}
- --plugin=protoc-gen-grpc=$<TARGET_FILE:grpc_cpp_plugin>
+ --plugin=protoc-gen-grpc=@PATH_TO_PLUGIN@
- --plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
+ --plugin=protoc-gen-grpc=@PATH_TO_PLUGIN@
${_protobuf_include_path}
${REL_FIL}
DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} grpc_cpp_plugin

View File

@ -2,8 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://grpc.io/
TERMUX_PKG_DESCRIPTION="High performance, open source, general RPC framework that puts mobile and HTTP/2 first"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="Vishal Biswas @vishalbiswas"
TERMUX_PKG_VERSION=1.17.2
TERMUX_PKG_REVISION=2
TERMUX_PKG_VERSION=1.20.1
TERMUX_PKG_DEPENDS="openssl, protobuf, c-ares, zlib"
TERMUX_PKG_BUILD_DEPENDS="libprotobuf"
TERMUX_PKG_HOSTBUILD=true

View File

@ -1,12 +0,0 @@
diff -u -r ../pristine/src/core/ext/transport/chttp2/transport/flow_control.cc ./src/core/ext/transport/chttp2/transport/flow_control.cc
--- ../pristine/src/core/ext/transport/chttp2/transport/flow_control.cc 2018-11-27 01:07:46.866889212 +0000
+++ ./src/core/ext/transport/chttp2/transport/flow_control.cc 2018-11-27 01:11:22.480304660 +0000
@@ -190,7 +190,7 @@
uint32_t TransportFlowControl::MaybeSendUpdate(bool writing_anyway) {
FlowControlTrace trace("t updt sent", this, nullptr);
const uint32_t target_announced_window =
- static_cast<const uint32_t>(target_window());
+ static_cast<uint32_t>(target_window());
if ((writing_anyway || announced_window_ <= target_announced_window / 2) &&
announced_window_ != target_announced_window) {
const uint32_t announce = static_cast<uint32_t> GPR_CLAMP(

View File

@ -1,15 +0,0 @@
https://github.com/c-ares/c-ares/pull/209/files
diff -u -r ../pristine/third_party/cares/cares/ares_init.c ./third_party/cares/cares/ares_init.c
--- ../pristine/third_party/cares/cares/ares_init.c 2018-11-27 01:07:47.790878142 +0000
+++ ./third_party/cares/cares/ares_init.c 2018-11-27 01:08:17.002528134 +0000
@@ -298,7 +298,8 @@
(*dest)->sock_func_cb_data = src->sock_func_cb_data;
strncpy((*dest)->local_dev_name, src->local_dev_name,
- sizeof(src->local_dev_name));
+ sizeof((*dest)->local_dev_name));
+
(*dest)->local_ip4 = src->local_ip4;
memcpy((*dest)->local_ip6, src->local_ip6, sizeof(src->local_ip6));