gap: update to 4.12.2

Several workarounds are not needed anymore
This commit is contained in:
Max Horn 2022-12-19 00:33:17 +01:00 committed by xtkoba
parent caae917415
commit 90cf224d1d
3 changed files with 4 additions and 85 deletions

View File

@ -1,20 +0,0 @@
--- ../gap-4.12.1/Makefile.rules 2022-10-20 19:53:39.000000000 +0000
+++ ./Makefile.rules 2022-10-26 08:09:47.012253589 +0000
@@ -586,7 +586,7 @@
install-bin: gap
# install the real GAP executable as $(libdir)/gap/gap
$(INSTALL) -d -m 0755 $(DESTDIR)$(libdir)/gap
- $(LTINSTALL) -s gap $(DESTDIR)$(libdir)/gap
+ $(LTINSTALL) gap $(DESTDIR)$(libdir)/gap
# install a wrapper shell script invoking the real GAP executable as $(bindir)/gap
$(INSTALL) -d -m 0755 $(DESTDIR)$(bindir)
@@ -658,8 +658,6 @@
$(INSTALL) -m 0644 $(builddir)/build/version.h $(DESTDIR)$(includedir)/gap
$(INSTALL) -d -m 0755 $(DESTDIR)$(includedir)/gap/hpc
$(INSTALL) -m 0644 $(srcdir)/src/hpc/*.h $(DESTDIR)$(includedir)/gap/hpc
- # Create a symlink to support packages using `#include "src/compiled.h"`
- ln -sfn . $(DESTDIR)$(includedir)/gap/src
install-libgap: libgap.la
$(INSTALL) -d -m 0755 $(DESTDIR)$(libdir)

View File

@ -2,22 +2,14 @@ TERMUX_PKG_HOMEPAGE=https://www.gap-system.org/
TERMUX_PKG_DESCRIPTION="GAP is a system for computational discrete algebra, with particular emphasis on Computational Group Theory"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=4.12.1
TERMUX_PKG_VERSION=4.12.2
TERMUX_PKG_SRCURL=https://github.com/gap-system/gap/releases/download/v${TERMUX_PKG_VERSION}/gap-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=f9ebef11ee31b210ce36e3c70960742b4e253282bbd5270adc9324273c92b016
TERMUX_PKG_SHA256=672308745eb78a222494ee8dd6786edd5bc331456fcc6456ac064bdb28d587a8
TERMUX_PKG_DEPENDS="readline, libgmp, zlib, gap-packages"
TERMUX_PKG_BREAKS="gap-dev"
TERMUX_PKG_REPLACES="gap-dev"
TERMUX_PKG_GROUPS="science"
termux_step_post_configure() {
# workaround build system bug that occurs when doing
# an out-of-tree cross compilation build
mkdir -p src
cp $TERMUX_PKG_SRCDIR/src/ffdata.* src/
cp $TERMUX_PKG_SRCDIR/src/c_*.c src/
}
termux_step_post_make_install() {
mkdir -p $TERMUX_PREFIX/lib/gap/pkg
# install at least gapdoc, smallgrp, transgrp, primgrp or else
@ -27,9 +19,7 @@ termux_step_post_make_install() {
cp -r $TERMUX_PKG_SRCDIR/pkg/transgrp $TERMUX_PREFIX/lib/gap/pkg/
cp -r $TERMUX_PKG_SRCDIR/pkg/primgrp $TERMUX_PREFIX/lib/gap/pkg/
# To get them to be small enough, could gzip them in place
# To save some disk space, compress transgrp data in place
# (GAP transparently allows read access to those)
gzip -9 -n -f $TERMUX_PREFIX/lib/gap/pkg/*/data/*.*
gzip -9 -n -f $TERMUX_PREFIX/lib/gap/pkg/smallgrp/id*/*.*
gzip -9 -n -f $TERMUX_PREFIX/lib/gap/pkg/smallgrp/small*/*.*
gzip -9 -n -f $TERMUX_PREFIX/lib/gap/pkg/transgrp/data/*.*
}

View File

@ -1,54 +1,3 @@
diff --git ./pkg/caratinterface/src/setcaratdir.c b/pkg/caratinterface/src/setcaratdir.c
index b4010465..5e2a0eea 100644
--- ./pkg/caratinterface/src/setcaratdir.c
+++ ./pkg/caratinterface/src/setcaratdir.c
@@ -1,6 +1,6 @@
#include <stdio.h>
#include <stdlib.h>
-#include "src/compiled.h"
+#include "compiled.h"
Obj FuncSET_CARAT_DIR( Obj self, Obj str ) {
setenv("CARAT_DIR", CSTR_STRING(str), 1);
diff --git ./pkg/cddinterface/src/CddInterface.c b/pkg/cddinterface/src/CddInterface.c
index 9c931ba0..19e7eb75 100644
--- ./pkg/cddinterface/src/CddInterface.c
+++ ./pkg/cddinterface/src/CddInterface.c
@@ -2,7 +2,7 @@
* CddInterface: Gap interface to Cdd package
*/
-#include "src/compiled.h" /* GAP headers */
+#include "compiled.h" /* GAP headers */
#include "setoper.h"
#include "cdd.h"
diff --git ./pkg/digraphs/src/cliques.c b/pkg/digraphs/src/cliques.c
index 4bcf8219..f7f34728 100644
--- ./pkg/digraphs/src/cliques.c
+++ ./pkg/digraphs/src/cliques.c
@@ -15,7 +15,7 @@
#include <stdlib.h> // for malloc, NULL
// GAP headers
-#include "src/compiled.h"
+#include "compiled.h"
// Digraphs package headers
#include "bitarray.h" // for BitArray
diff --git ./pkg/digraphs/src/cliques.h b/pkg/digraphs/src/cliques.h
index d953121b..909c7919 100644
--- ./pkg/digraphs/src/cliques.h
+++ ./pkg/digraphs/src/cliques.h
@@ -12,7 +12,7 @@
#define DIGRAPHS_SRC_CLIQUES_H_
// GAP headers
-#include "src/compiled.h"
+#include "compiled.h"
Obj FuncDigraphsCliquesFinder(Obj self, Obj args);
diff --git ./pkg/edim/src/compstat_with_ediv.c b/pkg/edim/src/compstat_with_ediv.c
index 0b335b25..010122d1 100644
--- ./pkg/edim/src/compstat_with_ediv.c