new package: python-lameenc

This commit is contained in:
Tee KOBAYASHI 2023-02-13 18:16:41 +09:00 committed by xtkoba
parent 13192a977c
commit 924310cc4e
2 changed files with 46 additions and 0 deletions

View File

@ -0,0 +1,35 @@
TERMUX_PKG_HOMEPAGE=https://github.com/chrisstaite/lameenc
TERMUX_PKG_DESCRIPTION="Python bindings around the LAME encoder"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.4.2
TERMUX_PKG_SRCURL=https://github.com/chrisstaite/lameenc/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=a4798f088eb58be929ecf23b9a5e25fafc55a9c1b96550b7074a72cdf80cd3b8
TERMUX_PKG_DEPENDS="libmp3lame, python"
TERMUX_PKG_PYTHON_COMMON_DEPS="wheel"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
rm -rf build dist
}
termux_step_configure() {
:
}
termux_step_make() {
python setup.py \
--libdir=$TERMUX_PREFIX/lib \
--incdir=$TERMUX_PREFIX/include/lame \
bdist_wheel
}
termux_step_make_install() {
local f
for f in dist/lameenc-${TERMUX_PKG_VERSION#*:}-*.whl; do
if [ -e "${f}" ]; then
pip install --force "${f}" --prefix $TERMUX_PREFIX
break
fi
done
}

View File

@ -0,0 +1,11 @@
--- a/setup.py
+++ b/setup.py
@@ -32,7 +32,7 @@
include_dirs=[incdir],
libraries=['libmp3lame'] if sys.platform == 'win32' else [],
extra_objects=
- [] if sys.platform == 'win32' else [os.path.join(libdir, 'libmp3lame.a')],
+ [] if sys.platform == 'win32' else [os.path.join(libdir, 'libmp3lame.so')],
library_dirs=[libdir] if sys.platform == 'win32' else [],
sources=['lameenc.c']
)