mailutils: Add dependencies

and avoid automagic dependencies.
This commit is contained in:
Tee KOBAYASHI 2022-11-17 10:00:40 +09:00 committed by xtkoba
parent a8d1fb4a13
commit 97a17d018b
2 changed files with 25 additions and 1 deletions

View File

@ -3,9 +3,22 @@ TERMUX_PKG_DESCRIPTION="Mailutils is a swiss army knife of electronic mail handl
TERMUX_PKG_LICENSE="LGPL-3.0, GPL-3.0"
TERMUX_PKG_MAINTAINER="@suhan-paradkar"
TERMUX_PKG_VERSION=3.15
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://ftp.gnu.org/gnu/mailutils/mailutils-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=b7d0c286c352fcc7da7978cfd617cc66736b21fa891aa4f88855f516354f2ddb
TERMUX_PKG_DEPENDS="libandroid-glob, libcrypt"
TERMUX_PKG_DEPENDS="libandroid-glob, libcrypt, libiconv, libltdl, libunistring, ncurses, readline"
# Most of these configure arguments are for avoiding automagic dependencies.
# You may instead add dependencies properly and enable them.
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-python
--without-gssapi
--without-gnutls
--without-gdbm
--without-berkeley-db
--without-fribidi
--without-ldap
--without-guile
"
termux_step_pre_configure() {
export LIBS="-landroid-glob"

View File

@ -0,0 +1,11 @@
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -1031,7 +1031,7 @@
noinst_LIBRARIES = libmuscript.a libmutcpwrap.a
libmuaux_la_SOURCES = mailcap.c manlock.c mdecode.c signal.c strexit.c \
mu_umaxtostr.c mu_umaxtostr.h $(am__append_3) $(am__append_4)
-libmuaux_la_LIBADD = gnu/libgnu.la
+libmuaux_la_LIBADD = gnu/libgnu.la $(UNISTRING_LIBS)
libmuaux_la_LDFLAGS = -version-info @VI_CURRENT@:@VI_REVISION@:@VI_AGE@
libmutcpwrap_a_SOURCES = tcpwrap.c
noinst_HEADERS = \