Add runit package (#5384)

* runit: add package

* termux-services: switch to using runit instead of busybox
This commit is contained in:
Henrik Grimler 2020-06-10 14:18:13 +02:00 committed by GitHub
parent 2f9d04e2d5
commit 98a9ec70b9
5 changed files with 50 additions and 3 deletions

View File

@ -0,0 +1,14 @@
--- ../src.orig/runit-2.1.2/src/Makefile 2020-06-10 13:15:17.927086588 +0200
+++ ./runit-2.1.2/src/Makefile 2020-06-10 13:39:52.277171576 +0200
@@ -232,9 +232,8 @@
hassgprm.h: choose compile hassgprm.h1 hassgprm.h2 load trysgprm.c
./choose cl trysgprm hassgprm.h1 hassgprm.h2 > hassgprm.h
-hasshsgr.h: chkshsgr choose compile hasshsgr.h1 hasshsgr.h2 load \
-tryshsgr.c warn-shsgr
- ./chkshsgr || ( cat warn-shsgr; exit 1 )
+hasshsgr.h: choose compile hasshsgr.h1 hasshsgr.h2 load \
+tryshsgr.c
./choose clr tryshsgr hasshsgr.h1 hasshsgr.h2 > hasshsgr.h
haswaitp.h: choose compile haswaitp.h1 haswaitp.h2 load trywaitp.c

15
packages/runit/build.sh Normal file
View File

@ -0,0 +1,15 @@
TERMUX_PKG_HOMEPAGE=http://smarden.org/runit
TERMUX_PKG_DESCRIPTION="Tools to provide service supervision and to manage services"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=2.1.2
TERMUX_PKG_SRCURL=http://smarden.org/runit/runit-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=6fd0160cb0cf1207de4e66754b6d39750cff14bb0aa66ab49490992c0c47ba18
TERMUX_PKG_EXTRA_MAKE_ARGS="-C runit-${TERMUX_PKG_VERSION}/src"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_make_install() {
install -Dm755 runit-${TERMUX_PKG_VERSION}/src/{chpst,runit,runsv,runsvchdir,runsvdir,sv,svlogd,utmpset} $TERMUX_PREFIX/bin/
mkdir -p $TERMUX_PREFIX/share/man/man8
install -Dm644 runit-${TERMUX_PKG_VERSION}/man/{chpst,runit,runsv,runsvchdir,runsvdir,sv,svlogd,utmpset}.8 $TERMUX_PREFIX/share/man/man8/
}

View File

@ -0,0 +1,10 @@
--- ../src.orig/runit-2.1.2/src/conf-cc 2020-06-10 13:15:17.927086588 +0200
+++ ./runit-2.1.2/src/conf-cc 2020-06-10 13:27:28.210306192 +0200
@@ -1,5 +1,5 @@
-gcc -O2 -Wall
+${CC} ${CPPFLAGS} ${CFLAGS}
-gcc -O2 -Wimplicit -Wunused -Wcomment -Wchar-subscripts -Wuninitialized -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings
+${CC} -Wimplicit -Wunused -Wcomment -Wchar-subscripts -Wuninitialized -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings ${CPPFLAGS} ${CFLAGS}
This will be used to compile .c files.

View File

@ -0,0 +1,7 @@
--- ../src.orig/runit-2.1.2/src/conf-ld 2020-06-10 13:15:17.927086588 +0200
+++ ./runit-2.1.2/src/conf-ld 2020-06-10 13:33:42.302118866 +0200
@@ -1,3 +1,3 @@
-gcc -s
+${CC} ${LDFLAGS} -s
This will be used to link .o files into an executable.

View File

@ -1,9 +1,10 @@
TERMUX_PKG_HOMEPAGE=https://github.com/termux/termux-services/
TERMUX_PKG_DESCRIPTION="Service daemon for Termux"
TERMUX_PKG_VERSION=0.12
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=0.13
TERMUX_PKG_SRCURL=https://github.com/termux/termux-services/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=b7b31e2a958774ce9c59120b7803dbb8ed9daca8d40dd2f1d50bd46573be25d2
TERMUX_PKG_DEPENDS="busybox, coreutils"
TERMUX_PKG_SHA256=486a2b21332e0557764c706e6d01a33af54425ee4ac9cc3d3e74ee574799ffb9
TERMUX_PKG_DEPENDS="runit, coreutils"
TERMUX_PKG_PLATFORM_INDEPENDENT=true
TERMUX_PKG_BUILD_IN_SRC=true