bump(main/dar): 2.7.14

This commit is contained in:
tqfx 2024-04-22 21:05:07 +08:00 committed by Twaik Yont
parent 420f5469a9
commit 99f9a40476
3 changed files with 47 additions and 45 deletions

View File

@ -2,13 +2,13 @@ TERMUX_PKG_HOMEPAGE=http://dar.linux.free.fr/
TERMUX_PKG_DESCRIPTION="A full featured command-line backup tool, short for Disk ARchive"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="2.7.13"
TERMUX_PKG_VERSION="2.7.14"
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/dar/dar/${TERMUX_PKG_VERSION}/dar-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=2d563b5d1d928a3eecab719cc22d43320786c52053f4e3a557cdf1c84b120f4c
TERMUX_PKG_SHA256=40d4dba44260df3a8ddce1e61f411ea9ab43c2cfc47bd83ab868c939d19dc582
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="attr, libbz2, libc++, libgcrypt, libgpg-error, liblzma, liblzo, zlib, zstd"
TERMUX_PKG_BUILD_IN_SRC=
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-dar-static "
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-dar-static"
termux_step_pre_configure() {
if [ "$TERMUX_ARCH_BITS" = "32" ]; then

View File

@ -1,46 +1,47 @@
diff -uNr dar-2.7.0/configure dar-2.7.0.mod/configure
--- dar-2.7.0/configure 2021-04-24 12:18:42.000000000 +0000
+++ dar-2.7.0.mod/configure 2021-05-03 18:46:56.060794046 +0000
@@ -24003,7 +24003,7 @@
diff --git a/configure b/configure
--- a/configure
+++ b/configure
@@ -26165,7 +26165,7 @@ printf "%s\n" "#define MIN_VERSION_GCRYPT_HASH_BUG \"$min_version_gcrypt_hash_bu
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libgcrypt usability" >&5
$as_echo_n "checking for libgcrypt usability... " >&6; }
- if test "$cross_compiling" = yes; then :
+ if test "$cross_compiling" = fakeyes; then :
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for libgcrypt usability" >&5
printf %s "checking for libgcrypt usability... " >&6; }
- if test "$cross_compiling" = yes
+ if test "$cross_compiling" = fakeyes;
then :
# if cross compiling
@@ -24071,13 +24071,13 @@
@@ -26235,14 +26235,14 @@ main (void)
}
_ACEOF
-if ac_fn_cxx_try_run "$LINENO"; then :
+if true; then :
-if ac_fn_cxx_try_run "$LINENO"
+if true;
then :
$as_echo "#define CRYPTO_AVAILABLE 1" >>confdefs.h
printf "%s\n" "#define CRYPTO_AVAILABLE 1" >>confdefs.h
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ok" >&5
$as_echo "ok" >&6; }
- if test "$cross_compiling" = yes; then :
+ if test "$cross_compiling" = "fakeyes"; then :
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
as_fn_error $? "cannot run test program while cross compiling
@@ -24106,7 +24106,7 @@
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: ok" >&5
printf "%s\n" "ok" >&6; }
- if test "$cross_compiling" = yes
+ if test "$cross_compiling" = "fakeyes"
then :
{ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
printf "%s\n" "$as_me: error: in \`$ac_pwd':" >&2;}
@@ -26272,7 +26272,7 @@ main (void)
}
_ACEOF
-if ac_fn_cxx_try_run "$LINENO"; then :
+if true; then :
-if ac_fn_cxx_try_run "$LINENO"
+if true;
then :
else
libgcrypt_hash_bug="yes"
@@ -26596,7 +26596,7 @@
else $as_nop
@@ -28990,7 +28990,7 @@ main (void)
}
_ACEOF
-if ac_fn_cxx_try_run "$LINENO"; then :
+if false; then :
-if ac_fn_cxx_try_run "$LINENO"
+if false;
then :
local_threadar=yes

View File

@ -1,8 +1,9 @@
diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
--- dar-2.7.0/src/Makefile.in 2021-04-24 12:18:44.000000000 +0000
+++ dar-2.7.0.mod/src/Makefile.in 2021-05-03 18:59:53.520818313 +0000
@@ -142,12 +142,12 @@
am__v_at_1 =
diff --git a/src/Makefile.in b/src/Makefile.in
index dd8771b..ddd403e 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -143,12 +143,12 @@ am__v_at_0 = @
am__v_at_1 =
SOURCES =
DIST_SOURCES =
-RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
@ -16,16 +17,16 @@ diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
installdirs-recursive pdf-recursive ps-recursive \
tags-recursive uninstall-recursive
am__can_run_installinfo = \
@@ -184,7 +184,7 @@
@@ -183,7 +183,7 @@ am__define_uniq_tagged_files = \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | $(am__uniquify_input)`
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = libdar dar_suite check python examples testing
+DIST_SUBDIRS = libdar dar_suite python examples testing
am__DIST_COMMON = $(srcdir)/Makefile.in README
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
am__relativize = \
@@ -373,7 +373,7 @@
@@ -376,7 +376,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
upx = @upx@
@MAKE_ALL_DIR_TRUE@OPT_SUBDIR = examples testing
@ -34,7 +35,7 @@ diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
noinst_HEADERS = my_config.h
dist_noinst_DATA = README gettext.h
all: all-recursive
@@ -572,8 +572,6 @@
@@ -574,8 +574,6 @@ distdir-am: $(DISTFILES)
|| exit 1; \
fi; \
done
@ -43,7 +44,7 @@ diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
all-am: Makefile $(DATA) $(HEADERS)
installdirs: installdirs-recursive
installdirs-am:
@@ -585,7 +583,6 @@
@@ -587,7 +585,6 @@ uninstall: uninstall-recursive
install-am: all-am
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
@ -51,7 +52,7 @@ diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
install-strip:
if test -z '$(STRIP)'; then \
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
@@ -653,8 +650,6 @@
@@ -655,8 +652,6 @@ install-ps: install-ps-recursive
install-ps-am:
@ -60,7 +61,7 @@ diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
maintainer-clean: maintainer-clean-recursive
-rm -f Makefile
maintainer-clean-am: distclean-am maintainer-clean-generic
@@ -675,15 +670,15 @@
@@ -677,15 +672,15 @@ uninstall-am:
.MAKE: $(am__recursive_targets) install-am install-strip