newsboat: revert to 2.19

This commit is contained in:
Butta 2020-08-10 01:18:44 +05:30
parent a222457a36
commit 9ae491e849
3 changed files with 15 additions and 51 deletions

View File

@ -32,8 +32,8 @@ diff -u -r ../newsboat-2.16.1/Makefile ./Makefile
PODBOAT=podboat
PODBOAT_SOURCES:=$(shell cat mk/podboat.deps)
PODBOAT_OBJS:=$(patsubst %.cpp,%.o,$(PODBOAT_SOURCES))
-PODBOAT_LIBS=-lboat -lnewsboat -lfilter -lpthread -ldl
+PODBOAT_LIBS=-lboat -lnewsboat -lfilter -ldl
-PODBOAT_LIBS=-lboat -lnewsboat -lpthread -ldl
+PODBOAT_LIBS=-lboat -lnewsboat -ldl
ifeq (, $(filter Linux GNU GNU/%, $(shell uname -s)))
NEWSBOAT_LIBS+=-liconv -lintl

View File

@ -40,51 +40,14 @@ diff -uNr newsboat-2.17/rust/libnewsboat/src/cliargsparser.rs newsboat-2.17.mod/
&opts[0],
log_level_str
);
diff -ruw newsboat-2.20.1/rust/regex-rs/Cargo.toml src/rust/regex-rs/Cargo.toml
--- newsboat-2.20.1/rust/regex-rs/Cargo.toml 2020-06-24 09:51:43.000000000 +0000
+++ src/rust/regex-rs/Cargo.toml 2020-08-09 15:53:33.917513569 +0000
@@ -12,4 +12,3 @@
diff -uNr newsboat-2.17/rust/libnewsboat/src/lib.rs newsboat-2.17.mod/rust/libnewsboat/src/lib.rs
--- newsboat-2.17/rust/libnewsboat/src/lib.rs 2019-09-22 17:19:19.000000000 +0300
+++ newsboat-2.17.mod/rust/libnewsboat/src/lib.rs 2019-09-24 20:56:44.030818719 +0300
@@ -11,7 +11,6 @@
#[macro_use]
extern crate proptest;
extern crate clap;
-extern crate gettextrs;
extern crate libc;
bitflags = "1.0"
libc = ">=0.2.69"
-gettext-rs = "0.4.1"
diff -ruw newsboat-2.20.1/rust/regex-rs/src/lib.rs src/rust/regex-rs/src/lib.rs
--- newsboat-2.20.1/rust/regex-rs/src/lib.rs 2020-06-24 09:51:43.000000000 +0000
+++ src/rust/regex-rs/src/lib.rs 2020-08-09 15:55:06.893777550 +0000
@@ -29,7 +29,6 @@
//! ```
use bitflags::bitflags;
-use gettextrs::gettext;
use libc::{regcomp, regerror, regex_t, regexec, regfree, regmatch_t};
use std::ffi::{CString, OsString};
use std::mem;
@@ -155,12 +154,12 @@
} else {
match regex_error_to_str(errcode, &regex) {
Some(regcomp_errmsg) => {
- let msg = fmt!(&gettext("regcomp returned code %i"), errcode);
+ let msg = fmt!("regcomp returned code %i", errcode);
let msg = format!("{}: {}", msg, regcomp_errmsg);
Err(msg)
}
- None => Err(fmt!(&gettext("regcomp returned code %i"), errcode)),
+ None => Err(fmt!("regcomp returned code %i", errcode)),
}
}
}
@@ -240,11 +239,11 @@
_ => unsafe {
match regex_error_to_str(errcode, &self.regex) {
Some(regexec_errmsg) => {
- let msg = fmt!(&gettext("regexec returned code %i"), errcode);
+ let msg = fmt!("regexec returned code %i", errcode);
let msg = format!("{}: {}", msg, regexec_errmsg);
Err(msg)
}
- None => Err(fmt!(&gettext("regexec returned code %i"), errcode)),
+ None => Err(fmt!("regexec returned code %i", errcode)),
}
},
}
// This module must be declared before the others because it exports a `log!` macro that everyone

View File

@ -1,9 +1,10 @@
TERMUX_PKG_HOMEPAGE=https://newsboat.org/
TERMUX_PKG_DESCRIPTION="RSS/Atom feed reader for the text console"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=2.20.1
TERMUX_PKG_VERSION=2.19
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://newsboat.org/releases/${TERMUX_PKG_VERSION}/newsboat-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=82782079b75fe307f7a5a17dff9e712aa5975678fa550fb728d5a46867943566
TERMUX_PKG_SHA256=ba484c825bb903daf6d33d55126107b59e41111b455d368362208f1825403d1b
TERMUX_PKG_DEPENDS="libc++, libiconv, libandroid-support, libandroid-glob, json-c, libsqlite, libcurl, libxml2, stfl, ncurses, openssl"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"