csol: Bump to 1.6.0

This commit is contained in:
Tee KOBAYASHI 2023-03-09 13:27:22 +09:00 committed by xtkoba
parent 94417ace0f
commit a305097441
4 changed files with 14 additions and 19 deletions

View File

@ -17,8 +17,7 @@ diff -uNr csol-1.5.0/CMakeLists.txt csol-1.5.0.mod/CMakeLists.txt
-install(FILES "${CMAKE_BINARY_DIR}/csolrc" DESTINATION /etc/xdg/csol COMPONENT config)
-install(DIRECTORY "${CMAKE_BINARY_DIR}/themes" DESTINATION /etc/xdg/csol COMPONENT config)
-install(DIRECTORY "${CMAKE_BINARY_DIR}/games" DESTINATION /etc/xdg/csol COMPONENT config)
-install(FILES "${CMAKE_BINARY_DIR}/doc/csol.6" DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man6)
+install(FILES "${CMAKE_BINARY_DIR}/csolrc" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(DIRECTORY "${CMAKE_BINARY_DIR}/themes" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(DIRECTORY "${CMAKE_BINARY_DIR}/games" DESTINATION @TERMUX_PREFIX@/etc/xdg/csol COMPONENT config)
+install(FILES "${CMAKE_BINARY_DIR}/doc/csol.6" DESTINATION @TERMUX_PREFIX@/share/man/man6)
install(FILES "${PROJECT_SOURCE_DIR}/doc/csol.6" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man6)

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/nielssp/csol
TERMUX_PKG_DESCRIPTION="A small collection of solitaire games implemented in C using ncurses"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.5.0
TERMUX_PKG_VERSION=1.6.0
TERMUX_PKG_SRCURL=https://github.com/nielssp/csol/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=f14ad0756cf7d3ae63fd73e28ae6be7a9f8047380dc4300ff44388aefcfef4f4
TERMUX_PKG_SHA256=9fa45da2b73fcb4e58b5e0734c92e5325e664fab95ca31873760244ef9ddedd9
TERMUX_PKG_DEPENDS="libandroid-support, ncurses"
TERMUX_CMAKE_BUILD="Unix Makefiles"
TERMUX_PKG_GROUPS="games"

View File

@ -1,15 +0,0 @@
--- a/src/main.c
+++ b/src/main.c
@@ -100,10 +100,10 @@
}
}
} else {
- f = fopen("/etc/xdg/csol/csolrc", "r");
+ f = fopen("@TERMUX_PREFIX@/etc/xdg/csol/csolrc", "r");
if (f) {
fclose(f);
- return strdup("/etc/xdg/csol/csolrc");
+ return strdup("@TERMUX_PREFIX@/etc/xdg/csol/csolrc");
}
}
#endif

View File

@ -0,0 +1,11 @@
--- a/src/util.c
+++ b/src/util.c
@@ -104,7 +104,7 @@
}
free(relative_path);
} else {
- config_file = combine_paths("/etc/xdg", relative_path);
+ config_file = combine_paths("@TERMUX_PREFIX@/etc/xdg", relative_path);
free(relative_path);
f = fopen(config_file, "r");
if (f) {