recoll: Bump to 1.34.0

This commit is contained in:
Tee KOBAYASHI 2023-01-08 15:12:22 +09:00 committed by xtkoba
parent bb3dea5d60
commit a4daf872e6
3 changed files with 41 additions and 6 deletions

View File

@ -1,3 +1,30 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -619,7 +619,7 @@
# php/00README.txt php/recoll/config.m4 php/recoll/make.sh
# php/recoll/php_recoll.h php/recoll/recoll.cpp php/sample/shell.php
-OPTSFORPYTHON = $(shell test -f /etc/debian_version && echo --install-layout=deb)
+OPTSFORPYTHON =
if MAKEPYTHON
all-local:: recollpython
@@ -627,13 +627,13 @@
clean-local:: recollpython-clean
recollpython: librecoll.la
(cd python/recoll; set -x; \
- for v in 2 3;do test -n "`which python$${v}`" && \
+ for v in 3;do test -n "`command -v python$${v}`" && \
libdir=$(libdir) python$${v} setup.py build; \
done \
)
recollpython-install:
(cd python/recoll; set -x; \
- for v in 2 3;do test -n "`which python$${v}`" && \
+ for v in 3;do test -n "`command -v python$${v}`" && \
python$${v} setup.py install \
--prefix=${prefix} --root=$${DESTDIR:-/} $(OPTSFORPYTHON); \
done; \
--- a/Makefile.in
+++ b/Makefile.in
@@ -1145,7 +1145,7 @@

View File

@ -2,16 +2,16 @@ TERMUX_PKG_HOMEPAGE=https://www.lesbonscomptes.com/recoll/index.html
TERMUX_PKG_DESCRIPTION="Full-text search for your desktop"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.33.4
TERMUX_PKG_REVISION=2
TERMUX_PKG_VERSION=1.34.0
TERMUX_PKG_SRCURL=https://www.lesbonscomptes.com/recoll/recoll-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=7df0f8f6c1985981160053d1b69c8353f09816f92b1032f6d4376add0b170af7
TERMUX_PKG_SHA256=7baeaac2c79dcbff6d866f986c2d538603f25378dd71862f2cb7e775c6594668
TERMUX_PKG_DEPENDS="aspell, file, libc++, libiconv, libxapian, libxml2, libxslt, zlib"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
ac_cv_path_aspellProg=$TERMUX_PREFIX/bin/aspell
--with-file-command=$TERMUX_PREFIX/bin/file
--disable-userdoc
--disable-python-chm
--disable-python-aspell
--disable-x11mon
--disable-qtgui
"
@ -37,3 +37,11 @@ termux_step_pre_configure() {
$TERMUX_PKG_BUILDER_DIR/python-recoll-setup.py.in.diff \
| patch --silent -p1
}
termux_step_post_massage() {
# Regression test for https://github.com/termux/termux-packages/issues/14293
if ! readelf -d bin/recollindex | grep -E -q \
'\(RUNPATH\).*(\[|:)'"${TERMUX_PREFIX//./\\.}"'/lib/recoll(:|\])'; then
termux_error_exit "RUNPATH for recollindex is not properly set."
fi
}

View File

@ -159,9 +159,9 @@
idxrundir = tmp
@@ -857,7 +857,7 @@
# command.</brief><descr>Some aspell packages may need an additional option
# (e.g. on Debian Jessie: --local-data-dir=/usr/lib/aspell). See Debian bug
# 772415.</descr></var>
# <brief>Additional option and parameter to aspell dictionary creation command.</brief>
# <descr>Some aspell packages may need an additional option (e.g. on Debian Jessie:
# --local-data-dir=/usr/lib/aspell). See Debian bug 772415.</descr></var>
-#aspellAddCreateParam = --local-data-dir=/usr/lib/aspell
+#aspellAddCreateParam = --local-data-dir=@TERMUX_PREFIX@/lib/aspell