tesseract: Bump to 5.3.0

This commit is contained in:
Tee KOBAYASHI 2022-12-23 09:57:58 +09:00 committed by xtkoba
parent 1ad9b1d32c
commit a79d28ab1a
2 changed files with 5 additions and 13 deletions

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/tesseract-ocr/tesseract
TERMUX_PKG_DESCRIPTION="Tesseract is probably the most accurate open source OCR engine available"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=5.2.0
TERMUX_PKG_REVISION=4
TERMUX_PKG_VERSION=5.3.0
TERMUX_PKG_SRCURL=https://github.com/tesseract-ocr/tesseract/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=eba4deb2f92a3f89a6623812074af8c53b772079525b3c263aa70bbf7b748b3c
TERMUX_PKG_SHA256=7e70870f8341e5ea228af2836ce79a36eefa11b01b56177b4a8997f330c014b8
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="leptonica, libandroid-glob, libandroid-posix-semaphore, libcpufeatures, libc++, libicu, libtool, libuuid, openmpi, pango, zstd"
TERMUX_PKG_BREAKS="tesseract-dev"

View File

@ -1,7 +1,7 @@
diff -uNr tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0.mod/src/training/CMakeLists.txt
--- tesseract-5.2.0/src/training/CMakeLists.txt 2022-07-07 05:15:49.000000000 +0900
+++ tesseract-5.2.0.mod/src/training/CMakeLists.txt 2022-09-30 13:12:18.222593892 +0900
@@ -108,13 +108,14 @@
@@ -115,7 +115,7 @@
common/trainingsampleset.h)
endif()
@ -10,13 +10,6 @@ diff -uNr tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0.mod/src/tr
target_include_directories(common_training PUBLIC common
${CMAKE_CURRENT_BINARY_DIR})
target_link_libraries(common_training PUBLIC libtesseract)
generate_export_header(common_training EXPORT_MACRO_NAME
TESS_COMMON_TRAINING_API)
project_group(common_training "Training Tools")
+install(TARGETS common_training DESTINATION lib)
# ##############################################################################
# EXECUTABLE ambiguous_words
@@ -242,7 +243,7 @@
file(GLOB unicharset_training_src unicharset/*)
@ -30,8 +23,8 @@ diff -uNr tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0.mod/src/tr
PkgConfig::ICU)
else()
target_link_libraries(unicharset_training PUBLIC common_training
- ${ICU_LINK_LIBRARIES})
+ ${ICU_LINK_LIBRARIES} libandroid-glob.so)
- ${ICU_LIBRARIES})
+ ${ICU_LIBRARIES} libandroid-glob.so)
endif()
endif()
target_include_directories(unicharset_training