libgit2: Bump to 1.6.2

This commit is contained in:
Tee KOBAYASHI 2023-03-01 13:04:13 +09:00 committed by xtkoba
parent 1ce8a0b444
commit ac961851da
3 changed files with 3 additions and 66 deletions

View File

@ -4,9 +4,9 @@ TERMUX_PKG_DESCRIPTION="C library implementing Git core methods"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_LICENSE_FILE="COPYING"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.5.2
TERMUX_PKG_VERSION=1.6.2
TERMUX_PKG_SRCURL=https://github.com/libgit2/libgit2/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=57638ac0e319078f56a7e17570be754515e5b1276d3750904b4214c92e8fa196
TERMUX_PKG_SHA256=d557fbf35557bb5df53cbf38ae0081edb4a36494ec0d19741fa673e509245f8f
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="libssh2, openssl, pcre2, zlib"
TERMUX_PKG_BUILD_DEPENDS="libiconv, libpcreposix"
@ -21,7 +21,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
termux_step_post_get_source() {
# Do not forget to bump revision of reverse dependencies and rebuild them
# after SOVERSION is changed.
local _SOVERSION=1.5
local _SOVERSION=1.6
local v=$(echo ${TERMUX_PKG_VERSION#*:} | cut -d . -f 1-2)
if [ "${v}" != "${_SOVERSION}" ]; then
@ -32,6 +32,4 @@ termux_step_post_get_source() {
termux_step_pre_configure() {
find "$TERMUX_PKG_SRCDIR" -name CMakeLists.txt | xargs -n 1 \
sed -i 's/\( PROPERTIES C_STANDARD\) 90/\1 99/g'
cp "$TERMUX_PKG_BUILDER_DIR"/getloadavg.c "$TERMUX_PKG_SRCDIR"/src/util/
}

View File

@ -1,48 +0,0 @@
/*
* Copyright (C) 2018 The Android Open Source Project
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
* * Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
* * Redistributions in binary form must reproduce the above copyright
* notice, this list of conditions and the following disclaimer in
* the documentation and/or other materials provided with the
* distribution.
*
* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
* OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
* AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
* OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
* OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*/
#if defined __ANDROID__ && __ANDROID_API__ < 29
#include <stdlib.h>
#include <sys/sysinfo.h>
int getloadavg(double averages[], int n) {
if (n < 0) return -1;
if (n > 3) n = 3;
struct sysinfo si;
if (sysinfo(&si) == -1) return -1;
for (int i = 0; i < n; ++i) {
averages[i] = (double)(si.loads[i]) / (double)(1 << SI_LOAD_SHIFT);
}
return n;
}
#endif

View File

@ -1,13 +0,0 @@
--- a/src/util/rand.c
+++ b/src/util/rand.c
@@ -14,6 +14,10 @@
# include <sys/random.h>
#endif
+#if defined __ANDROID__ && __ANDROID_API__ < 29
+int getloadavg(double[], int);
+#endif
+
static uint64_t state[4];
static git_mutex state_lock;