libfuse3: Bump to 3.12.0

This commit is contained in:
Tee KOBAYASHI 2022-11-24 02:44:52 +09:00 committed by xtkoba
parent ea4475aa5b
commit bb2f15ac01
3 changed files with 5 additions and 17 deletions

View File

@ -2,14 +2,14 @@ TERMUX_PKG_HOMEPAGE=https://github.com/libfuse/libfuse
TERMUX_PKG_DESCRIPTION="FUSE (Filesystem in Userspace) is an interface for userspace programs to export a filesystem to the Linux kernel"
TERMUX_PKG_LICENSE="LGPL-2.1, GPL-2.0"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=3.10.3
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=3.12.0
TERMUX_PKG_SRCURL=https://github.com/libfuse/libfuse/archive/fuse-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=c32527782cef620df58b162aa29901d1fb13253b029375d5860a2253a810344e
TERMUX_PKG_SHA256=df6cc8807c4fd36b6b0ebef2b738dad6d19a9c7c085ccc3775063688d0bfcc0b
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Ddisable-mtab=true
-Dexamples=false
-Dtests=false
-Dsbindir=bin
-Dmandir=share/man
-Dudevrulesdir=$TERMUX_PREFIX/etc/udev/rules.d

View File

@ -1,9 +1,9 @@
--- a/lib/fuse_loop_mt.c
+++ b/lib/fuse_loop_mt.c
@@ -24,6 +24,7 @@
#include <sys/time.h>
@@ -25,6 +25,7 @@
#include <sys/ioctl.h>
#include <assert.h>
#include <limits.h>
+#include <stdatomic.h>
/* Environment var controlling the thread stack size */

View File

@ -33,15 +33,3 @@ diff -uNr libfuse-fuse-3.9.1/lib/meson.build libfuse-fuse-3.9.1.mod/lib/meson.bu
libraries_private: '-ldl',
version: meson.project_version(),
name: 'fuse3',
diff -uNr libfuse-fuse-3.9.1/meson.build libfuse-fuse-3.9.1.mod/meson.build
--- libfuse-fuse-3.9.1/meson.build 2020-03-19 22:00:41.000000000 +0200
+++ libfuse-fuse-3.9.1.mod/meson.build 2020-08-11 20:32:23.502040209 +0300
@@ -96,7 +96,7 @@
#
# Read build files from sub-directories
#
-subdirs = [ 'lib', 'include', 'test' ]
+subdirs = [ 'lib', 'include' ]
if get_option('utils') and not platform.endswith('bsd') and platform != 'dragonfly'
subdirs += [ 'util', 'doc' ]
endif