libarchive: bump to 3.7.1

This commit is contained in:
Chongyun Lee 2023-07-30 13:18:51 +08:00 committed by Uchiha Kakashi
parent 1b6689e934
commit bd2b7b97a6
3 changed files with 2 additions and 33 deletions

View File

@ -1,18 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -1417,6 +1417,7 @@
bsdcat_test_LDADD=libarchive_fe.la
cat/test/list.h: Makefile
+ $(MKDIR_P) cat/test
cat $(top_srcdir)/cat/test/test_*.c | grep '^DEFINE_TEST' > cat/test/list.h
if BUILD_BSDCAT
@@ -1520,6 +1521,7 @@
bsdunzip_test_LDADD=libarchive_fe.la
unzip/test/list.h: Makefile
+ $(MKDIR_P) unzip/test
cat $(top_srcdir)/unzip/test/test_*.c | grep '^DEFINE_TEST' > unzip/test/list.h
if BUILD_BSDUNZIP

View File

@ -1,13 +0,0 @@
--- a/unzip/bsdunzip.c
+++ b/unzip/bsdunzip.c
@@ -694,8 +694,10 @@
if (symlink(linkname, *path) != 0)
error("symlink('%s')", *path);
info(" extracting: %s -> %s\n", *path, linkname);
+#ifdef HAVE_LCHMOD
if (lchmod(*path, mode) != 0)
warning("Cannot set mode for '%s'", *path);
+#endif
/* set access and modification time */
if (utimensat(AT_FDCWD, *path, ts, AT_SYMLINK_NOFOLLOW) != 0)
warning("utimensat('%s')", *path);

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.libarchive.org/
TERMUX_PKG_DESCRIPTION="Multi-format archive and compression library"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="3.7.0"
TERMUX_PKG_VERSION="3.7.1"
TERMUX_PKG_SRCURL=https://github.com/libarchive/libarchive/releases/download/v$TERMUX_PKG_VERSION/libarchive-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=d937886a14b48c4287c4d343644feb294a14b31b7926ba9a4f1777123ce7c2cc
TERMUX_PKG_SHA256=5d24e40819768f74daf846b99837fc53a3a9dcdf3ce1c2003fe0596db850f0f0
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="libbz2, libiconv, liblzma, libxml2, openssl, zlib"
TERMUX_PKG_BREAKS="libarchive-dev"