libzthread: Remove package

This package was last updated in 2005, and contain really old code
which is no longer used.

As no termux package depends on it, and it fails to build with android
ndk 26 (https://github.com/termux/termux-packages/pull/17863), let's
remove it instead of trying to maintain it for little value.
This commit is contained in:
Fredrik Fornwall 2023-10-02 14:15:51 +02:00 committed by Henrik Grimler
parent 68661d9ea0
commit bea729df53
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
3 changed files with 0 additions and 66 deletions

View File

@ -1,24 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://zthread.sourceforge.net/
TERMUX_PKG_DESCRIPTION="An advanced object-oriented, cross-platform, C++ threading and synchronization library"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_LICENSE_FILE="LICENSE"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.3.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/zthread/ZThread-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=950908b7473ac10abb046bd1d75acb5934344e302db38c2225b7a90bd1eda854
TERMUX_PKG_DEPENDS="libc++"
termux_step_post_get_source() {
termux_download \
"https://github.com/gentoo/gentoo/raw/ae61075e7fb307c5f13810963099df88f99df426/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff" \
$TERMUX_PKG_CACHEDIR/zthread-2.3.2-no-fpermissive-r1.diff \
ac0acd39a1122887c7d62efd078b9649a8f010ce48305c1d225fc81b8452a511
cat $TERMUX_PKG_CACHEDIR/zthread-2.3.2-no-fpermissive-r1.diff | patch --silent -p1
}
termux_step_pre_configure() {
autoreconf -fi -Ishare
LDFLAGS+=" $($CC -print-libgcc-file-name)"
}

View File

@ -1,10 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -70,7 +70,6 @@
AM_ENABLE_ATOMIC_LINUX
AM_ENABLE_ATOMIC_GCC
-AM_DETECT_FTIME
dnl Setup compiler/linker options based on the target type

View File

@ -1,32 +0,0 @@
https://bugs.launchpad.net/hugin/+bug/1213585
https://bugs.debian.org/667430
--- a/include/zthread/Guard.h
+++ b/include/zthread/Guard.h
@@ -108,7 +108,7 @@
}
template <class LockType>
- static void createScope(LockHolder<LockType>& l, unsigned long ms) {
+ static bool createScope(LockHolder<LockType>& l, unsigned long ms) {
if(Scope1::createScope(l, ms))
if(!Scope2::createScope(l, ms)) {
@@ -428,7 +428,7 @@
template <class U, class V>
Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
- LockingPolicy::shareScope(*this, extract(g));
+ LockingPolicy::shareScope(*this, this->extract(g));
}
@@ -458,7 +458,7 @@
template <class U, class V>
Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
- LockingPolicy::transferScope(*this, extract(g));
+ LockingPolicy::transferScope(*this, this->extract(g));
}